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1 Getting Started

Product Overview
Simulink® Verification and Validation™ automates requirements tracing,
modeling standards compliance checking, and test-harness generation.

You can create detailed requirements traceability reports, author your
own modeling style checks, and develop check configurations to share with
engineering teams. Requirements documentation can be linked to models,
test cases, and generated code. You can generate harness models for testing
model components and code before the complete system becomes available.

Simulink Verification and Validation provides modeling standards checks
for the DO-178B and IEC 61508 industry standards. Additional support is
available through DO Qualification Kit and IEC Certification Kit.
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Key Features

Key Features
• Compliance checking for MAAB style guidelines and high-integrity system
design guidelines (DO-178B and IEC-61508)

• Model Advisor Configuration Editor, including custom check authoring

• Requirements Management Interface for traceability of model objects, code,
and tests to requirements documents

• Automatic test-harness generation for subsystems

• Component testing via simulation, software-in-the-loop (SIL), and
processor-in-the-loop (PIL)

• Programmable scripting interface for automating compliance checking,
requirements traceability analysis, and component testing
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1 Getting Started

System Requirements

In this section...

“Operating System Requirements” on page 1-4

“Product Requirements” on page 1-4

Operating System Requirements
The Simulink Verification and Validation software works with the following
operating systems:

• Microsoft® Windows® XP, Windows Vista™, and Windows 7

• UNIX® systems (Requirements linking to HTML and TXT documents only)

Product Requirements
The Simulink Verification and Validation software requires the following
MathWorks® products:

• MATLAB®

• Simulink®

If you want to use the Requirements Management Interface with Stateflow®

charts, the Simulink Verification and Validation software requires the
following MathWorks product:

• Stateflow

The Requirements Management Interface in the Simulink Verification and
Validation software allows you to associate requirements with Simulink
models and Stateflow charts. The software supports the following applications
for documenting requirements:

• Microsoft Word 2003 or later

• Microsoft® Excel® 2003 or later

• IBM® Rational® DOORS® 6.0 or later
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System Requirements

• Adobe® PDF
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Requirements Linking and
Traceability

• Chapter 2, “Working with the Requirements Management Interface”

• Chapter 3, “QuickStart: Linking to Requirements Using
Selection-Based Linking”

• Chapter 4, “Creating and Managing Requirements Links”

• Chapter 5, “Reviewing Requirements Information in a Model”

• Chapter 6, “Keeping Requirements Information Up to Date”

• Chapter 7, “Synchronizing a Simulink Model with a DOORS
Surrogate Module”

• Chapter 8, “Adding Navigation Objects to IBM Rational DOORS
Requirements”

• Chapter 9, “Adding Navigation Controls to Microsoft Office
Documents”

• Chapter 10, “Creating Custom Types of Requirements Documents”

• Chapter 11, “Creating Navigation Interfaces in Requirements
Documents”

• Chapter 12, “Including Requirements Information with Generated
Code”
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Working with the
Requirements Management
Interface

• “Linking to Requirements with the Requirements Management Interface
(RMI)” on page 2-2

• “What Is a Requirements Link?” on page 2-3

• “Supported Requirements Document Types” on page 2-4

• “Supported Model Objects for Requirements Linking” on page 2-7

• “Configuring the Requirements Management Interface (RMI)” on page 2-8



2 Working with the Requirements Management Interface

Linking to Requirements with the Requirements
Management Interface (RMI)

Using the Requirements Management Interface (RMI), you can link Simulink
and Stateflow objects to locations in requirements documents.

Use the RMI to:

• Associate Simulink and Stateflow objects with requirements.

• Navigate from a Simulink or Stateflow object to requirements.

• Navigate from an embedded link in a requirements document to the
corresponding Simulink or Stateflow object.

• Review requirements links in your model using highlighting and tags that
you define.

• Create reports for your Simulink model that show which objects link to
which requirements.
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What Is a Requirements Link?

What Is a Requirements Link?
Requirements links are inserted into Simulink models that allow you to
navigate from the model to a location inside a requirements document.

Requirements links have the following attributes:

• A description of up to 255 characters.

• A requirements document path name, such as a Microsoft Word file or
a module in an IBM Rational DOORS database. (The RMI supports
several built-in document formats; you can also register custom types of
requirements documents. See “Supported Requirements Document Types”
on page 2-4.)

• A designated location inside the requirements document, such as:

- Bookmark

- Anchor

- ID

- Page number

- Line number

- Cell range

- Link target

- Tags that you define
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2 Working with the Requirements Management Interface

Supported Requirements Document Types
The following table lists the supported requirements document types. For
each document type, it lists the options for requirements locations within
the document.

Requirements
Document
Type

Location Options

Microsoft
Word
document

• Search text — A search string. The RMI links to the
first occurrence of that string in the document. This
search is not case sensitive.

• Named item— A bookmark name. The RMI links to the
location of that bookmark in the document.

• Page/item number— A page number. The RMI links to
the top of the specified page.

Microsoft
Excel
workbook

• Search text — A search string. The RMI links to the
first occurrence of that string in the workbook. This
search is not case sensitive.

• Named item — A named range of cells. The RMI links
to that named item in the workbook.

• Sheet range— A cell location in a workbook:

- Cell number (A1, C13)

- Range of cells (C5:D7)

- Range of cells on another worksheet (Sheet1!A1:B4)

The RMI links to that cell or cells.

IBM Rational
DOORS
database

Page/item number— The unique numeric ID of the target
DOORS object. The RMI links to that object.

MuPAD®

notebook
Named item — The name of a link target in a MuPAD
notebook.
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Supported Requirements Document Types

Requirements
Document
Type

Location Options

Simulink
DocBlock block
(RTF format
only)

Create links to the RTF file associated with the DocBlock
block as you would to a Microsoft Word file:

• Search text — A search string. The RMI links to the
first occurrence of that string in the document. This
search is not case sensitive.

• Named item— A bookmark name. The RMI links to the
location of that bookmark in the document.

• Page/item number— A page number. The RMI links to
the top of that page.

Text document • Search text — A search string. The RMI links to the
first occurrence of that string within the document.
This search is not case sensitive.

• Line number — A line number. The RMI links to the
beginning of that line.

HTML file You can link only to a named anchor.

For example, in your HTML requirements document, if
you define the anchor

<A NAME=valve_timing> ...contents... </A>

in the Location field, enter valve_timing or, from the
document index, choose the anchor name.
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Requirements
Document
Type

Location Options

PDF file • Named item— A bookmark name. The RMI links to the
location of that bookmark in the document.

• Page/item number— A page number. The RMI links to
the top of that page.

Note The RMI cannot create a document index of
bookmarks in PDF files.

Web browser
URL

The RMI can link to a URL location. In the Document
field, type the URL string. When you click the link, the
document opens in a Web browser:

• Named item— An anchor name. The RMI links to that
location on the Web page at that URL.

If you register custom types of requirements documents, the RMI supports
those types of documents. For more information, see Chapter 10, “Creating
Custom Types of Requirements Documents”.
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Supported Model Objects for Requirements Linking
You can create requirements links in a Simulink model to the following
types of objects:

• Simulink block diagrams

• Simulink blocks, including library-linked blocks and subsystems

• Signal Builder signal groups

• Stateflow charts, subcharts, states, transitions, and boxes

• Stateflow functions
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Configuring the Requirements Management Interface
(RMI)

To use the features of the Requirements Management Interface (RMI), you
must communicate with external software products like Microsoft Office and
IBM Rational DOORS.

Before you start using RMI, run this command:

rmi setup

This command:

• Registers ActiveX® controls that are used for navigation from Microsoft
Office documents to Simulink models.

• If you have DOORS installed on your system, installs the required API files
to allow communication with the DOORS application.

If the rmi setup command fails to detect a DOORS installation on your
system, and you know that the DOORS software is installed, enter the
following command:

rmi setup doors

This command prompts you to enter the path to your DOORS installation,
and then installs the required files.
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What Is Selection-Based Linking?
You can use selection-based linking to create links from a model object
to a currently selected section or object in a requirements document.
Selection-based linking is the easiest way to create requirements links from a
model to an external document when you know exactly what text you want to
link to.

If you need to search the document or link to a specific bookmark or other
designated location in the requirements document, follow the instructions in
Chapter 4, “Creating and Managing Requirements Links”.
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Basic Workflow for Creating a Link Using Selection-Based
Linking

Using any model and a requirements document of your own, create a link
from the model to the document using selection-based linking:

1 In a requirements document, select text or objects to link to.

2 Right-click the model object and select Requirements and then the option
that correspond to the three types of requirements documents for which
selection-based linking is available:

• Add link to Word selection

• Add link to active Excel cell

• Add link to current DOORS object

Linking Multiple Model Objects to a Requirement
You can use the same technique to link multiple Simulink and Stateflow
objects to requirements in any type of requirements document that the RMI
supports. The workflow for linking to multiple model objects is as follows:

1 In the requirements document, select the requirement.

2 In the model window, select all the objects to link to that requirement.

3 Right-click one of the selected objects and select the selection-based linking
option that corresponds to your requirements document.
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Example: Linking to Requirements in Microsoft Word
Documents

In this section...

“Opening the Demo Model and Associated Requirements Document” on
page 3-4

“Creating a Link from a Model Object to a Microsoft Word Requirements
Document” on page 3-4

“Creating Bookmarks in a Microsoft Word Requirements Document” on
page 3-7

This example describes how to create links from objects in a Simulink model
to selected requirements text in a Microsoft Word document.

Opening the Demo Model and Associated
Requirements Document
Navigate from the model to the requirements document:

1 Open the demo model:

slvnvdemo_fuelsys_officereq

2 Open a requirements document associated with that model:

rmi('view','slvnvdemo_fuelsys_officereq',1);

Keep the demo model and the requirements document open.

Creating a Link from a Model Object to a Microsoft
Word Requirements Document
Create a link from the Airflow calculation subsystem in the
slvnvdemo_fuelsys_officereq model to selected text in the requirements
document:

1 In slvnvdemo_FuelSys_DesignDescription.docx, find the section titled
2.2 Determination of pumping efficiency.
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2 Select the header text.

3 Open the demo model:

slvnvdemo_fuelsys_officereq

4 Open the fuel rate controller subsystem by double-clicking it,

5 Open the Airflow calculation subsystem.

6 Right-click the Pumping Constant block and select Requirements > Add
link to Word selection.

The RMI inserts a bookmark at that location in the requirements document
and assigns it a generic name, in this case, Simulink_requirement_item_7.

7 To verify that the link was created correctly, select
Tools > Requirements > Highlight model.

The Pumping Constant block, and other blocks with requirements links,
are highlighted.

8 To navigate the link, right-click the Pumping Constant block and select
Requirements > 1. “Determination of pumping efficiency”.

The section 2.2 Determination of pumping efficiency is displayed,
selected in the requirements document.

Keep the demo model and the requirements document open.

Viewing Link Details
To view the details of the link you just created, right-click the Pumping
Constant block and select Requirements > Edit/Add Links.

The Requirements dialog box opens.
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This dialog box contains the following information the link you just created:

• Description of the link, which for selection-based links, matches the text
of the selected requirements document, in this case Determination of
pumping efficiency.

• Name of the requirements document, in this case
slvnvdemo_FuelSys_DesignDescription.docx.
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• Document type, in this case, Microsoft Word.

• The type and identifier of the location in the requirements document. With
selection-based linking for Microsoft Word requirements documents, the
RMI creates a bookmark in the requirements document. For this link, the
RMI created a bookmark named Simulink_requirement_item_7.

If you do not want the RMI to modify the Microsoft Word requirements
document when it creates links, create bookmarks in your Microsoft
Word file, as described in “Creating Bookmarks in a Microsoft Word
Requirements Document” on page 3-7.

• User tag, a user-defined keyword. This link does not have a user tag.

Note For more information about user tags, see “Filtering Requirements”
on page 5-23

Creating Bookmarks in a Microsoft Word
Requirements Document
You can create bookmarks in your Microsoft Word requirements documents
to identify the requirements you want to link to. When you create the links,
you specify that the RMI link to an existing bookmark, rather than create a
new bookmark.

This approach offers several advantages:

• You can give the bookmarks meaningful names that represent the content
of the requirement.

• The RMI does not modify your requirements document when it creates
links.

If you have a requirements document that contains bookmarks for
requirements, to link from a Simulink model to bookmarks that represent
requirements, follow these steps:

1 Open your model.
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2 Open your Microsoft Word requirements document that has bookmarks
that identify requirements.

3 Right-click a block in the model that you want to link to a requirement and
select Requirements > Edit/Add Links

The Requirements dialog box opens.

4 Click New.

5 Click Browse and navigate to the Microsoft Word requirements document
that has bookmarks.

6 Open the document. The RMI populates the Document and Document
type fields.

7 Click the Document Index tab of the Requirements dialog box.

The Document Index tab lists all bookmarks in the requirements
document, as well as all section headings (text that you have styled as
Heading 1, Heading 2, and so on).

The following graphic is an example of a document index that lists the
bookmarks in a requirements document. The document index lists the
bookmarks in alphabetical order, not in order of location within the
document.
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8 Select the bookmark that you want to link the block to and click OK.

The RMI creates a link from the block to the location of the bookmark in
the requirements document without modifying the document itself.
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Example: Linking to Requirements in IBM Rational DOORS
Databases

This example describes how to create links from objects in a Simulink model
to requirements in an IBM Rational DOORS database.

1 Open a DOORS formal module.

2 Click to select one of the requirement objects.

3 Open the demo model:

sldemo_fuelsys

4 Open the fuel_rate_control subsystem.

5 Right-click the airflow_calc subsystem and select Requirements > Add
link to current DOORS object.

6 To confirm the requirement link, right-click the airflow_calc subsystem and
select Requirements. In the submenu, the top item is the heading text
for the DOORS requirement object.
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Note You can view a demo of using the RMI with an IBM Rational DOORS
database, run the Managing Requirements for Fault-Tolerant Fuel Control
System (IBM Rational DOORS) demo.
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Linking Multiple Model Objects to a Requirement
You can use the same technique to link multiple Simulink and Stateflow
objects to a requirement. The workflow is as follows:

1 In the requirements document, select the requirement.

2 In the model window, select the objects to link to that requirement.

3 Right-click one of the selected objects and select one of the selection-based
linking options:

• Add link to Word selection

• Add link to active Excel cell

• Add link to current DOORS object
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Creating Requirements Reports
To create the default requirements report for a Simulink model:

1 Open the demo model:

slvnvdemo_fuelsys_officereq

2 Make sure that your current working folder is writable.

3 In the Model Editor, select Tools > Requirements > Generate report.

If your model is large and has many requirements links, it takes a few
minutes to create the report.

A Web browser window opens with the contents of the report. The following
graphic shows the Table of Contents for the slvnvdemo_fuelsys_officereq
model.
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A typical requirements report includes:

• Table of contents

• List of tables

• Per-subsystem sections that include:

- Tables that list objects with requirements and include links to associated
requirements documents

- Graphic images of objects with requirements

- Lists of objects with no requirements

For detailed information about requirements reports, see “Creating and
Customizing a Requirements Report” on page 5-7.
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The Requirements Dialog Box

In this section...

“Creating Requirements Using the Requirements Dialog Box” on page 4-2

“Requirements Tab” on page 4-3

“Document Index Tab” on page 4-4

Creating Requirements Using the Requirements
Dialog Box
The Requirements dialog box is a centralized location where you can manage
the requirements links associated with a given model object. In this dialog
box, you can:

• Create links to a single requirement from one or more model objects.

• Create links to multiple requirements from a single model object

• Create links to multiple requirements documents from the same model
object.

• Customize information about requirements links, including specifying user
tags to filter requirements highlighting and reporting.

• Delete existing requirements links.

To open the Requirements dialog box, right-click a block in a Simulink model
and select Edit/Add Links. The following graphic shows the Requirements
dialog box for the Metered Fuel block in the slvnvdemo_fuelsys_officereq
model. This block has no linked requirements.
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Requirements Tab
On the Requirements tab, you specify detailed information about the link,
including:
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• Description of the requirement (up to 255 words). If you create a link using
the document index, the name of the index location becomes the description
for the link unless a description already exists.

• Path name to the requirements document

• Document type (Microsoft Word, Microsoft Excel, IBMRationalDOORS,
MuPAD, HTML, text file, etc.)

• Location of the requirement (search text, named location, or page or item
number)

• User-specified tag or keyword

Document Index Tab
The Document Index tab is only available if you have specified a file in the
Document field on the Requirements tab. On the Document Index tab,
the RMI generates an list of locations in the specified requirements document
for the following types of requirements documents:

• Microsoft Word

• IBM Rational DOORS

• HTML files

• MuPAD

Note The RMI cannot create document indexes for PDF files.

You select the desired requirement from the document index and click OK.
The name of the index location becomes the description for the link unless
a description already exists.

If you make any changes to your requirements document, to load any newly
created locations into the document index, you must click Refresh. During
any MATLAB session, the RMI does not reload the document index unless
you click the Refresh button.
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The Requirements Dialog Box

In this section, you learn how to use the Requirements dialog box to link to
Microsoft Excel workbooks and MuPAD notebooks. You also learn how to
modify and delete existing requirements links.
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Tutorial: Managing Requirements Links to Microsoft Excel
Workbooks

In this section...

“Navigating from a Model Object to Requirements in a Microsoft® Excel
Workbook” on page 4-6

“Creating Requirements Links to the Workbook” on page 4-6

“Linking Multiple Model Objects to a Microsoft® Excel Workbook” on page
4-8

“Changing Requirements Links” on page 4-8

Navigating from a Model Object to Requirements in
a Microsoft Excel Workbook

1 Open the demo model:

slvnvdemo_fuelsys_officereq

2 Select Tools > Requirements > Highlight model to highlight the model
objects with requirements.

3 Right-click the Test inputs Signal Builder block and select
Requirements > 1. “Normal mode of operation”.

The slvnvdemo_FuelSys_TestScenarios.xlsx file opens, with the
associated cell highlighted.

Keep the demo model and Microsoft Excel requirements document open.

For information about creating requirements links in Signal Builder blocks,
see “Tutorial: Linking Signal Builder Blocks to Requirements” on page 4-13.

Creating Requirements Links to the Workbook

1 At the top level of the slvnvdemo_fuelsys_officereq model, right-click
the speed sensor block and select Requirements > Edit/Add Links.

4-6



Tutorial: Managing Requirements Links to Microsoft® Excel® Workbooks

The Requirements dialog box opens.

2 To create a requirements link, click New.

3 In the Description field, enter:

Speed sensor failure

You will link the speed sensor block to the Speed Sensor Failure
information in the Microsoft Excel requirements document.

4 When you browse and select a requirements document, the RMI stores the
document path as specified by the Document file reference option on the
Requirements Settings dialog box, Selection Linking tab. Make sure that
setting is correct for your working environment.

For information about which setting to use, see “Resolving the Document
Path” on page 6-14.

5 At the Document field, click Browse to locate and open the
slvnvdemo_FuelSys_TestScenarios.xlsx file.

The Document Type field information changes to Microsoft Excel.

6 In the workbook, the Speed sensor failure information is in cells B22:E22.
For the Location (Type/Identifier) field, select Sheet range and in the
second field, enter B22:E22. (The cell range letters are not case sensitive.)

7 Click Apply or OK to create the link.

8 To confirm that you created the link, right-click the speed sensor block and
select Requirements > 1. “Speed sensor failure”.

The workbook opens, with cells B22:E22 highlighted.

Keep the demo model and Microsoft Excel requirements document open.

4-7



4 Creating and Managing Requirements Links

Linking Multiple Model Objects to a Microsoft Excel
Workbook
You can use the same technique to link multiple Simulink and Stateflow
objects to a requirement in a Microsoft Excel workbook. The workflow is as
follows:

1 In the model window, select the objects to link to a requirement.

2 Right-click one of the selected objects and selectRequirements > Edit/Add
Links.

3 When you browse and select a requirements document, the RMI stores the
document path as specified by the Document file reference option on the
Requirements Settings dialog box, Selection Linking tab. Make sure that
setting is correct for your working environment.

For information about which setting to use, see “Resolving the Document
Path” on page 6-14.

4 Use the Requirements dialog to specify information about the Microsoft
Excel requirements document, the requirement, and the link.

5 Click Apply or OK to create the link.

Changing Requirements Links

1 In the slvnvdemo_fuelsys_officereq model, right-click the MAP sensor
block and select Requirements > Edit/Add Links.

The Requirements dialog box opens displaying the information about the
requirements link.
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2 In the Description field, enter:

MAP sensor test scenario

The User tag field contains the tag test. User tags allow you to filter
requirements for highlighting and reporting.
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Note For more information about user tags, see “Filtering Requirements”
on page 5-23.

3 Click Apply or OK to save the change.

Keep the demo model open.
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Tutorial: Creating Links to MuPAD Notebooks
This example describes how to create a link from a Simulink model to a
MuPAD notebook. You use a model that simulates a nonlinear second-order
system with the van der Pol equation.

Before beginning this tutorial, create a MuPAD notebook with one or more
link targets. This tutorial uses a MuPAD notebook that includes information
about solving the van der Pol equation symbolically and numerically.

Note You must have the Symbolic Math Toolbox™ installed to open a
MuPAD notebook. For information about creating a MuPAD notebook, see
“Creating, Opening, and Saving MuPAD Notebooks”.

1 Open a demo model for the van der Pol equation:

vdp

2 Right-click a blank area of the model and selectRequirements > Edit/Add
Links.

In this tutorial, you add the requirement to the model itself, not to a
specific block in the model.

3 Click New.

4 In the Document type drop-down list, select MuPAD Notebook.

5 When you browse and select a requirements document, the RMI stores the
document path as specified by the Document file reference option on the
Requirements Settings dialog box, Selection Linking tab. Make sure that
setting is correct for your working environment.

For information about which setting to use, see “Resolving the Document
Path” on page 6-14.

6 Click Browse to navigate to the notebook that you want to use.

Use a notebook that has link targets in it.
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7 Make sure the MuPAD notebook is in a saved state. Any link targets
created since the last save do not appear in the RMI document index.

8 To list the link targets, in the Requirements dialog box, click the
Document Index tab.

This example shows two link targets.

Note These link targets are in a MuPAD notebook that was created for
the purposes of this tutorial. The Document Index tab will display only
link targets you have created in your MuPAD notebook.

9 Select a link target name and click Apply.

The Requirements tab reopens, displaying the details of the newly
created link. The link target name appears in the Description field,
unless you have previously entered a description.

10 To confirm that you created the link, right-click a blank area of the model
and select Requirement. The new link is at the top of the submenu.
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Tutorial: Linking Signal Builder Blocks to Requirements
You can create links from a signal group in a Signal Builder block to a
requirements document:

1 Open the demo model:

sf_car

2 In the sf_car model, double-click the User Inputs block.

The Signal Builder dialog box opens, displaying four groups of signals. The
Passing Maneuver signal group is the current tab. The RMI associates any
requirements links you add to the current signal group.

3 At the far-right end of the toolbar, click the Show verification settings

button . (You may need to expand the Signal Builder dialog box for this
button to become visible.)

A Requirements pane opens on the right-hand side of the Signal Builder
dialog box.

4 Place your cursor in the window, right-click, and select Edit/Add Links.

The Requirements dialog box opens.

5 Click New. In the Description field, enter User input requirements.
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6 When you browse and select a requirements document, the RMI stores the
document path as specified by the Document file reference option on the
Requirements Settings dialog box, Selection Linking tab. Make sure that
setting is correct for your working environment.

For information about which setting to use, see “Resolving the Document
Path” on page 6-14.

7 Browse to a requirements document and click Open.

8 In the Location drop-down list, select Search text to link to specified
text in the document.

9 Next to the Location drop-down list, enter User Input Requirements.

10 Click Apply to create the link.

11 To verify that the RMI created the link, in the Model Editor, select the User
Inputs block, right-click, and select Requirements.

The link to the new requirement is the top menu option.

12 Save the sf_car_linking model.

Note Links that you create in this way associate requirements information
with individual signal groups, not with the entire Signal Builder block.

In this example, switch to a different tab to link a requirement to another
signal group.
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Highlighting Requirements in a Model
You can highlight a model to see which objects in the model have links to
requirements in external documents. You highlight a model from the Model
Editor or from the Model Explorer.

In this section...

“Highlighting a Model Using the Model Editor” on page 5-2

“Highlighting a Model Using the Model Explorer” on page 5-3

Highlighting a Model Using the Model Editor
If you are working in the Model Editor and want to see which model objects
in the slvnvdemo_fuelsys_officereq model have requirements, follow
these steps:

1 Open the demo model:

slvnvdemo_fuelsys_officereq

2 Select Tools > Requirements > Highlight model.

Two types of highlighting indicate model objects with requirements:

• Yellow fill indicates objects that have requirements links for the object
itself.

• Orange outline indicates objects, such as subsystems, whose child objects
have requirements links.
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Objects that do not have requirements appear dimmed.

3 To remove the highlighting from the model, select
Tools > Requirements > Unhighlight model. Alternatively, you can
right-click anywhere in the model, and select Remove Highlighting.

While a model is highlighted, you can still manage the model and its contents
as you do normally.

Highlighting a Model Using the Model Explorer
If you are working in the Model Explorer and want to see which model objects
have requirements, follow these steps:
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1 Open the demo model:

slvnvdemo_fuelsys_officereq

2 Select View > Model Explorer.

3 To highlight the model objects with requirements, click the Highlight
items with requirements on model icon ( ).

The Model Editor window opens, and all objects in the model with
requirements are highlighted.

Note If you are running a 64-bit version of MATLAB, when you navigate to
a requirement in a PDF file, the file opens at the top of the page, not at the
bookmark location.
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Navigating to Requirements from a Model

In this section...

“Navigating from the Model Object” on page 5-5

“Navigating from a System Requirements Block” on page 5-5

Navigating from the Model Object
You can navigate directly from a model object to that object’s associated
requirement. When you take these steps, the external requirements document
opens in the appropriate application, with the requirements text highlighted:

1 Open the demo model:

slvnvdemo_fuelsys_officereq

2 Open the fuel rate controller subsystem.

3 To open the linked requirement, right-click the Airflow calculation
subsystem and select Requirements > 1. “Mass airflow estimation”.

The Microsoft Word document,
slvnvdemo_FuelSys_DesignDescription.docx, opens, with the section
2.1 Mass airflow estimation selected.

Note If you are running a 64-bit version of MATLAB, when you navigate to
a requirement in a PDF file, the file opens at the top of the page, not at the
bookmark location.

Navigating from a System Requirements Block
Sometimes you want to see all the requirements links at a given level of the
model hierarchy. In such cases, you can insert a System Requirements block
to collect all requirements links in the model or subsystem. The System
Requirements block does not list requirements links for any blocks for that
model or subsystem.
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For example, you can insert the System Requirements block at the top level of
the slvnvdemo_fuelsys_officereq model, and navigate to the requirements
using the links inside the block:

1 Open the demo model:

slvnvdemo_fuelsys_officereq

2 Select Tools > Requirements > Highlight model.

3 In the slvnvdemo_fuelsys_officereq model, open the fuel rate controller
subsystem.

The Airflow calculation subsystem has a requirements link.

4 Open the Airflow calculation subsystem.

5 Select View > Library Browser

6 On the Libraries pane, click the Simulink Verification and Validation
library.

This library contains only one block—the System Requirements block.

7 Drag a System Requirements block into the Airflow calculation subsystem.

The RMI software collects and displays any requirements links for that
subsystem.

8 Double-click 1. “Mass airflow subsystem”.

The Microsoft Word document,
slvnvdemo_FuelSys_DesignDescription.docx, opens, with the section
2.1 Mass airflow estimation selected.
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Creating and Customizing a Requirements Report

In this section...

“Creating a Default Requirements Report” on page 5-7

“Reporting on Requirements in Model Blocks” on page 5-15

“Customizing the Requirements Report” on page 5-16

“Generating Requirements Reports Using Simulink” on page 5-21

Creating a Default Requirements Report
You can generate a default report with information about all the requirements
associated with the model and its objects.

Note If the model for which you are creating a report contains Model blocks,
see “Reporting on Requirements in Model Blocks” on page 5-15.

Before you generate the report, add a requirement to a Stateflow chart to see
information the requirements report contains about Stateflow charts:

1 Open the demo model:

slvnvdemo_fuelsys_officereq

2 Open the fuel rate controller subsystem.

3 Open the Microsoft Word requirements document:

matlabroot/toolbox/slvnv/rmidemos/fuelsys_req_docs/slvnvdemo_FuelSys_RequirementsSpecification.docx

4 Create a link from the control logic Stateflow chart to a location in this
document.

5 Close the requirements document, but keep the demo model open.

To generate a default requirements report for the
slvnvdemo_fuelsys_officereq model:
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1 Select Tools > Requirements > Generate Report.

The Requirements Management Interface (RMI) searches through all the
blocks and subsystems in the model for associated requirements. The RMI
generates and displays a complete report in HTML format with the default
name requirements.html. The report contains the following content:

• “Table of Contents” on page 5-8

• “List of Tables” on page 5-9

• “Model Information” on page 5-10

• “Documents Summary” on page 5-10

• “System” on page 5-11

• “Chart” on page 5-14

Table of Contents
The Table of Contents lists the major sections of the report. There is one
System section for the top-level model and one System section for each
subsystem, Model block, or Stateflow chart.

Click a link to view information about a specific section of the model.
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List of Tables
The List of Tables includes links to navigate to each table in the report.
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Model Information
TheModel Information contains general information about the model, such
as when the model was created and when the model was last modified.

Documents Summary
The Documents Summary section lists all the requirements documents to
which objects in the slvnvdemo_fuelsys_officereq model link, along with
some additional information about each document.
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• ID — The ID—in this example, DOC1, DOC2, DOC3, and DOC4—is a
short name for the requirements documents linked from this model.

Before you generate a report, in the Settings dialog box, on the Reports
tab, if you select User document IDs in requirements tables, links with
these short names are included throughout the report when referring to a
requirements document. When you click a short name link in a report, the
requirements document associated with that document ID opens.

Select the User document IDs in requirements tables option when
your requirements documents have long path names that can clutter the
report. This option is disabled by default, as you can see in the examples
in this section.

• Document paths stored in the model — Click this link to open the
requirements document in its native application.

• Last modified— The date the requirements document was last modified.

• # links— The total number of links to a requirements document.

System
Each System section includes:

• An image of the model or model object. The objects with requirements
are highlighted.
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• A list of requirements associated with the model or model object. In
this example, click the target document name to open the requirements
document associated with the slvnvdemo_fuelsys_officereq model.

• A list of blocks in the top-level model that have requirements. In this
example, only the MAP sensor block has a requirement at the top level.
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Click the link next to Target: to open the requirements document
associated with the MAP sensor block.

The preceding table does not include these blocks in the top-level model
because:

- The fuel rate controller and engine gas dynamics subsystems are in
dedicated chapters of the report.

- The report lists Signal Builder blocks separately, in this example, in
Table 3.3.

• A list of requirements associated with each signal group in any Signal
Builder block, and a graphic of that signal group. In this example, the Test
inputs Signal Builder block in the top-level model has one signal group that
has a requirement link. Click the link under Target (document name
and location ID) to open the requirements document associated with this
signal group in the Test inputs block.
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Chart
Each Chart section reports on requirements in Stateflow charts, and includes:

• A graphic of the Stateflow chart that identifies each state

• A list of elements in the chart that have requirements.

To navigate to the requirements document associated with a chart element,
click the link next to Target.
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Reporting on Requirements in Model Blocks
If your model contains Model blocks that reference external models, the
default report does not include information about requirements in the
referenced models. To generate a report that includes requirements
information for referenced models, you must have a license for the Simulink®

Report Generator™ software. The report includes the same information and
graphics for referenced models as it does for the top-level model.

If you have a Simulink Report Generator license, take the following steps
before generating a requirements report:

1 Open the model for which you want to create a requirements report.

2 To open the template for the default requirements report, at the MATLAB
command prompt, enter

setedit requirements
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3 In the Simulink Report Generator software window, in the far-left pane,
click the Model Loop component.

4 On the far-right pane, locate theModel reference field. If you cannot see
the drop-down arrow for that field, expand the pane.

5 In the Model reference field drop-down list, select Follow all model
reference blocks.

6 To generate a requirements report for the open model that includes
information about referenced models, click the Report icon .

Customizing the Requirements Report
The Requirements Management Interface (RMI) uses the Simulink Report
Generator software to generate the requirements report. You can customize
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the requirements report using the RMI or using the Simulink Report
Generator software:

• “Customizing a Requirements Report Using the RMI Settings” on page 5-17

• “Customizing the Report Using the Simulink® Report Generator Software”
on page 5-19

Customizing a Requirements Report Using the RMI Settings
To customize the requirements report using the RMI settings:

1 In the Model Editor, select Tools > Requirements > Settings.

The Requirements Settings dialog box opens.

2 Click the Report tab.
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In the Requirements Settings dialog box, you select options that specify the
contents that you want in the report.

Requirements Settings Report
Option

Description

Highlight the model before
generating report

Enables highlighting of Simulink
objects with requirements in the
report graphics.

Show user tags for each
reported link

Lists the user tags, if any, for each
reported link.
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Requirements Settings Report
Option

Description

Use document IDs in
requirements tables

Uses a document ID, if available,
instead of a path name in the
tables of the requirements report.
This capability prevents long path
names to requirements documents
from cluttering the report tables.

Report objects with no links to
requirements

Includes hypertext links from the
report to model objects that have
no requirements.

Include links to objects Includes hypertext links from the
report to model objects that have
requirements.

3 For this example, select the following options:

• Highlight the model before generating the report — Before
generating the report, the RMI highlights all objects with requirements
in the Model Editor. In addition, the graphics of the model in the report
are highlighted.

• Show user tags for each reported link — The report lists the user
tags (if any) associated with each requirement.

4 To close the selected options and close the Requirements Settings dialog
box, click Close.

5 Generate a new requirements report by selecting
Tools > Requirements > Generate Report.

Customizing the Report Using the Simulink Report Generator
Software
If you have a license for the Simulink Report Generator software, you can
further modify the default requirements report.

At the MATLAB command prompt, enter the following command:

setedit requirements
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The Report Explorer GUI opens the requirements report template that the
RMI uses when generating a requirements report. The report template
contains Simulink Report Generator components that define the structure
of the requirements report.

If you click a component in the middle pane, the options you can specify for
that component appear in the right-hand pane. For detailed information
about using a particular component to customize your report, click Help at
the bottom of the right-hand pane.

In addition to the standard report components, Simulink Report Generator
provides components specific to the RMI in the Requirements Management
Interface category.

Simulink Report Generator
Component

Report Information

Missing Requirements Block
Loop

Applies all child components to
blocks that have no requirements

Missing Requirements System
Loop

Applies all child components to
systems that have no requirements

Requirements Block Loop Applies all child components to
blocks that have requirements

Requirements Documents Table Inserts a table that lists
requirements documents

Requirements Signal Loop Applies all child components to
signal groups with requirements

Requirements Summary Table Inserts a property table that lists
requirements information for blocks
with associated requirements

Requirements System Loop Applies all child components to
systems with requirements

Requirements Table Inserts a table that lists system and
subsystem requirements

To customize the requirements report, you can:
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• Add or delete components.

• Move components up or down in the report hierarchy.

• Customize components to specify how the report presents certain
information.

For more information, see Simulink Report Generator User’s Guide.

Generating Requirements Reports Using Simulink
When you have a model open in Simulink, the Model Editor provides two
options for creating requirements reports:

• “System Design Description Report” on page 5-21

• “Design Requirements Report” on page 5-22

System Design Description Report
The System Design Description report describes a system design represented
by the current Simulink model.

You can use the System Design Description report to:

• Review a system design without having the model open.

• Generate summary and detailed descriptions of the design.

• Assess compliance with design requirements.

• Archive the system design in a format independent of the modeling
environment.

• Build a customized version of the report, using the Simulink Report
Generator software.

To generate System Design Description report that includes requirements
information:

1 Open the model for which you want to create a report.

2 Select File > Reports > System Design Description.
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The Design Description dialog box for the current model opens.

3 In the Design Description dialog box, select Requirements traceability.

4 Select other options for this report as desired.

5 Click Generate.

While the software is generating the report, the status appears in the
MATLAB command window.

The report name is the model name, followed by a numeral, followed by the
extension that reflects the document type (.pdf, .html, etc.).

If your model has linked requirements, the report includes a chapter
Requirements Traceability that includes:

• Lists of model objects that have requirements with hyperlinks to display
the objects

• Images of each subsystem, highlighting model objects with requirements

Design Requirements Report
In the Model Editor, the menu option File > Reports > Design
Requirements creates a requirements report, as described in “Creating a
Default Requirements Report” on page 5-7. This menu option is equivalent
to Tools > Requirements > Generate report.

To specify options for the report, select Tools > Requirements > Settings
and set the desired options on the Report tab before generating the
report. For detailed information about these options, see “Customizing the
Requirements Report” on page 5-16.
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Filtering Requirements

In this section...

“Filtering Requirements with User Tags” on page 5-23

“Applying a User Tag to a Requirement” on page 5-23

“Filtering, Highlighting, and Reporting with User Tags” on page 5-25

“Applying User Tags During Selection-Based Linking” on page 5-27

“Configuring Requirements Filtering” on page 5-29

Filtering Requirements with User Tags
User tags are user-defined keywords that you associate with specific
requirements. With user tags, you can highlight a model or generate a
requirements report for a model:

• Highlight or report only those requirements that have a specific user tag

• Highlight or report only those requirements that have one of several user
tags

• Do not highlight and report requirements that have a specific user tag

Applying a User Tag to a Requirement
Apply one or more user tags to a newly created requirement:

1 Open the demo model:

slvnvdemo_fuelsys_officereq

2 Open the fuel rate controller subsystem.

3 To open the requirements document, right-click the Airflow calculation
subsystem and select Requirements > Edit/Add links.

The Requirements dialog box opens, with the details about the requirement
that you created.
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4 In the User tag field, enter one or more keywords, separated by commas,
that the RMI can use to filter requirements. In this example, after design,
enter a comma, followed by the user tag test to specify a second user tag
for this requirement.

User tags:

• Are not case sensitive.
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• Can consist of multiple words. If, for example, you enter design
requirement, the entire phrase constitutes the user tag. Separate user
tags with commas.

5 Click Apply or OK to save the changes.

Filtering, Highlighting, and Reporting with User Tags
The slvnvdemo_fuelsys_officereq model includes several requirements
with the user tag design. This section describes how to highlight only those
model objects that have the user tag, test:

1 In the Model Editor, remove any highlighting from
the slvnvdemo_fuelsys_officereq model by selecting
Tools > Requirements > Unhighlight model.

2 Select Tools > Requirements > Settings.

The Requirements Settings dialog box opens.

3 Click the Filters tab.
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4 To enable filtering with user tags, click the Filter links by user tags
when highlighting and reporting requirements option.

5 To include only those requirements that have the user tag, test, enter
test in the Include links with any of these tags field.

6 Click Close.

7 In the Model Editor, select Tools > Requirements > Highlight model.

The RMI highlights only those model objects whose requirements have the
user tag test, for example, the MAP sensor.

8 Reopen the Requirements Settings dialog box to the Filters tab.
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9 In the Include links with any of these tags field, delete test. In the
Exclude links with any of these tags field, add test.

In the model, the highlighting changes to exclude objects whose
requirements have the test user tag; the MAP sensor and Test inputs
blocks are no longer highlighted.

10 In the Model Editor, select Tools > Requirements > Generate Report.

The report does not include information about objects whose requirements
have the test user tag.

Applying User Tags During Selection-Based Linking
When creating a succession of requirements links, you can apply the
same user tags to all links automatically. This capability, also known as
selection-based linking, is available only when you are creating links to
selected objects in the requirements documents.

When creating selection-based links, specify one or more user tags to apply
to requirements:

1 In the Model Editor, select Tools > Requirements > Settings.

2 Select the Selection Linking tab.
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3 In the Apply this user tag to new links field, enter one or more user
tags, separated by commas.

The RMI applies these user tags to all selection-based requirements links
that you create.

4 Click Close to close the Requirements Settings dialog box.

5 In a requirements document, select the desired requirement text.

6 Right-click a model object and select Requirements.

The selection-based linking options specify which user tags the RMI applies
to the link that you create. In the following example, you can apply the user
tags design and review to the link that you create to your selected text.
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Configuring Requirements Filtering
In the Requirements Settings dialog box, the Filters tab has the following
options for filtering requirements in a model.
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Option Description

Filter links by user tags when
highlighting and reporting
requirements

Enables filtering for highlighting
and reporting, based on specified
user tags.

Include links with any of these
tags

Includes information about all
requirements that have any of
the specified user tags. Separate
multiple user tags with commas.

Exclude links with any of these
tags

Excludes information about all
requirements that have any of
the specified user tags. Separate
multiple user tags with commas or
spaces.

Apply same filters in context
menus

Disables link labels in context
menus if any of the specified filters
are satisfied, for example if a
requirement has a designated user
tag.

Apply same filters in consistency
checking

Includes or excludes requirements
with specified user tags when
running a consistency check
between a model and its associated
requirements documents.

Under Link type filters, Disable
DOORS surrogate item links in
context menus

Disables links to IBM Rational
DOORS surrogate items from the
context menus when you right-click
a model object. This option does not
depend on current user tag filters.
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Checking Requirements Links
Requirements links in a model can become outdated when requirements
change over time. Similarly, links in requirements documents may become
invalid when your Simulink model changes, for example, when the model, or
objects in the model, are renamed, moved, or deleted.

The Simulink Verification and Validation software provides tools that allow
you to detect and resolve these problems in the model or in the requirements
document.

In this section...

“Checking and Fixing Requirements Links in a Simulink Model” on page 6-2

“Checking and Fixing Links in Requirements Documents” on page 6-9

Checking and Fixing Requirements Links in a
Simulink Model

• “Checking Requirements Links” on page 6-2

• “Fixing Inconsistent Links” on page 6-5

Checking Requirements Links
To make sure that every requirements link in your Simulink model has a valid
target in a requirements document, run the Model Advisor Requirements
consistency checks:

1 Open the demo model:

slvnvdemo_fuelsys_officereq

2 Open the Model Advisor to run a consistency check by selecting
Tools > Requirements > Consistency checking.

In the Requirement consistency checking category, all the checks are
selected. For this tutorial, keep all the checks selected.
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These checks identify the following problems with your model requirements.

Consistency Check Problem Identified

Identify requirement links with missing
documents

The Model Advisor cannot find the
requirements document.

Identify requirement links that specify
invalid locations within documents

The Model Advisor cannot find the designated
location in the requirement document.

Identify selection-based links having
description fields that do not match their
requirements document text

The Description field for the link does
not match the requirements document text.
When you create selection-based links, the
Requirements Management Interface (RMI)
saves the selected text in the link Description
field.

Identify requirement links with path type
inconsistent with preferences

The path for the requirements document does
not match the Document file reference
field in the Requirements Settings dialog box
Selection Linking tab.

On Linux® systems, this check is named
Identify requirement links with absolute
path type. The check reports a warning for
each requirements links that uses an absolute
path.

Note For information about how the RMI
resolves the path to the requirements
document, see “Resolving the Document Path”
on page 6-14.
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The Model Advisor checks to see if any applications that have link targets
are running:

• If your model has links to Microsoft Word or Microsoft Excel documents,
the consistency check requires that you close all instances of those
applications. If you have one of these applications open, it displays a
warning and does not continue the checks. The consistency checks must
verify up-to-date stored copies of the requirements documents.

• If your model has links to DOORS requirements, you must be logged
in to the DOORS software. Your DOORS database must include the
module that contains the target requirements.

3 For this tutorial, make sure that you close both Microsoft Word and
Microsoft Excel.

4 Click Run Selected Checks.

After the check is complete:

• The green circles with the check mark indicate that two checks passed.

• The yellow triangles with the exclamation point indicate that two checks
generated warnings.

The right-hand pane shows that two checks passed and two checks had
warnings. The pane includes a link to the HTML report.
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Keep the Model Advisor open. The next section describes how to interpret
and fix the inconsistent links.

Note To view a demo that uses the Model Advisor to check requirements
links in an IBM Rational DOORS database, run the Managing Requirements
for Fault-Tolerant Fuel Control System (IBM Rational DOORS) demo.

Fixing Inconsistent Links
In “Checking and Fixing Requirements Links in a Simulink Model” on
page 6-2, three requirements consistency checks generate warnings in the
slvnvdemo_fuelsys_officereq model.

• “Resolve Warning: Identify requirement links that specify invalid locations
within documents” on page 6-5

• “Resolve Warning: Identify selection-based links having description fields
that do not match their requirements document text” on page 6-7

Resolve Warning: Identify requirement links that specify invalid
locations within documents. To fix the warning about attempting to link
to an invalid location in a requirements document:

1 In the Model Advisor, select Identify requirement links that specify
invalid locations within documents to display the description of the
warning.
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This check identifies a link that specifies a location that
does not exist in the Microsoft Word requirements document,
slvnvdemo_FuelSys_DesignDescription.docx. The link originates in the
Terminator1 block. In this example, the target location in the requirements
document was deleted after the requirement was created.

2 Get more information about this link:

a To navigate to the Terminator1 block, under Block, click the hyperlink.

b To open the Requirements dialog box for this link, underRequirements,
click the hyperlink.

3 To fix the problem from the Requirements dialog box, do one of the
following:

• In the Location field, specify a valid location in the requirements
document.

• Delete the requirements link by selecting the link and clicking Delete.

4 In the Model Advisor, select the Requirement consistency checking
category of checks.

5 Click Run Selected Checks again, and verify that the warning no longer
occurs.
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Resolve Warning: Identify selection-based links having description
fields that do not match their requirements document text. To fix
the warnings about the Description field not matching the requirements
document text:

1 In the Model Advisor, click Identify selection-based links having
description fields that do not match their requirements document
text to display the description of the warning.
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The first message indicated that the model contains a link to a bookmark
named Simulink_requirement_item_7 in the requirements document
that does not exist.

In addition, this check identified the following mismatching text between
the requirements blocks and the requirements document:

• The Description field in the Test inputs Signal Builder block link is
Normal mode of operation. The requirement text is The simulation
is run with a throttle input that ramps from 10 to 20 degrees over
a period of two seconds, then back to 10 degrees over the next
two seconds. This cycle repeats continuously while the engine is
held at a constant speed.

• The Description field in the MAP Estimate block link
is Manifold pressure failure. The requirement text in
slvnvdemo_FuelSys_DesignDescription.docx is Manifold pressure
failure mode.

2 Get more information about this link:

a To navigate to a block, under Block, click the hyperlink.

b To open the Requirements dialog box for this link, under Current
Description, click the hyperlink.

3 Fix this problem in one of two ways:

• In the Model Advisor, click Update. This action automatically updates
the Description field for that link so that it matches the requirement.

• In the Requirements dialog box, manually edit the link from the block so
that the Description field matches the selected requirements text.

4 In the Model Advisor, select the Requirement consistency checking
category of checks.

5 Click Run Selected Checks again, and verify that the warning no longer
occurs.
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Checking and Fixing Links in Requirements
Documents

• “When to Check Links in a Requirements Document” on page 6-9

• “How the rmi Function Checks a Requirements Document” on page 6-10

• “Checking Links in a Requirements Document” on page 6-10

• “Fixing Requirements Links in a Requirements Document” on page 6-11

When to Check Links in a Requirements Document
When you enableModify documents to include links to models (two-way
linking) and create a link between a requirement and a Simulink model
object, the RMI software inserts a navigation control into your requirements
document. These links may become invalid if your model changes.

To check these links, the 'checkDoc' option of the rmi function reviews a
requirements document to ensure that all the navigation controls represent
valid links to model objects. The rmi function can check the following types
of requirements documents:

• Microsoft Word

• IBM Rational DOORS

The rmi function only checks requirements documents that contain navigation
controls; to check links in your Simulink model, see “Checking and Fixing
Requirements Links in a Simulink Model” on page 6-2.

Note For more information about inserting navigation controls in
requirements documents, see:

• “Inserting Navigation Controls in Microsoft Office Requirements
Documents” on page 9-5

• “Inserting Navigation Objects into DOORS Requirements” on page 8-7
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How the rmi Function Checks a Requirements Document
rmi performs the following actions:

• Locates all links to Simulink objects in the specified requirements
document.

• Checks each link to ensure that the target object is present in a Simulink
model. If the target object is present, rmi checks that the link label matches
the target object.

• Modifies the navigation controls in the requirements document to identify
any detected problems. This allows you to see invalid links at a glance:

- Valid link:

- Invalid link:

Checking Links in a Requirements Document
To check the links in a requirements document:

1 At the MATLAB command prompt, enter

rmi('checkdoc', docName)

docName is a string that represents one of the following:

• Module ID for a DOORS requirements document

• Full path name for a Microsoft Word requirements document

The rmi function creates and displays an HTML report that lists all
requirements links in the document.

The report highlights invalid links in red. For each invalid link, the report
includes brief details about the problem and a hyperlink to the invalid
link in the requirements document. The report groups together links that
have the same problem.

2 Double-click the hyperlink under Document content to open the
requirements document at the invalid link.
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The navigation controls for the invalid link has a different appearance than
the navigation controls for the valid links.

3 If there invalid links in your requirements document, you have the
following options:

If you want to... Do the following...

Fix the invalid links Follow the instructions in
“Fixing Requirements Links in a
Requirements Document” on page
6-11.

Keep the changes to the navigation
controls without fixing the invalid
links

Save the requirements document.

Ignore the invalid links Close the requirements document
without saving it.

Fixing Requirements Links in a Requirements Document
Using the report that the rmi function creates, you may be able to fix the
invalid links in your requirements document.

In the following example, rmi cannot locate the model specified in two links.

To fix invalid links:

1 In the report, under Document content, click the hyperlink associated
with the invalid requirement link.
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The requirements document opens with the requirement text highlighted.

2 In the requirements document, depending on the document format, take
these steps:

• In DOORS:

a Select the navigation control for an invalid link.

b Select MATLAB > Select item.

• In Microsoft Word, double-click the navigation control.

A dialog box similar to the following opens, allowing you to fix or ignore all
the invalid links with a given problem.

3 Click one of the following options.

Click... To...

Fix all Navigate to and select a new target
model or new target objects for
these broken links.

Reset all Reset the navigation controls for
these invalid links to their original
state, the state before you checked
the requirements document.

Cancel Make no changes to the
requirements document. Any
modifications rmi made to the
navigation controls remain in the
requirements document.
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4 Save the requirements document to preserve the changes made by the
rmi function.
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Resolving the Document Path
When you create a requirements link, the RMI stores the location of the
requirements document with the link. If you use selection-based linking or
browse to select a requirements document, the RMI stores the document
location as specified by the Document file reference option on the
Requirements Settings dialog box, Selection Linking tab. The available
settings are:

• Absolute path

• Path relative to current folder

• Path relative to model folder

• Filename only (on MATLAB path)

Note For detailed information about these settings, see “Resolving the
Document Path” on page 6-14.

You can also manually enter an absolute or relative path for the document
location. A relative path can be a partial path or no path at all, but you must
specify the file name of the requirements document. If you use a relative
path, the document is not constrained to a single location in the file system.
With a relative path, the RMI resolves the exact location of the requirements
document in this order:

1 The software attempts to resolve the path relative to the current MATLAB
folder.

2 If there is no path specification and the document is not in the current
folder, the software uses the MATLAB search path to locate the file.

3 If the RMI cannot locate the document relative to the current folder or the
MATLAB search path, the RMI resolves the path relative to the model
file folder.

The following examples illustrate the procedure for locating a requirements
document.
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Relative (Partial) Path Example

Current MATLAB folder C:\work\scratch

Model file C:\work\models\controllers\pid.mdl

Document link ..\reqs\pid.html

Documents searched for
(in order)

C:\work\reqs\pid.html
C:\work\models\reqs\pid.html

Relative (No) Path Example

Current MATLAB folder C:\work\scratch

Model file C:\work\models\controllers\pid.mdl

Requirements document pid.html

Documents searched for
(in order)

C:\work\scratch\pid.html
<MATLAB path dir>\pid.html
C:\work\models\controllers\pid.html

Absolute Path Example

Current MATLAB folder C:\work\scratch

Model file C:\work\models\controllers\pid.mdl

Requirements document C:\work\reqs\pid.html

Documents searched for C:\work\reqs\pid.html
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Deleting Requirement Links from Simulink Objects

In this section...

“Deleting a Single Link from a Simulink Object” on page 6-16

“Deleting All Links from a Simulink Object” on page 6-16

“Deleting All Links from Multiple Simulink Objects” on page 6-17

Deleting a Single Link from a Simulink Object
If you have an obsolete link to a requirement, delete it from the model object.

To delete a single link to a requirement from a Simulink model object:

1 Right-click a model object and select Requirements > Edit/Add Links.

2 In the top-most pane of the Requirements dialog box, select the link that
you want to delete.

3 Click Delete.

4 Click Apply or OK to complete the deletion.

Deleting All Links from a Simulink Object
To delete all links to requirements from a Simulink model object:

1 Right-click the model object and select Requirements > Delete All Links

2 Click OK to confirm the deletion.

This action deletes all requirements at the top level of the object. For
example, if you delete requirements for a subsystem, this action does not
delete any requirements for objects inside the subsystem; it only deletes
requirements for the subsystem itself. To delete requirements for child
objects inside a subsystem, Model block, or Stateflow chart, you must
navigate to each child object and perform these steps for each object from
which you want to delete requirements.
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Deleting All Links from Multiple Simulink Objects
To delete all requirements links from a group of Simulink model objects in the
same model diagram or Stateflow chart:

1 Select the model objects whose requirements links you want to delete.

2 Right-click one of the objects and select Requirements > Delete All.

3 Click OK to confirm the deletion.

This action deletes all requirements at the top level of each object. It does
not delete requirements for any child objects inside subsystems, Model
blocks, or Stateflow charts.
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Managing Requirements in Library Blocks and Reference
Blocks

In this section...

“Introduction to Library Blocks and Reference Blocks” on page 6-18

“Library Blocks and Requirements” on page 6-18

“Copying Library Blocks with Requirements” on page 6-19

“Managing Requirements Inside Reference Blocks” on page 6-21

“Managing Requirements on Reference Blocks” on page 6-24

“Links from Requirements to Library Blocks” on page 6-25

Introduction to Library Blocks and Reference Blocks
Simulink allows you to create your own block libraries. If you create a block
library, you can reuse the functionality of a block, subsystem, or Stateflow
subchart in multiple models.

When you copy a library block to a Simulink model, the new block is called
a reference block. You can create several instances of this library block in
one or more models.

The reference block is linked to the library block using a library link. If you
change a library block, any reference block that is linked to the library block
is updated with those changes when its parent model is opened.

Note For more information about reference blocks and library links, see
“Working with Block Libraries” in the Simulink documentation.

Library Blocks and Requirements
Library blocks can have links to requirements in external requirements
documents. You use the Requirements Management Interface (RMI) to create
and manage these links.
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The following sections describe how you manage requirements links on library
blocks and reference blocks.

Copying Library Blocks with Requirements
When you copy a library block to a model, the reference block has all the
characteristics of the library block, including access to linked requirements.

You can add, modify, or delete requirements links in the library block. After
you make these changes, the next time you open the model containing the
reference block, you see the updated requirements links in the model.

For example, in the following graphic, consider the library block My
Integrator. To see the requirements links associated with My Integrator,
right-click the library block and select Requirements.
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If you copy the My Integrator block to a model, the reference block provides
access to the same requirements links. To see library block requirements
links from the reference block, right-click the reference block and select
Requirements > Library Block Requirements.
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To navigate from the reference block to the linked requirements document,
select the requirement text.

Note For more information about navigating from a block to a linked
requirement, see “Navigating to Requirements from a Model” on page 5-5.

Managing Requirements Inside Reference Blocks
If your reference block is a subsystem or a Stateflow atomic subchart, you
can create a link to a requirement from an object inside the subsystem or
subchart. You can push that new requirements link to the library block. The
link you created inside the reference block is pushed to the corresponding
block in the library block. The next time you create an instance of the library
block, the requirement you created inside the reference block is copied to
the new instance.

The workflow for this task is:

1 Within a library you have a subsystem S1. You drag S1 to a model, creating
a new subsystem. This subsystem is the reference block.
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2 You disable the library link between the reference block and the library
block. To do this, select the reference block and select Edit > Link
Options > Disable Link.

Note You cannot make any changes to a reference block without first
disabling the link to the library block.

3 Create the link from an object inside the reference block to the requirements
document.
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4 Restore the library link between the reference block and the library block:
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a Select the reference block.

b Select Edit > Link Options > Resolve Link.

c In the Action column, click Push.

d Click OK to reenable the link to the library block and push the newly
added requirement to the object inside the library block.

When you restore the library link between the library block and the
subsystem, Simulink pushes the new requirement link to the library
block S1, along with any other changes you made to the reference block.
The following graphic shows the new link from inside the library block
S1 to the requirement.
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Note If you see a message that the library is locked, you must unlock the
library before you can push the changes to the library block.

5 If you reuse S1, which now has a requirement link, in another model, the
new subsystem contains an object that has a link to the same requirement.
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Managing Requirements on Reference Blocks
You can manage requirements links on a reference block just like any other
model object, using the Requirements Management Interface capabilities.
However, you cannot add, change, or delete the requirements links on the
linked library block from the context of the reference block.

Any changes that you make to requirements associated with the reference
block are local to the reference block. They cannot be pushed to the library
block.

You can push only requirements changes that you make to objects inside a
reference block that is a subsystem or Stateflow atomic subchart, as described
in “Managing Requirements Inside Reference Blocks” on page 6-21.

For example, in the following graphic, the reference block requirements link
is Manifold absolute pressure sensor. This link is local to the reference
block. You can modify or delete this link without making changes to the
library block.

The library block requirements links are:

• Speed sensor
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• Throttle sensor

• Oxygen sensor

These links are associated with the library block. You cannot modify or delete
these links from the context of the reference block.

Links from Requirements to Library Blocks
If you have a requirement that links to a library block and you drag that
library block to a model, the requirement does not link to the reference block;
the requirement links only to the library block.

For example, consider the situation where you have established two-way
linking between a library block (B1 in the following graphic) and a
requirement.
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When you use library block B1 in a model, Simulink copies the requirement
link to the reference block. However, the link from the requirement still
points only to library block B1, not to the reference block.
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What Is Synchronization?
Synchronization is a user-initiated process that creates or updates a DOORS
surrogate module. A surrogate module is a DOORS formal module that is a
representation of a Simulink model hierarchy.

When you synchronize a model for the first time, the DOORS software
creates a surrogate module. The surrogate module contains a representation
of the model, depending on your synchronization settings. (To learn how
to customize the links and level of detail in the synchronization, see
“Customizing the Synchronization” on page 7-9.)

If you create or remove model objects or links, keep your surrogate module
up to date by resynchronizing. The updated surrogate module reflects any
changes in the requirements links since the previous synchronization.

Note The RMI and DOORS software both use the term object. In the RMI,
and in this document, the term object refers to a Simulink model or block, or
to a Stateflow chart or its contents.

In the DOORS software, object refers to numbered elements in modules. The
DOORS software assigns each of these objects a unique object ID. In this
document, these objects are referred to as DOORS objects.

You use standard DOORS capabilities to navigate between the Simulink
objects in the surrogate module and requirements in other formal modules.
The surrogate module facilitates navigation between the Simulink model
object and the requirements, as the following diagram illustrates.
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DOORS Formal Module(s) with Requirements

DOORS Surrogate Module

Objects in a Simulink Model

Requirement

Enter requirements in the DOORS formal 
module and link them to objects in the 
DOORS surrogate module, so you can 
navigate from requirements to Simulink 
objects.

A surrogate module is a representation
of a Simulink model hierarchy.
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Advantages of Synchronizing Your Model with a Surrogate
Module

Synchronizing your Simulink model with a surrogate module offers the
following advantages:

• You can navigate from a requirement to a Simulink object without
modifying the requirements modules.

• You avoid cluttering your requirements modules with inserted navigation
objects.

• The DOORS database contains complete information about requirements
links. You can review requirements links and verify traceability, even if
the Simulink software is not running.

• You can use DOORS reporting features to analyze requirements coverage.

• You can separate the requirements tracking work from the Simulink model
developers’ work, as follows:

- Systems engineers can establish requirements links to models without
using the Simulink software.

- Model developers can capture the requirements information using
synchronization and store it with the model.

• You can resynchronize a model with a new surrogate module, updating any
model changes or specifying different synchronization options.
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Tutorial: Synchronizing a Simulink Model to Create a
Surrogate Module

The first time that you synchronize your model with the DOORS software,
the DOORS software creates a surrogate module.

In this tutorial, you synchronize the sf_car model with the DOORS software.

Note Before you begin, make sure you know how to create links from
a Simulink model object to a requirement in a DOORS database. For a
tutorial on creating links to DOORS requirements, see “Example: Linking to
Requirements in IBM Rational DOORS Databases” on page 3-10.

1 To create a surrogate module, start the DOORS software and open a
project. If the DOORS software is not already running, start the DOORS
software and open a project.

2 Open the sf_car model.

3 Rename the model to sf_car_doors, and save the model in a writable
folder.

4 Create links to a DOORS formal module from two objects in sf_car_doors:

• The transmission subsystem

• The engine torque block inside the Engine subsystem

5 Save the changes to the model.

6 In the Model Editor, select Tools > Requirements > Synchronize with
DOORS.

The DOORS synchronization settings dialog box opens.

7 For this tutorial, accept the default synchronization options.

The default option under Extra mapping additionally to objects with
links, None, creates objects in the surrogate module only for the model and
any model objects with links to DOORS requirements.

7-5



7 Synchronizing a Simulink® Model with a DOORS® Surrogate Module

Note For more information about the synchronization options, see
“Customizing the Synchronization” on page 7-9.

8 Click Synchronize to create and open a surrogate module for all DOORS
requirements that have links to objects in the sf_car_doors model.

After synchronization with the None option, the surrogate module, a formal
module named sf_car_doors, contains:

• A top-level object for the model (sf_car_doors)

• Objects that represent model objects with links to DOORS requirements
(transmission, engine torque), and their parent objects (Engine).

9 Save the surrogate module and the model.
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Tutorial: Creating Links Between the Surrogate Module
and Formal Module in a DOORS Database During
Synchronization

The surrogate module is the interface between the DOORS formal module
that contains your requirements and the Simulink model. To establish links
between the surrogate module and the requirements module, copy the link
information from the model to the surrogate module:

1 Open the sf_car_doors model.

2 In the Model Editor, select Tools > Requirements > Synchronize with
DOORS.

3 In the DOORS synchronization settings dialog box, select two options:

• Update links during synchronization

• from Simulink to DOORS.

4 Click Synchronize.

The RMI creates links from the DOORS surrogate module to the formal
module. These links correspond to links from the Simulink model to the
formal module. In this example, the DOORS software copies the links from
the engine torque block and transmission subsystems to the formal module,
as indicated by the red triangles.
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Customizing the Synchronization

In this section...

“DOORS Synchronization Settings” on page 7-9

“Resynchronizing a Model with a Different Surrogate Module” on page 7-11

“Customizing the Level of Detail in Synchronization” on page 7-12

“Tutorial: Resynchronizing to Include All Simulink Objects” on page 7-13

DOORS Synchronization Settings
When you synchronize your Simulink model with a DOORS database, you can:

• Customize the level of detail for your surrogate module.

• Update links in the surrogate module or in the model to ensure consistency
of requirements links among the model, and the surrogate and formal
modules.

The DOORS synchronization settings dialog box provides the following
options during synchronization.

DOORS Settings Option Description

DOORS surrogate module path and name Specifies a unique DOORS path to a new or an
existing surrogate module.

For information about how the RMI resolves
the path to the requirements document, see
“Resolving the Document Path” on page 6-14.

Extra mapping additionally to objects
with links

Determines the completeness of the Simulink
model representation in the DOORS surrogate
module. None specifies synchronizing only
those Simulink objects that have linked
requirements, and their parent objects. For
more information about these synchronization
options, see “Customizing the Level of Detail in
Synchronization” on page 7-12.
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DOORS Settings Option Description

Update links during synchronization Specifies updating any unmatched links the
RMI encounters during synchronization, as
designated in the Copy unmatched links and
Delete unmatched links options.

Copy unmatched links During synchronization, selecting the following
options has the following results:

• from Simulink to DOORS: For links
between the model and the formal module,
the RMI creates matching links between the
DOORS surrogate and formal modules.

• from DOORS to Simulink: For links
between the DOORS surrogate and formal
modules, the RMI creates matching links
between the model and the DOORS modules.

Delete unmatched links During synchronization, selecting the following
options has the following results:

• Remove unmatched in DOORS: For links
between the formal and surrogate modules,
if there is not a corresponding link between
the model and the DOORS modules, the
RMI deletes the link in DOORS.

This option is available only if you select the
from Simulink to DOORS option.

• Remove unmatched in Simulink: For
links between the model and the DOORS
modules, if there is not a corresponding link
between the formal and surrogate modules,
the RMI deletes the link from the model.

This option is available only if you select the
from DOORS to Simulink option.
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DOORS Settings Option Description

Save DOORS surrogate module After the synchronization, saves all changes
to the surrogate module and updates the
version of the surrogate module in the DOORS
database.

Save Simulink model (recommended) After the synchronization, saves all changes to
the model. If you use a version control system,
selecting this option changes the version of the
model.

Resynchronizing a Model with a Different Surrogate
Module
You can synchronize the same Simulink model with a new DOORS surrogate
module. For example, you might want the surrogate module to contain only
objects that have requirements to DOORS, rather than all objects in the
model. In this case, you can change the synchronization options to reduce the
level of detail in the surrogate module:

1 In the DOORS synchronization settings dialog box, change the DOORS
surrogate module path and name to the path and name of the new
surrogate module in the DOORS database.

2 Specify a module with either a relative path (starting with ./) or a full
path (starting with /).

The software appends relative paths to the current DOORS project.
Absolute paths must specify a project and a module name.

When you synchronize a model, the RMI automatically updates the
DOORS surrogate module path and name with the actual full path.
The RMI saves the unique module ID with the module.

3 If you select a new module path or if you have renamed the surrogate
module, and you click Synchronize, the Requirements: Surrogate Module
Mismatch dialog box opens.
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4 Click Continue to create a new surrogate module with the new path or
name.

Customizing the Level of Detail in Synchronization
You can customize the level of detail in a surrogate module so that the module
reflects the full or partial Simulink model hierarchy.

In “Tutorial: Synchronizing a Simulink Model to Create a Surrogate
Module” on page 7-5, you synchronized the model with the Extra mapping
additionally to objects with links option set to None. As a result, the
surrogate module contains only Simulink objects that have requirement links,
and their parent objects. Additional synchronization options, described in this
section, can increase the level of surrogate detail. Increasing the level of
surrogate detail can slow down synchronization.

The Extra mapping additionally to objects with links option can have
one of the following values. Each subsequent option adds additional Simulink
objects to the surrogate module. You choose None to minimize the surrogate
size or Complete to create a full representation of your model. The Complete
option adds all Simulink objects to the surrogate module, creating a one-to-one
mapping of the Simulink model in the surrogate module. The intermediate
options provide more levels of detail.
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Drop-Down List Option Description

None (Recommended for better
performance)

Maps only Simulink objects that have requirements links
and their parent objects to the surrogate module.

Minimal - Non-empty unmasked
subsystems and Stateflow charts

Adds all nonempty Stateflow charts and unmasked
Simulink subsystems to the surrogate module.

Moderate - Unmasked subsystems,
Stateflow charts, and
superstates

Adds Stateflow superstates to the surrogate module.

Average - Nontrivial Simulink
blocks, Stateflow charts and
states

Adds all Stateflow charts and states and Simulink
blocks, except for trivial blocks such as ports, bus objects,
and data-type converters, to the surrogate module.

Extensive - All unmasked
blocks, subsystems, states and
transitions

Adds all unmasked blocks, subsystems, states, and
transitions to the surrogate module.

Complete - All blocks,
subsystems, states and
transitions

Copies all blocks, subsystems, states, and transitions to
the surrogate module.

Tutorial: Resynchronizing to Include All Simulink
Objects
This tutorial shows how you can include all Simulink objects in the DOORS
surrogate module. Before you start these steps, make sure you have
completed the tutorials “Tutorial: Synchronizing a Simulink Model to Create
a Surrogate Module” on page 7-5 and “Tutorial: Creating Links Between
the Surrogate Module and Formal Module in a DOORS Database During
Synchronization” on page 7-7.

1 Open the sf_car_doors model that you synchronized in “Tutorial:
Synchronizing a Simulink Model to Create a Surrogate Module” on page
7-5 and again in “Tutorial: Creating Links Between the Surrogate Module
and Formal Module in a DOORS Database During Synchronization” on
page 7-7.

2 In the Model Editor, select Tools > Requirements > Synchronize with
DOORS.
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The DOORS synchronization settings dialog box opens.

3 Resynchronize with the same surrogate module, making sure that the
DOORS surrogate module path and name specifies the surrogate
module path and name that you used in “Tutorial: Synchronizing a
Simulink Model to Create a Surrogate Module” on page 7-5.

For information about how the RMI resolves the path to the requirements
document, see “Resolving the Document Path” on page 6-14.

4 Update the surrogate module to include all objects in your model. To do
this, under Extra mapping additionally to objects with links, from
the drop-down list, select Complete - All blocks, subsystems, states
and transitions.

5 Click Synchronize.

After synchronization, the DOORS surrogate module for the sf_car_doors
model opens with the updates. All Simulink objects and all Stateflow
objects in the sf_car_doors model are now mapped in the surrogate
module.
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6 Scroll through the surrogate module. Notice that the objects with
requirements (the engine torque block and transmission subsystem) retain
their links to the DOORS formal module, as indicated by the red triangles.

7 Save the surrogate module.

Detailed Information About The Surrogate Module You Created
Notice the following information about the surrogate module that you created
in “Tutorial: Resynchronizing to Include All Simulink Objects” on page 7-13:
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• The name of the surrogate module is sf_car_doors, as you specified in the
DOORS synchronization settings dialog box.

• DOORS object headers are the names of the corresponding Simulink
objects.

• The Block Type column identifies each object as a particular block type
or a subsystem.

• If you delete a previously synchronized object from your Simulink model
and then resynchronize, the Block Deleted column reads true. Otherwise,
it reads false.

These objects are not deleted from the surrogate module. The DOORS
software retains these surrogate module objects so that the RMI can
recover these links if you later restore the model object.

• Each Simulink object has a unique ID in the surrogate module. For
example, the ID for the surrogate module object associated with the Mux
block in the preceding figure is 11.

• Before the complete synchronization, the surrogate module contained
the transmission subsystem, with an ID of 3. After the complete
synchronization, the transmission object retains its ID (3), but is listed
farther down in the surrogate module. This order reflects the model
hierarchy. The transmission object in the surrogate module retains the red
arrow that indicates that it links to a DOORS formal module object.
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Tutorial: Resychronizing to Reflect Model Changes
If you change your model after synchronization, the RMI does not display a
warning message. If you want the surrogate module to reflect changes to the
Simulink model, resynchronize your model.

In this tutorial, you add a new block to the sf_car_doors model, and later
delete it, resynchronizing after each step:

1 In the sf_car_doors model, make a copy of the vehicle mph (yellow) &
throttle % Scope block and paste it into the model. The name of the new
Scope block is vehicle mph (yellow) & throttle %1.

2 Select Tools > Requirements > Synchronize with DOORS.

3 In the DOORS settings dialog box, leave the Extra mapping additionally
to objects with links option set to Complete - All blocks,
subsystems, states, and transitions. Click Synchronize.

After the synchronization, the surrogate module includes the new block.

4 In the sf_car_doors model, delete the newly added Scope block and
resynchronize.

The block that you delete appears at the bottom of the list of objects in the
surrogate module. Its entry in the Block Deleted column reads True.
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5 Delete the copied object (vehicle mph (yellow) & throttle %1 and
resynchronize the model.

6 Save the surrogate module.

7 Save the sf_car_doors model.
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Navigating with the Surrogate Module

In this section...

“Navigating Between Requirements and the Surrogate Module in the
DOORS Database” on page 7-19

“Navigation Between DOORS Requirements and the Simulink Module via
the Surrogate Module” on page 7-20

Navigating Between Requirements and the Surrogate
Module in the DOORS Database
The surrogate module and the requirements in the formal module are both
in the DOORS database. When you synchronize your model, the DOORS
software creates links between the surrogate module objects and the
requirements in the DOORS database.

Navigating between the requirements and the surrogate module allows you
to review the requirements that have links to the model without starting
the Simulink software.

To navigate from the surrogate module transmission object to the requirement
in the formal module:

1 In the surrogate module object for the transmission subsystem, right-click
the right-facing red arrow.

2 Select the requirement name.

The formal module opens, at the Transmission Requirements object.

To navigate from the requirement in the formal module to the surrogate
module:
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1 In the Transmission Requirements object in the formal module, right-click
the left-facing orange arrow.

2 Select the object name.

The surrogate module for sf_car_doors opens, at the object associated
with the transmission subsystem.

Navigation Between DOORS Requirements and the
Simulink Module via the Surrogate Module
Two-way navigation allows you to navigate from Simulink objects to
DOORS requirements and from DOORS requirements to the model. If you
synchronize your model, you using the surrogate module as an intermediary
for the navigation in both directions. The surrogate module allows two-way
navigation to remain available even if you remove the direct link from the
model object to the DOORS formal module.

Navigating from a Simulink Object to a Requirement via the
Surrogate Module
To navigate from the transmission subsystem in the sf_car_doors model to a
requirement in the DOORS formal module:

1 In the sf_car_doors model, right-click the transmission subsystem and
select Requirements > 1. “DOORS Surrogate Item”. (The direct link
to the DOORS formal module is also available.)

The surrogate module opens, at the object associated with the transmission
subsystem.
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2 To display the individual requirement, in the surrogate module, right-click
the right-facing red arrow and select the requirement.

The formal module opens, at Transmission Requirements.

Navigating from a Requirement to the Model via the Surrogate
Module
To navigate from the Transmission Requirements requirement in the formal
module to the transmission subsystem in the sf_car_doors model:

1 In the formal module, in the Transmission Requirements object,
right-click the left-facing orange arrow.

2 Select the path to the linked surrogate object: /sf_car
Project/sf_car_doors > 4. transmission.

The surrogate module opens, at the transmission object.

3 In the surrogate module, select MATLAB > Select item.

The linked object is highlighted in sf_car_doors.
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Why Add Navigation Objects to DOORS Requirements?
IBM Rational DOORS software is a requirements management application
that you use to capture, track, and manage requirements. The Requirements
Management Interface (RMI) allows you to link objects in a Simulink model
to requirements managed by external applications, including the DOORS
software.

When you create a link from a model object to a DOORS requirement, the RMI
stores information about the DOORS object in the model. This information
allows you to navigate from the model to the associated requirement.

You can configure the RMI to insert a navigation object in the DOORS
database. This object helps you to navigate from the DOORS requirement to
the model object.

To insert navigation objects into the DOORS database, you must have write
access to the DOORS database.
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Configuring the Requirements Management Interface for
DOORS Software

In this section...

“Before You Begin” on page 8-3

“Manually Installing Additional Files for DOORS Software” on page 8-3

Before You Begin
If you plan to use DOORS software with the RMI, make sure to install
additional files to establish communication between the DOORS application
and the Simulink software. Follow the instructions in “Configuring the
Requirements Management Interface (RMI)” on page 2-8.

Manually Installing Additional Files for DOORS
Software
The setup script automatically copies all the required DOORS files to the
correct folders. However, the script may fail because of file permissions in
your DOORS installation. If the script fails, change the file permissions on
the DOORS installation folders and rerun the script.

Alternative, you can install the additional files into the folders specified
manually, as described in the following steps:

1 If the DOORS software is running, close the application.

2 Copy the following files from matlabroot\toolbox\slvnv\reqmgt to the
<doors_install_dir>\lib\dxl\addins folder.

addins.idx
addins.hlp

If you have not modified the files, replace any existing versions of the files;
otherwise, merge the contents of both files into a single file.

3 Copy the following files from matlabroot\toolbox\slvnv\reqmgt to the
<doors_install_dir>\lib\dxl\addins\dmi folder.
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dmi.hlp
dmi.idx
dmi.inc
runsim.dxl
selblk.dxl

Replace any existing versions of these files.

4 Open the <doors_install_dir>\lib\dxl\startup.dxl file. In the
user-defined files section, add the following include statement:

#include <addins/dmi/dmi.inc>

If you upgrade from Version 7.1 to a later version of the DOORS software,
perform these additional steps:

a In your DOORS installation folder, navigate to the
...\lib\dxl\startupFiles subfolder.

b In a text editor, open the copiedFromDoors7.dxl file.

c Add // before this line to comment it out:

#include <addins/dmi/dmi.inc>

d Save and close the file.

5 Start the DOORS and MATLAB software.

6 Run the setup script:

rmi setup
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Enabling Linking Between DOORS Databases and Simulink
Models

By default, the RMI does not insert navigation objects into requirements
documents. If you want the RMI to insert navigation objects when you create
a link from a model object to a requirement, you must configure the RMI to
do this.

Enable the RMI to insert navigation objects into the DOORS database:

1 Open the Simulink demo model:

sldemo_fuelsys

Note You can modify requirements settings only from the Model Editor.
Even though you have a model open, any settings you change persist for
all models you open subsequently.

2 Select Tools > Requirements > Settings.

The Requirements Settings dialog box opens.

3 Click the Selection Linking tab.

4 Select the Modify documents to include links to models (two-way
linking) option.

When you select this option, every time you create a selection-based link
from a model object to a requirement, the RMI inserts navigation objects
at the designated location. Using this option requires write access to the
requirements document.

5 Set theModel file reference option to none (on MATLAB path).

For this exercise, you save a copy of the demo model on the MATLAB path.

If you are adding requirements to a model that is not on the MATLAB path,
select absolute, to indicate an absolute path to the model.
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6 In the Apply this user tag to new links field, enter one or more user tags
to apply to the links that you create.

For more information about user tags, see “Filtering Requirements with
User Tags” on page 5-23.

7 Click Close to close the Requirements Settings dialog box.

Keep the sldemo_fuelsys model open.
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Inserting Navigation Objects into DOORS Requirements
When you enable Modify documents to include links to models
(two-way linking), the RMI inserts a navigation object into both the model
and the requirement. For this tutorial, you need a formal module that
contains requirements. The examples in the tutorial show a demo model
used for the purposes of illustration.

1 Rename the sldemo_fuelsys model and save it in a writable folder on
the MATLAB path.

2 Start the DOORS software and open a formal module that contains
requirements.

3 Select the requirement that you want to link to by left-clicking that
requirement in the DOORS database.

4 In the sldemo_fuelsys model, select an object in the model.

This example creates a requirement from the fuel_rate_control subsystem.

5 Right-click the model object and select Requirements > Add link to
current DOORS object.

The RMI creates the link for the fuel_rate_control subsystem. It also
inserts a new DOORS object into the formal module—a Simulink reference
object ( ) that enables you to navigate from the requirement to the model.

6 Close the model.

The next section describes how to navigate the links that you created.
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Inserting Navigation Objects to Multiple Simulink
Objects
If you have several model objects that correspond to a requirement, you can
link all the model objects to that requirement with one navigation object.
This eliminates the need to insert multiple navigation objects for a single
requirement. The model objects must be available in the same model diagram
or Stateflow chart.

The workflow for linking multiple objects to a DOORS requirement is as
follows:

1 Make sure that you have enabledModify documents to include links to
models (two-way linking).

2 Select the DOORS requirement to link to.

3 Select the model objects that need to link to that requirement.

4 Right-click one of the objects and select Requirements > Add link to
current DOORS object.

A single navigation object is inserted at the selected requirement.

5 Double-click the navigation object in DOORS to highlight the model objects
that are linked to that requirement.
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Customizing Navigation Objects and Controls
If the Requirements Management Interface (RMI) is configured to modify
documents to include links to models, the RMI inserts a navigation control
into your requirements document. This object or control looks like the icon for

the Simulink software:

Note In IBMRationalDOORS requirements documents, clicking the
navigation objects does not navigate back to your Simulink model; you must
select MATLAB > Select object to find the model object that contains the
requirements link.

In Microsoft Office requirements documents, clicking the navigation controls
highlights the model object that contains the requirements link.

To use an icon of your own choosing for the navigation object or control:

1 Select Tools > Requirements > Settings.

2 Select the Selection Linking tab.

3 Select Modify documents to include links to models (two-way
linking).

Selecting this option enables the Use custom icon option.

4 Select Use custom icon.

5 Click Browse to locate the file you want to use for the navigation controls.

For best results, use an icon file (.ico) or a small (16×16 or 32×32) bitmap
image (.bmp) file for the navigation object or control. Other types of image
files may give unpredictable results.

6 Select the desired file to use for navigation objects or controls and click
Open.

7 Close the Requirements Settings dialog box.
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The next time you insert a navigation object or control into a requirements
document, the RMI uses the file you selected.
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Navigating Between a DOORS Requirement and a Model
Object

In “Inserting Navigation Objects into DOORS Requirements” on page 8-7,
you created a link between a DOORS requirement and the fuel_rate_control
subsystem in the sldemo_fuelsys model. Navigate the links in both
directions:

1 With the sldemo_fuelsys model closed, go to the DOORS requirement
in the formal module.

2 Left-click the Simulink reference object that you inserted to select it.

3 Select MATLAB > Select item.

Your version of the sldemo_fuelsysmodel opens, with the fuel_rate_control
subsystem highlighted.

4 Log in to the DOORS software.

5 Navigate from the model to the DOORS requirement. In the Model Editor,
right-click the fuel_rate_control subsystem and select Requirements > 1.
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“<requirement name>” where <requirement name> is the name of the
DOORS requirement that you created.

The DOORS formal module opens with the requirement object and its child
objects highlighted in red.
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Troubleshooting Your DOORS Installation

DXL Errors
If you try to synchronize your Simulink model to a DOORS project, you may
see the following errors:

-E- DXL: <Line:2> incorrectly concatenated tokens
-E- DXL: <Line:2> undeclared variable (dmiRefreshModule)
-I- DXL: all done with 2 errors and 0 warnings

If you see these errors, exit the DOORS software, rerun the rmi setup
command at the MATLAB command prompt, and restart the DOORS
software.
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Why Add Navigation Controls to Microsoft Office
Requirements?

You can use the Microsoft Word and Microsoft Excel applications to capture,
track, and manage requirements. The Requirements Management Interface
(RMI) allows you to link objects in a Simulink model to requirements managed
by external applications.

When you create a link from a model to a requirement in a Microsoft Office
document, the RMI stores information about the requirement in the model.
With this information, you can navigate from the model to the associated
requirement.

You can configure the RMI to insert a navigation reference in the Microsoft
Office document. With this control, you can navigate from the requirement to
the model object.

To insert a navigation reference into both the model and a requirements
document, you must have write access to the requirements document.
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Enabling Linking from Microsoft Office Documents to
Simulink Models

By default, the RMI does not insert navigation controls into requirements
documents. So that the RMI inserts navigation controls into the requirements
document when you create a link from a model object to a requirement, you
must change this setting in the RMI.

The RMI can insert navigation controls into the following applications:

• IBM Rational DOORS

• Microsoft Excel

• Microsoft Word

Inserting navigation controls into Microsoft Office documents requires that
ActiveX is enabled. If you cannot navigate using the links from the Microsoft
Office document, you may also need to take the steps described in “ActiveX
Control Does Not Link to Model Object” on page 9-13.

Enable linking from Microsoft Office document:

1 Open the demo model:

slvnvdemo_fuelsys_officereq

Note You can modify requirements settings only from the Model Editor.
Even though you have a model open, any settings you change persist for
all models you open subsequently.

2 Select Tools > Requirements > Settings.

The Requirements Settings dialog box opens.

3 Click the Selection Linking tab.

4 Select the Modify documents to include links to models (two-way
linking) option.
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When you select this option, every time you create a link from a model
object to a requirement, the RMI inserts navigation controls into the
designated location in the requirements document. If you do not have write
access to the requirements document, save the requirements document
that include the controls with a new file name.

5 For this exercise, you save a copy of the demo model on the MATLAB path.
Set theModel file reference option to none (on MATLAB path).

If you are adding requirements to a model that is not on the MATLAB path,
select absolute, to indicate an absolute path to the model.

6 To specify one or more user tags to apply to the links that you create, in the
Apply this user tag to new links field, enter the tags.

For more information about user tags, see “Filtering Requirements with
User Tags” on page 5-23.

7 Click Close to close the Requirements Settings dialog box.

Keep the slvnvdemo_fuelsys_officereq model open.
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Inserting Navigation Controls in Microsoft Office
Requirements Documents

Use selection-based linking to create a requirement from the
slvnvdemo_fuelsys_officereq model to a requirements document. If you
have configured the RMI as described in “Enabling Linking Between DOORS
Databases and Simulink Models” on page 8-5, the RMI inserts a navigation
control into both the model and the requirement.

1 Open the Microsoft Word requirements document:

matlabroot/toolbox/slvnv/rmidemos/fuelsys_req_docs/
slvnvdemo_FuelSys_RequirementsSpecification.docx

2 Select the Throttle Sensor header.

3 In the slvnvdemo_fuelsys_officereq model, open the engine gas
dynamics subsystem.

4 Right-click the Throttle & Manifold subsystem and select
Requirements > Add link to Word selection.

5 The RMI inserts an ActiveX control into the requirements document.

Inserting Navigation Controls to Multiple Simulink
Objects
If you have several model objects that correspond to a requirement, you can
link all the model objects to that requirement with one navigation control.
This eliminates the need to insert multiple navigation controls for a single
requirement. The model objects must be available in the same model diagram
or Stateflow chart.

The workflow for linking multiple objects to a Microsoft Word requirement
is as follows:
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1 Make sure that the RMI is configured to insert navigation controls into
requirements documents, as described in “Enabling Linking from Microsoft
Office Documents to Simulink Models” on page 9-3.

2 Select the Microsoft Word requirement to link to.

3 Select the model objects that need to link to that requirement.

4 Right-click one of the objects and select Requirements > Add link to
Word selection.

A single navigation control is inserted at the selected requirement.

5 Double-click the navigation control in Microsoft Word to highlight the
model objects that are linked to that requirement.
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Customizing Navigation Objects and Controls
If the Requirements Management Interface (RMI) is configured to modify
documents to include links to models, the RMI inserts a navigation control
into your requirements document. This object or control looks like the icon for

the Simulink software:

Note In IBMRationalDOORS requirements documents, clicking the
navigation objects does not navigate back to your Simulink model; you must
select MATLAB > Select object to find the model object that contains the
requirements link.

In Microsoft Office requirements documents, clicking the navigation controls
highlights the model object that contains the requirements link.

To use an icon of your own choosing for the navigation object or control:

1 Select Tools > Requirements > Settings.

2 Select the Selection Linking tab.

3 Select Modify documents to include links to models (two-way
linking).

Selecting this option enables the Use custom icon option.

4 Select Use custom icon.

5 Click Browse to locate the file you want to use for the navigation controls.

For best results, use an icon file (.ico) or a small (16×16 or 32×32) bitmap
image (.bmp) file for the navigation object or control. Other types of image
files may give unpredictable results.

6 Select the desired file to use for navigation objects or controls and click
Open.

7 Close the Requirements Settings dialog box.
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The next time you insert a navigation object or control into a requirements
document, the RMI uses the file you selected.
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Navigating Between a Microsoft Word Requirement and a
Model

In “Inserting Navigation Controls in Microsoft Office Requirements
Documents” on page 9-5, you created a link between a Microsoft
Word requirement and the Throttle & Manifold subsystem in the
slvnvdemo_fuelsys_officereq demo model. Navigate these links in both
directions:

1 In the slvnvdemo_fuelsys_officereq model, right-click the Throttle &
Manifold subsystem and select Requirements > 1. “Throttle Sensor”.

The requirements document opens, and the header in the requirements
document is highlighted.

2 In the requirements document, next to Throttle Sensor, double-click
the navigation control.

The engine gas dynamics subsystem opens, with the Throttle & Manifold
subsystem highlighted.

Note To ensure that the navigation controls work, in the Microsoft Office
Trust Center, enable ActiveX controls.

9-9



9 Adding Navigation Controls to Microsoft® Office Documents

Troubleshooting Simulink Navigation Controls in Microsoft
Office 2007

In this section...

“Saving Requirements Documents to Microsoft Word 2007 Format” on page
9-10

“Field Codes in Requirements Documents” on page 9-11

“ActiveX Control Does Not Link to Model Object” on page 9-13

“Deleting an ActiveX Control from Microsoft® Excel 2007 file” on page 9-15

Saving Requirements Documents to Microsoft Word
2007 Format
If you create a requirements document with an earlier version of Microsoft
Word than Word 2007, links to the Simulink model automatically work. If you
open a document created in an earlier version and then save it in Microsoft
Word 2007 format, make sure that the links to the models continue to work:

1 In the Microsoft Word window, in the upper-left corner, click theMicrosoft
Office Button.

2 Select Save As > Word Document.

You see the following dialog box.
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3 Click OK.

You then see the following dialog box.

4 Click Yes to save the current document in Microsoft Word 2007 format,
with a .docx extension.

Field Codes in Requirements Documents
If your Microsoft Word requirements document displays the field codes in
addition to, or instead of, the ActiveX icon, clear the Show field codes
instead of their values option in Microsoft Word 2007.

The following graphic shows a requirements document created in Microsoft
Word 2003, with the field codes (CONTROL mwSimulink1.SLRefButton \s)
displayed.

The following graphic shows a requirements document created in Microsoft
Word 2007, with the field codes (CONTROL mwSimulink1.SLRefButton)
displayed.

9-11



9 Adding Navigation Controls to Microsoft® Office Documents

To hide the field codes and display the ActiveX icon:

1 In the Microsoft Word window, in the upper-left corner, click theMicrosoft
Office Button.

2 In the pane that opens, at the bottom, click Word Options.

3 In the left-hand portion of the pane, click Advanced.

4 In the Advanced pane, scroll to the Show document content section
and clear the Show field codes instead of their values option.
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ActiveX Control Does Not Link to Model Object
If you click an ActiveX control that links to a Simulink or Stateflow object,
and the object does not open, do one of the following:

• Store your requirements documents in trusted locations, as described in
the Microsoft Office 2007 documentation. The Trust Center does not check
files for ActiveX controls stored in trusted locations, so you can maintain
your Trust Center restrictions.

• Enable ActiveX controls:

1 In the Microsoft Word or Microsoft Excel window, in the upper-left
corner, click the Microsoft Office Button.
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2 In the pane that opens, at the bottom, click Word Options or Excel
Options, depending on which program you are running.

3 In the left-hand portion of the pane, click Trust Center.

4 In the Trust Center pane, click Trust Center Settings.

5 In the Trust Center pane, on the right, select ActiveX Settings.

6 Select the setting that you want for ActiveX controls:

• Prompt me for enabling all controls with minimum restrictions
to decide each time you click an ActiveX control if you want to enable
all controls.
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• Enable all controls without restrictions and without
prompting to enable all ActiveX controls whenever you open the
document.

7 Close and then restart the application for the settings to take effect.

Deleting an ActiveX Control from Microsoft Excel
2007 file
Use the following procedure to remove an ActiveX control from your Microsoft
Excel 2007 file.

1 Your document may have an ActiveX control in a worksheet cell:

In the Microsoft Excel window, in the upper-left corner, click theMicrosoft
Office Button.

2 In the pane that opens, at the bottom, click Excel Options.

3 In the Excel Options dialog box, in the left-hand pane, click Popular.

4 On the Popular pane, in the Top options for working with Excel
section, select Show Developer tab in the Ribbon.

5 Click OK.

6 In the Ribbon, on the Developer tab, select Design Mode.

When you select Design Mode, the ActiveX control is no longer visible in
the cell.

7 Click where the ActiveX control was, and you see four handles showing
the location of the control.
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8 Select Home > Cut to delete the control.
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Why Create a Custom Link Type?
In addition to linking to built-in types of requirements documents, you
can register custom requirements document types with the Requirements
Management Interface (RMI). Then you can create requirement links to these
types of documents.

Custom link types let you define how you:

• Open and navigate to a document

• Browse for a document

• View an index of a document’s contents

When you define a custom link type, you create MATLAB functions that
perform these operations. The RMI invokes the registered code:

• When navigating to a document with the new link type that you created.

• When browsing for a document or displaying the index of a document
within the Requirements dialog box.

Using the external interfaces supported by the MATLAB software, you can
interact with external applications and run programs from the command shell.
You can also use the built-in Web browser and text editor to display custom
variants of HTML and text files without installing external applications.

With custom link types, you can:

• Link to requirement items in commercial requirement tracking software

• Link to in-house database systems

• Link to document types that the RMI does not support
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Custom Link Type Registration
You register custom link types with a unique MATLAB function name. The
function must exist on the MATLAB path and must not require any input
arguments. The function must return a single output argument that is an
instance of the requirements link type class. You can register your link type
with the following MATLAB command:

rmi register mytargetfilename

mytargetfilename is the name of the MATLAB function,
mytargetfilename.m.

Once you register a link type, it appears in the Requirements dialog box as an
entry in the Document type drop-down list. A file in your preference folder
contains the list of registered link types, so you can restore it in new MATLAB
sessions. You can remove a link type with the following MATLAB command:

rmi unregister mytargetfilename

When you create links using custom link types, the software saves the
registration name in the model. When you attempt to navigate to a link, the
RMI resolves the link type against the registered list. If the software cannot
find the link type, you see an error message.
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Link Properties
Requirements links are the data structures, saved in the Simulink model,
that identify a specific location within a document. You get and set the links
on a block using the rmi command. The RMI encapsulates link information in
a MATLAB structure array. Each element of the array is a single requirement
link.

Links and link types work together to perform navigation and manage
requirements. The document and ID fields of links uniquely identify the
linked item in external documents. The RMI passes both of these strings to
the navigation command when you navigate a link from the model.
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Link Type Properties
Link type properties define how links are created, identified, navigated to,
and stored within the requirement management tool. The following table
describes each of these properties.

Property Description

Registration The name of the function that creates the link type. The
RMI stores this name in the Simulink model.

Label A string to identify this link type. In the Requirements
dialog box, this string appears on the Document type
drop-down list for a Simulink or Stateflow object.

IsFile A Boolean property that indicates if the linked documents
are files within the computer file system. If a document is
a file:

• The software uses the standard method for resolving
the path.

For information about how the RMI resolves the path
to the requirements document, see “Resolving the
Document Path” on page 6-14.

• In the Requirements dialog box, when you click
Browse, the file selection dialog box opens.

Extensions An array of file extensions. Use these file extensions as
filter options in the Requirements dialog box when you
click Browse. The file extensions infer the link type based
on the document name. If you registered more than one
link type for the same file extension, the link type that you
registered takes first priority.

LocDelimiters A string containing the list of supported navigation
delimiters. The first character in the ID of a requirement
specifies the type of identifier. For example, an identifier
can refer to a specific page number (#4), a named bookmark
(@my_tag), or some searchable text (?search_text). The
valid location delimiters determine the possible entries in
the Requirements dialog box Location drop-down list.
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Property Description

NavigateFcn The MATLAB callback you invoke when you click a link.
The function has two input arguments: the document field
and the ID field of the link:

feval(LinkType.NavigateFcn, Link.document, Link.id)

ContentsFcn The MATLAB callback you invoke when you click the
Document Index tab in the Requirements dialog box.
This function has a single input argument that contains
the full path of the resolved function or, if the link type is
not a file, the Document field contents.

The function returns three outputs:

• Labels

• Depths

• Locations

BrowseFcn The MATLAB callback you invoke when you click Browse
in the Requirements dialog box. This function is not
necessary when the link type is a file. The function takes
no input arguments and returns a single output argument
that identifies the selected document.
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Creating a Custom Link Requirement Type
In this example, you implement a custom link type to a hypothetical document
type, a text file with the extension .abc. Within a document, the requirement
items are identified with a special text string, Requirement::, followed by a
single space and then the requirement item inside quotation marks (").

Create a document index containing a list of all the requirement items. When
navigating from the Simulink model to the requirements document, the
document opens in the MATLAB Editor at the line of the requirement that
you want.

To create a custom link requirement type:

1 Write a function that implements the custom link type and save it on
the MATLAB path. In this example, the file is rmicustabcinterface.m,
containing the function, rmicustabcinterface, that implements the
ABC files shipping with your installation. You can view it here, or at the
MATLAB prompt, type edit rmicustabcinterface.

function linkType = rmicustabcinterface
%RMICUSTABCINTERFACE - Example custom requirement link type
%
% This file implements a requirements link type that maps
% to "ABC" files.
% You can use this link type to map a line or item within an
% ABC file to a Simulink or Stateflow object.
%
% You must register a custom requirement link type before
% using it. Once registered, the link type will be reloaded in
% subsequent sessions until you unregister it. The following
% commands perform registration and registration removal.
%
% Register command: >> rmi register rmicustabcinterface
% Unregister command: >> rmi unregister rmicustabcinterface
%
% There is an example document of this link type contained in
% the requirement demo directory to determine the path to the
% document invoke:
%

10-7



10 Creating Custom Types of Requirements Documents

% >> which demo_req_1.abc

% Copyright 1984-2005 The MathWorks, Inc.
% $Revision: 1.1.4.4 $ $Date: 2009/08/04 14:34:12 $

% Create a default (blank) requirement link type
linkType = ReqMgr.LinkType;
linkType.Registration = mfilename;

% Label describing this link type
linkType.Label = 'ABC file (for demonstration)';

% File information
linkType.IsFile = 1;
linkType.Extensions = {'.abc'};

% Location delimiters
linkType.LocDelimiters = '>@';
linkType.Version = ''; % not needed

% Uncomment the functions that are implemented below
linkType.NavigateFcn = @NavigateFcn;
linkType.ContentsFcn = @ContentsFcn;

function NavigateFcn(filename,locationStr)
if ~isempty(locationStr)

findId=0;
switch(locationStr(1))
case '>'

lineNum = str2num(locationStr(2:end));
openFileToLine(filename, lineNum);

case '@'
openFileToItem(filename,locationStr(2:end));

otherwise
openFileToLine(filename, 1);

end
end

10-8



Creating a Custom Link Requirement Type

function openFileToLine(fileName, lineNum)
if lineNum > 0

err = javachk('mwt', 'The MATLAB Editor');
if isempty(err)

editor = com.mathworks.mlservices.MLEditorServices;
editor.openDocumentToLine(fileName, lineNum);

end
else

edit(fileName);
end

function openFileToItem(fileName, itemName)
reqStr = ['Requirement:: "' itemName '"'];
lineNum = 0;
fid = fopen(fileName);
i = 1;
while lineNum == 0

lineStr = fgetl(fid);
if ~isempty(strfind(lineStr, reqStr))

lineNum = i;
end;
if ~ischar(lineStr), break, end;
i = i + 1;

end;
fclose(fid);
openFileToLine(fileName, lineNum);

function [labels, depths, locations] = ContentsFcn(filePath)
% Read the entire file into a variable
fid = fopen(filePath,'r');
contents = char(fread(fid)');
fclose(fid);

% Find all the requirement items
fList1 = regexpi(contents,'\nRequirement:: "(.*?)"','tokens');

% Combine and sort the list
items = [fList1{:}]';
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items = sort(items);
items = strcat('@',items);

if (~iscell(items) && length(items)>0)
locations = {items};
labels = {items};

else
locations = [items];
labels = [items];

end

depths = [];

Note To view these files for the built-in link types, see the following files
in matlabroot\toolbox\slvnv\reqmgt\private:

linktype_rmi_doors.m
linktype_rmi_excel.m
linktype_rmi_html.m
linktype_rmi_pdf.m
linktype_rmi_text.m
linktype_rmi_url.m
linktype_rmi_word.m

2 To register the custom link type ABC, type the following MATLAB
command:

rmi register rmicustabcinterface

The ABC file type appears on the Requirements dialog box drop-down list
of document types.

3 Create a text file with the .abc extension containing several requirement
items marked by the Requirement:: string. For your convenience,
an example file ships with your installation. The example file is
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demo_req_1.abc and resides in matlabroot\toolbox\slvnv\rmidemos.
demo_req_1.abc contains the following content:

Requirement:: "Altitude Climb Control"

Altitude climb control is entered whenever:
|Actual Altitude- Desired Altitude | > 1500

Units:
Actual Altitude - feet
Desired Altitude - feet

Description:

When the autopilot is in altitude climb
control mode, the controller maintains a
constant user-selectable target climb rate.

The user-selectable climb rate is always a
positive number if the current altitude is
above the target altitude. The actual target
climb rate is the negative of the user
setting.

<END "Altitude Climb Control">

Requirement:: "Altitude Hold"

Altitude hold mode is entered whenever:
|Actual Altitude- Desired Altitude | <

30*Sample Period*(Pilot Climb Rate / 60)

Units:
Actual Altitude - feet
Desired Altitude - feet
Sample Period - seconds
Pilot Climb Rate - feet/minute
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Description:

The transition from climb mode to altitude
hold is based on a threshold that is
proportional to the Pilot Climb Rate.

At higher climb rates the transition occurs
sooner to prevent excessive overshoot.

<END "Altitude Hold">

Requirement:: "Autopilot Disable"

Altitude hold control and altitude climb
control are disabled when autopilot enable
is false.

Description:

Both control modes of the autopilot
can be disabled with a pilot setting.

<END "Autopilot Disable">

Requirement:: "Glide Slope Armed"

Glide Slope Control is armed when Glide
Slope Enable and Glide Slope Signal
are both true.

Units:
Glide Slope Enable - Logical
Glide Slope Signal - Logical

Description:
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ILS Glide Slope Control of altitude is only
enabled when the pilot has enabled this mode
and the Glide Slope Signal is true. This indicates
the Glide Slope broadcast signal has been
validated by the on board receiver.

<END "Glide Slope Armed">

Requirement:: "Glide Slope Coupled"

Glide Slope control becomes coupled when the control
is armed and (Glide Slope Angle Error > 0) and
Distance < 10000

Units:
Glide Slope Angle Error - Logical
Distance - feet

Description:

When the autopilot is in altitude climb control
mode the controller maintains a constant user
selectable target climb rate.

The user-selectable climb rate is always a positive
number if the current altitude is above the target
altitude the actual target climb rate is the
negative of the user setting.

<END "Glide Slope Coupled">

4 Open the model aero_dap3dof.

5 Right-click the Reaction Jet Control subsystem and select
Requirements > Edit/Add Links.

The Requirements dialog box opens.
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6 Click New to add a new requirement link. The Document type drop-down
list now contains the ABC file (for demonstration) option.

7 Set Document type to ABC file (for demonstration) and browse to
the demo_req_1.abc file. The browser shows only the files with the .abc
extension.

8 To define a particular location in the requirements document, use the
Location field.

In this example, the rmicustabcinterface function specifies two types of
location delimiters for your requirements:

• > — Line number in a file

• @— Named item, such as a bookmark, function, or HTML anchor

Note The rmi reference page describes other types of requirements
location delimiters.

The Location drop-down list contains these two types of location delimiters
whenever you set Document type to ABC file (for demonstration).
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9 Select Line number. Enter the number 26, which corresponds with the
line number for the Altitude Hold requirement in demo_req_1.abc.

10 In the Description field, enter Altitude Hold, to identify the requirement
by name.

11 Click Apply.

12 Verify that the Altitude Hold requirement links to the Reaction
Jet Control subsystem. Right-click the subsystem and select
Requirements > 1. “Altitude Hold”.

Creating a Document Index
A document index is a list of all the requirements in a given document. To
create a document index, MATLAB uses file I/O functions to read the contents
of a requirements document into a MATLAB variable. Then the RMI extracts
the list of requirement items.

The example requirements document, demo_req_1.abc, defines four
requirements using the string Requirement::. To generate the
document index for an ABC file, the ContentsFcn function, in the
rmicustabcinterface.m file, extracts the requirements names and inserts
@ before each name.

Note To see the code for the ContentsFcn file, go to step 1 in Chapter 10,
“Creating Custom Types of Requirements Documents”.

For the demo_req_1.abc file, in the Requirements: Engine dialog box,
click the Document Index tab. The ContentsFcn function generates the
document index automatically.
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Navigating to Simulink Objects from External Documents
The RMI includes several functions that simplify creating navigation
interfaces in external documents. The external application that displays
your document must support an application programming interface (API) for
communicating with the MATLAB software.

Providing Unique Object Identifiers
Whenever you create a requirement link for a Simulink or Stateflow object,
the RMI creates a globally unique identifier for that object. This identifier
identifies the object. The identifier does not change if you rename or move the
object, or add or delete requirement links. The RMI uses the unique identifier
only to resolve an object within a model. The identifier is globally unique and
does not collide with identifiers in other models, unless the two models derive
from the same original model. Unique object identifiers have formats such as
GIDa_cd14afcd_7640_4ff8_9ca6_14904bdf2f0f.

Using the rmiobjnavigate Function
The rmiobjnavigate function identifies the appropriate Simulink or Stateflow
object, highlights that object, and brings the appropriate editor window to the
front of the screen. When you navigate to a Simulink model from an external
application, invoke this function. Internally, this function creates a table of
all the unique object identifiers within a model for efficient object lookup.

The first time you navigate to an item in a particular model, you might
experience a slight delay while the software constructs the internal navigation
table. You do not experience a long delay on subsequent navigation.

Determining the Navigation Command
Once you create a requirement link for a Simulink or Stateflow object, at the
MATLAB prompt, use the rmi function to find the appropriate navigation
command string. The return value of the navCmd method is a string that
navigates to the correct object when evaluated by the MATLAB software:

cmdString = rmi('navCmd', block);
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Send this exact string to the MATLAB software for evaluation as part of
navigating from the external application to the Simulink model.

Using the ActiveX Navigation Control
The RMI uses software that includes a special Microsoft® ActiveX® control
to enable navigation to Simulink objects from Microsoft Word and Excel®

documents. You can use this same control in any other application that
supports ActiveX within its documents.

The control is derived from a push button and has the Simulink icon.
There are two instance properties that define how the control works. The
tooltipstring property is the string that is displayed in the control ToolTip.
The MLEvalCmd property is the string that you pass to the MATLAB software
for evaluation when you click the control.

Typical Code Sequence for Establishing Navigation
Controls
When you create an interface to an external tool, you can automate the
procedure for establishing links. This way, you do not need to manually
update the dialog box fields. This type of automation occurs as part of the
selection-based linking for certain built-in types, such as Microsoft Word
and Excel documents.

To automate the procedure for establishing links:

1 Select a Simulink or Stateflow object and an item in the external document.

2 Invoke the link creation action either from a Simulink menu or command,
or a similar mechanism in the external application.

3 Identify the document and current item using the scripting capability of
the external tool. Pass this information to the MATLAB software. Create
a requirement link on the selected object using rmi('createempty') and
rmi('cat').

4 Determine the MATLAB navigation command string that you must embed
in the external tool, using the navCmd method:
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cmdString = rmi('navCmd',obj)

5 Create a navigation item in the external document using the scripting
capability of the external tool. Set the MATLAB navigation command
string in the appropriate property.

For example, you can use the code for selection-based linking to the Microsoft
Word, Microsoft Excel, and IBM Rational DOORS software. The files are
contained in matlabroot\toolbox\slvnv\reqmgt\private:

selection_link_doors.m
selection_link_excel.m
selection_link_word.m
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Creating Navigation
Interfaces in Requirements
Documents

• “Interfacing with External Requirements Documents” on page 11-2

• “Providing Unique Object Identifiers” on page 11-3

• “Using the rmiobjnavigate Function” on page 11-4

• “Determining the Navigation Command” on page 11-5

• “Using the ActiveX Navigation Control” on page 11-6

• “Typical Code Sequence for Establishing Navigation Controls” on page 11-7
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Interfacing with External Requirements Documents
The RMI includes several capabilities that simplify creating and using
navigation interfaces in external documents. The external application that
displays your document must support an application programming interface
(API) for communicating with the MATLAB software.

11-2



Providing Unique Object Identifiers

Providing Unique Object Identifiers
Whenever you create a requirement link for a Simulink or Stateflow object,
the RMI creates a globally unique identifier for that object. This identifier
identifies the object. The identifier does not change if you rename or move the
object, or add or delete requirement links. The RMI uses the unique identifier
only to resolve an object within a model. The identifier is globally unique and
does not collide with identifiers in other models, unless the two models derive
from the same original model. Unique object identifiers have formats such as
GIDa_cd14afcd_7640_4ff8_9ca6_14904bdf2f0f.
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Using the rmiobjnavigate Function
The rmiobjnavigate function identifies the appropriate Simulink or Stateflow
object, highlights that object, and brings the appropriate editor window to the
front of the screen. When you navigate to a Simulink model from an external
application, invoke this function. Internally, this function creates a table of
all the unique object identifiers within a model for efficient object lookup.

The first time you navigate to an item in a particular model, you might
experience a slight delay while the software constructs the internal navigation
table. You do not experience a long delay on subsequent navigation.

11-4



Determining the Navigation Command

Determining the Navigation Command
Once you create a requirements link for a Simulink or Stateflow object, at the
MATLAB prompt, use the rmi function to find the appropriate navigation
command string. The return value of the navCmd method is a string that
navigates to the correct object when evaluated by the MATLAB software:

cmdString = rmi('navCmd', block);

Send this exact string to the MATLAB software for evaluation as part of
navigating from the external application to the Simulink model.
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Using the ActiveX Navigation Control
The RMI uses software that includes a special Microsoft ActiveX control
to enable navigation to Simulink objects from Microsoft Word and Excel
documents. You can use this same control in any other application that
supports ActiveX within its documents.

The control is derived from a push button and has the Simulink icon.
There are two instance properties that define how the control works. The
tooltipstring property is the string that is displayed in the control ToolTip.
The MLEvalCmd property is the string that you pass to the MATLAB software
for evaluation when you click the control.
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Typical Code Sequence for Establishing Navigation
Controls

When you create an interface to an external tool, you can automate the
procedure for establishing links. This way, you do not need to manually
update the dialog box fields. This type of automation occurs as part of the
selection-based linking for certain built-in types, such as Microsoft Word
and Excel documents.

To automate the procedure for establishing links:

1 Select a Simulink or Stateflow object and an item in the external document.

2 Invoke the link creation action either from a Simulink menu or command,
or a similar mechanism in the external application.

3 Identify the document and current item using the scripting capability of
the external tool. Pass this information to the MATLAB software. Create
a requirement link on the selected object using rmi('createempty') and
rmi('cat').

4 Determine the MATLAB navigation command string that you must embed
in the external tool, using the navCmd method:

cmdString = rmi('navCmd',obj)

5 Create a navigation item in the external document using the scripting
capability of the external tool. Set the MATLAB navigation command
string in the appropriate property.

For example, you can use the code for selection-based linking to the Microsoft
Word, Microsoft Excel, and IBM Rational DOORS software. The files are
contained in matlabroot\toolbox\slvnv\reqmgt\private:

selection_link_doors.m
selection_link_excel.m
selection_link_word.m
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Including Requirements
Information with Generated
Code

After you simulate your model and verify its performance against the
requirements, you can generate code from the model for an embedded
real-time application. The Embedded Coder™ software generates code for
Embedded Real-Time (ERT) targets.

If the model has any links to requirements, the Embedded Coder software
inserts information about the requirements links into the code comments.

For example, if a block has a requirement link, the software generates code
for that block. In the code comments for that block, the software inserts:

• Requirement description

• Hyperlink to the requirements document that contains the linked
requirement associated with that block

Note You must have a license for Embedded Coder to generate code for an
embedded real-time application.

Comments for the generated code include requirements descriptions and
hyperlinks to the requirements documents in the following locations.



12 Including Requirements Information with Generated Code

Model Object with Requirement Location of Code Comments with
Requirements Links

Model In the main header file, <model>.h

Nonvirtual subsystem At the call site for the subsystem

Virtual subsystem At the call site of the closest
nonvirtual parent subsystem. If a
virtual subsystem does not have
a nonvirtual parent, requirement
descriptions appear in the main
header file for the model, <model>.h.

Nonsubsystem block In the generated code for the block

To specify that generated code of an ERT target include requirements:

1 Open the rtwdemo_requirements demo model.

2 Select Simulation > Configuration Parameters.

3 In the Select pane of the Configuration Parameters dialog box, select the
Code Generation category.

The currently configured system target must be an ERT target.

4 Under the Code Generation category, select Comments.

5 In the Custom comments section on the right, select the Requirements
in block comments check box.

6 Under the Code Generation category, select Report.
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7 On the Report pane, select:

• Create code generation report

• Launch report automatically

8 On the Code Generation main pane, click Build.

9 In the code-generation report, open rtwdemo_requirements.c.

10 Scroll to the code for the Pulse Generator block, clock. The comments for
the code associated with that block include a hyperlink to the requirement
linked to that block.

11 Click the link Clock period shall be consistent with chirp
tolerance to open the HTML requirements document to the associated
requirement.

Note When you click a requirements link in the code comments, the
software opens the application for the requirements document, except
if the requirements document is a DOORS module. To view a DOORS
requirement, start the DOORS software and log in before clicking the
hyperlink in the code comments.
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Validating Your Model with
Model Coverage

• Chapter 13, “Introduction to Model Coverage”

• Chapter 14, “Model Objects That Receive Model Coverage”

• Chapter 15, “Setting Model Coverage Options”

• Chapter 16, “Collecting Model Coverage”

• Chapter 17, “Understanding Model Coverage Reports”

• Chapter 18, “Excluding Model Objects From Coverage”

• Chapter 19, “Using Model Coverage Commands”





13

Introduction to Model
Coverage

• “What Is Model Coverage?” on page 13-2

• “How Model Coverage Works” on page 13-3

• “Types of Model Coverage” on page 13-4

• “Simulink Optimizations and Model Coverage” on page 13-10
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What Is Model Coverage?
Model coverage helps you validate your model tests by measuring how
thoroughly the model objects are tested. Model coverage calculates how much
a model test case exercises simulation pathways through a model. Model
coverage is a measure of how thoroughly a test case tests a model and the
percentage of pathways that a test case exercise. Model coverage helps you
validate your model tests.
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How Model Coverage Works
Model coverage analyzes the execution of the following types of model objects
that directly or indirectly determine simulation pathways through your model:

• Simulink blocks

• Models referenced in Model blocks

• The states and transitions of Stateflow charts

During a simulation run, the tool records the behavior of the covered objects,
states, and transitions. At the end of the simulation, the tool reports the
extent to which the run exercised potential simulation pathways through each
covered object in the model.

The Simulink Verification and Validation software can only collect coverage
for a model if its simulation mode is set to Normal. If the simulation mode
is set to any mode other than Normal, coverage will not be measured during
simulation.

For the types of coverage that model coverage performs, see “Types of Model
Coverage” on page 13-4. For an example of a model coverage report, see
Chapter 17, “Understanding Model Coverage Reports”.

13-3



13 Introduction to Model Coverage

Types of Model Coverage
Simulink Verification and Validation software can perform several types
of coverage analysis:

• “Cyclomatic Complexity” on page 13-4

• “Decision Coverage (DC)” on page 13-5

• “Condition Coverage (CC)” on page 13-5

• “Modified Condition/Decision Coverage (MCDC)” on page 13-5

• “Lookup Table Coverage” on page 13-7

• “Signal Range Coverage” on page 13-7

• “Signal Size Coverage” on page 13-7

• “Simulink Design Verifier Coverage” on page 13-8

Cyclomatic Complexity
Cyclomatic complexity is a measure of the structural complexity of a model. It
approximates the McCabe complexity measure for code generated from the
model. The McCabe complexity measure is slightly higher on the generated
code due to error checks that the model coverage analysis does not consider.

To compute the cyclomatic complexity of an object (such as a block, chart, or
state), model coverage uses the following formula:

c on

N
= −∑( )1

1

N is the number of decision points that the object represents and on is
the number of outcomes for the nth decision point. The tool adds 1 to the
complexity number for atomic subsystems and Stateflow charts.

For an example of cyclomatic complexity data in a model coverage report, see
“Cyclomatic Complexity” on page 17-14.
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Decision Coverage (DC)
Decision coverage analyzes elements that represent decision points in a
model, such as a Switch block or Stateflow states. For each item, decision
coverage determines the percentage of the total number of simulation paths
through the item that the simulation actually traversed.

For an example of decision coverage data in a model coverage report, see
“Decisions Analyzed” on page 17-16.

Condition Coverage (CC)
Condition coverage analyzes blocks that output the logical combination
of their inputs (for example, the Logical Operator block) and Stateflow
transitions. A test case achieves full coverage when it causes each input to
each instance of a logic block in the model and each condition on a transition
to be true at least once during the simulation, and false at least once during
the simulation. Condition coverage analysis reports whether the test case
fully covered the block for each block in the model.

When you collect coverage for a model, you may not be able to achieve 100%
condition coverage. For example, if you specify to short-circuit logic blocks, by
selecting Treat Simulink Logic blocks as short-circuited in the Coverage
Settings dialog box, you might not be able to achieve 100% condition coverage
for that block. See “Treat Simulink Logic blocks as short-circuited” on page
15-16 for more information.

For an example of condition coverage data in a model coverage report, see
“Conditions Analyzed” on page 17-18.

Modified Condition/Decision Coverage (MCDC)
Modified condition/decision coverage analysis by the Simulink Verification
and Validation software extends the decision and condition coverage
capabilities. It analyzes blocks that output the logical combination of their
inputs and Stateflow transitions to determine the extent to which the test
case tests the independence of logical block inputs and transition conditions.

• A test case achieves full coverage for a block when a change in one input,
independent of any other inputs, causes a change in the block’s output.
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• A test case achieves full coverage for a Stateflow transition when there is
at least one time when a change in the condition triggers the transition for
each condition.

Because the Simulink Verification and Validation MCDC coverage does not
guarantee full decision or condition coverage, you can achieve 100% MCDC
coverage without achieving 100% decision coverage.

Some Simulink objects support MCDC coverage, some objects support only
condition coverage, and some objects support only decision coverage. The
table in Chapter 14, “Model Objects That Receive Model Coverage” lists which
objects receive which types of model coverage. For example, the Combinatorial
Logic block can receive decision coverage and condition coverage, but not
MCDC coverage.

To achieve 100% MCDC coverage for your model, as defined by the DO-178B
standard, in the Coverage Settings dialog box, collect coverage for all of the
following coverage metrics:

• Condition Coverage

• Decision Coverage

• MCDC Coverage

When you collect coverage for a model, you may not be able to achieve 100%
MCDC coverage. For example, if you specify to short-circuit logic blocks, you
may not be able to achieve 100% MCDC coverage for that block.

If you run the test cases independently and accumulate all the coverage
results, you can determine if your model adheres to the modified condition
and decision coverage standard. For more information about the DO-178B
standard, see “DO-178B Checks”.

For an example of MCDC coverage data in a model coverage report, see
“MCDC Analysis” on page 17-18. For an example of accumulated coverage
results, see “Cumulative Coverage” on page 17-20.
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Lookup Table Coverage
Lookup table coverage (LUT) examines blocks, such as the 1-D Lookup Table
block, that output information from inputs in a table of inputs and outputs,
interpolating between or extrapolating from table entries. Lookup table
coverage records the frequency that table lookups use each interpolation
interval. A test case achieves full coverage when it executes each interpolation
and extrapolation interval at least once. For each lookup table block in
the model, the coverage report displays a colored map of the lookup table,
indicating each interpolation.

For an example of lookup table coverage data in a model coverage report, see
“N-Dimensional Lookup Table” on page 17-22.

Note Configure lookup table coverage only at the start of a simulation. If
you tune a parameter that affects lookup table coverage at run time, the
coverage settings for the affected block are not updated.

Signal Range Coverage
Signal range coverage records the minimum and maximum signal values at
each block in the model, as measured during simulation. Only blocks with
output signals receive signal range coverage.

For an example of signal range coverage data in a model coverage report, see
“Signal Range Analysis” on page 17-31.

Signal Size Coverage
Signal size coverage records the minimum, maximum, and allocated size for
all variable-size signals in a model. Only blocks with variable-size output
signals are included in the report.

For an example of signal size coverage data in a model coverage report, see
“Signal Size Coverage for Variable-Dimension Signals” on page 17-33.

For more information about variable-size signals, see “Working with
Variable-Size Signals”.
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Simulink Design Verifier Coverage
The Simulink Verification and Validation software collects model coverage
data for the following Simulink® Design Verifier™ blocks and MATLAB for
code generation functions:

Simulink Design Verifier blocks MATLAB for code generation
functions

Test Condition sldv.condition

Test Objective sldv.test

Proof Assumption sldv.assume

Proof Objective sldv.prove

If you do not have a Simulink Design Verifier license, you can collect model
coverage for a model that contains these blocks or functions, but you cannot
analyze the model using the Simulink Design Verifier software.

By adding one or more Simulink Design Verifier blocks or functions into your
model, you can:

• Check the results of a Simulink Design Verifier analysis, run generated
test cases, and use the blocks to observe the results.

• Define model requirements using the Test Objective block and verify
the results with model coverage data that the software collected during
simulation.

• Analyze the model, create a test harness, and simulate the harness with
the Test Objective block to collect model coverage data.

• Analyze the model and use the Proof Assumption block to verify any
counterexamples that the Simulink Design Verifier identifies.

If you specify to collect Simulink Design Verifier coverage:

• The software collects coverage for the Simulink Design Verifier blocks
and functions.

• The software checks the data type of the signal that links to each Simulink
Design Verifier block. If the signal data type is fixed point, the block
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parameter must also be fixed point. If the signal data type is not fixed
point, the software tries to convert the block parameter data type. If the
software cannot convert the block parameter data type, the software
reports an error and you must explicitly assign the block parameter data
type to match the signal.

• If your model contains a Verification Subsystem block, the software only
records coverage for Simulink Design Verifier blocks in the Verification
Subsystem block; it does not record coverage for any other blocks in the
Verification Subsystem.

If you do not specify to collect Simulink Design Verifier coverage, the software
does not check the data types for any Simulink Design Verifier blocks and
functions in your model and does not collect coverage.

For an example of coverage data for Simulink Design Verifier blocks or
functions in a model coverage report, see “Simulink® Design Verifier
Coverage” on page 17-35.

13-9



13 Introduction to Model Coverage

Simulink Optimizations and Model Coverage
In the Configuration Parameters dialog box Optimization pane, there are
three Simulink optimization parameters that can affect your model coverage
data:

In this section...

“Inline parameters” on page 13-10

“Block reduction” on page 13-10

“Conditional input branch execution” on page 13-11

Inline parameters
To transform tunable model parameters into constant values for code
generation, in the Configuration Parameters dialog box, on the Optimization
> Signals and Parameters pane, select Inline parameters. When you
enable this option, you cannot change the values of block parameters during
simulation.

When the parameters are transformed into constants, Simulink may
eliminate certain decisions in your model. You cannot achieve coverage for
eliminated decision, so the coverage report displays 0/0 for those decisions.

Block reduction
To achieve faster execution during model simulation and in generated code, in
the Configuration Parameters dialog box, on the Optimization pane, select
the Block reduction parameter. The Simulink software collapses certain
groups of blocks into a single, more efficient block, or removes them entirely.

One of the model coverage options, Force block reduction off, allows you to
ignore the Block reduction parameter when collecting model coverage.

If you do not select the Block reduction parameter, or if you select Force
block reduction off, the Simulink Verification and Validation software
provides coverage data for every block in the model that collects coverage.
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If you select the Block reduction parameter and do not set Force block
reduction off, the coverage report lists the reduced blocks that would have
collected coverage.

Conditional input branch execution
To improve model execution when the model contains Switch and Multiport
Switch blocks, in the Configuration Parameters dialog box, on the
Optimization pane, select Conditional input branch execution. If you
select this parameter, the simulation executes only blocks that are required to
compute the control input and the data input selected by the control input.

You can apply this optimization only to certain kinds of Switch blocks, as
described in the “Optimizing Code for Switch Blocks” in the Simulink®

Coder™ documentation.

For example, if your model has a Switch block with output flagged as a test
point, such as when a Scope block is attached, that Switch block is not
executed, and the model coverage data is incomplete. If you have a model
with Switch blocks and you want to ensure that the model coverage data is
complete, clear Conditional input branch execution.
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Model Objects That Receive
Model Coverage

• “Summary of Objects That Receive Coverage” on page 14-3

• “Abs” on page 14-6

• “Combinatorial Logic” on page 14-7

• “Dead Zone” on page 14-8

• “Direct Lookup Table (n-D)” on page 14-9

• “Discrete-Time Integrator” on page 14-10

• “Enabled Subsystem” on page 14-12

• “Enabled and Triggered Subsystem” on page 14-13

• “Fcn” on page 14-15
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• “Library-Linked Objects” on page 14-19

• “Logical Operator” on page 14-20
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• “2-D Lookup Table” on page 14-22

• “n-D Lookup Table” on page 14-23

• “MATLAB Function” on page 14-24

• “MinMax” on page 14-25
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• “Model” on page 14-26

• “Multiport Switch” on page 14-27

• “Proof Assumption” on page 14-28

• “Proof Objective” on page 14-29

• “Rate Limiter” on page 14-30

• “Relay” on page 14-31

• “Saturation” on page 14-32

• “Simulink® Design Verifier Functions in MATLAB Function Blocks” on
page 14-33

• “Switch” on page 14-34

• “SwitchCase, SwitchCase Action Subsystem” on page 14-35

• “Test Condition” on page 14-36

• “Test Objective” on page 14-37

• “Triggered Models” on page 14-38

• “Triggered Subsystem” on page 14-39

• “While Iterator, While Iterator Subsystem” on page 14-40

• “Model Objects That Do Not Receive Coverage” on page 14-41
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Summary of Objects That Receive Coverage
Certain Simulink objects can receive any type of model coverage. Other
Simulink objects can receive only certain types of coverage, as the following
table shows. Click a link in the first column to get more detailed information
about coverage for a specific model objects.

For Stateflow states, events, and state temporal logic decisions, model
coverage provides only decision coverage. For Stateflow transitions, model
coverage provides decision, condition, and MCDC coverage. For more
information, see “Model Coverage for Stateflow Charts” on page 16-40.

Model Object Decision Condition MCDC
Lookup
Table

Simulink
Design
Verifier

“Abs” on page 14-6

“Combinatorial Logic” on page
14-7

“Dead Zone” on page 14-8

“Direct Lookup Table (n-D)”
on page 14-9

“Discrete-Time Integrator” on
page 14-10 (when saturation
limits are enabled or reset)

“Enabled Subsystem” on page
14-12

“Enabled and Triggered
Subsystem” on page 14-13

“Fcn” on page 14-15 (Boolean
operators only)

“For Iterator, For Iterator
Subsystem” on page 14-16

“If, If Action Subsystem” on
page 14-17
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Model Object Decision Condition MCDC
Lookup
Table

Simulink
Design
Verifier

“Interpolation Using
Prelookup” on page 14-18

“Library-Linked Objects” on
page 14-19

“Logical Operator” on page
14-20

“1-D Lookup Table” on page
14-21

“2-D Lookup Table” on page
14-22

“n-D Lookup Table” on page
14-23

“MATLAB Function” on page
14-24

“MinMax” on page 14-25

“Model” on page 14-26
See also “Triggered Models”
on page 14-38.

“Multiport Switch” on page
14-27

“Proof Assumption” on page
14-28

“Proof Objective” on page
14-29

“Rate Limiter” on page 14-30 (Relative
to slew
rates)

“Relay” on page 14-31

“Saturation” on page 14-32
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Model Object Decision Condition MCDC
Lookup
Table

Simulink
Design
Verifier

“Simulink® Design Verifier
Functions in MATLAB
Function Blocks” on page
14-33

Stateflow charts

“Switch” on page 14-34

“SwitchCase, SwitchCase
Action Subsystem” on page
14-35

“Test Condition” on page 14-36

“Test Objective” on page 14-37

“Triggered Models” on page
14-38

“Triggered Subsystem” on
page 14-39

“While Iterator, While Iterator
Subsystem” on page 14-40
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Abs
The Abs block receives decision coverage. Decision coverage is based on the
input to the block being less than zero and on the data type of the input
signal. The decision coverage measures:

• The number of time steps that the block input is less than zero, indicating
a true decision.

• The number of time steps the block input is not less than zero, indicating
a false decision.

If at least one time step is true and at least one time step is false, decision
coverage is 100%. If no time steps are true, or if no time steps are false,
decision coverage is 50%. The software treats each element of a vector or
matrix as a separate coverage measurement.

If the input data type to the Abs block is uint8, uint16, or uint32, the
Simulink Verification and Validation software reports no coverage for the
block. The software sets the block output equal to the block input without
making any decision. If the input data type to the Abs block is Boolean, an
error occurs.
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Combinatorial Logic
The Combinatorial Logic block receives decision and condition coverage.
Decision coverage is based on achieving each output row of the truth table.
The decision coverage measures the number of time steps that each output
row of the truth table is set to the block output.

The condition coverage measures the number of time steps that each input
is false (equal to zero) and the number of times each input is true (not equal
to zero). If the Combinatorial Logic block has a single input element, the
Simulink Verification and Validation software reports only decision coverage,
because decision and condition coverage are equivalent.

If all truth table values are set to the block output for at least one time step,
decision coverage is 100%. Otherwise, the software reports the coverage as
the number of truth table values output during at least one time step, divided
by the total number of truth table values. Because this block always has at
least one value in the truth table as output, the minimum coverage reported
is one divided by the total number of truth table values.

If all block inputs are false for at least one time step and true for at least one
time step, condition coverage is 100%. Otherwise, the software reports the
coverage as achieving a false value at each input for at least one time step,
plus achieving a true value for at least one time step, divided by two raised
to the power of the total number of inputs (i.e., 2^number_of_inputs). The
minimum coverage reported is the total number of inputs divided by two
raised to the power of the total number of inputs.
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Dead Zone
The Dead Zone block receives decision coverage. The Simulink Verification
and Validation software reports decision coverage for the Start of dead zone
and End of dead zone parameters.

The Start of dead zone parameter specifies the lower limit of the dead zone.
For the Start of dead zone parameter, decision coverage measures:

• The number of time steps that the block input is greater than or equal to
the lower limit, indicating a true decision.

• The number of time steps that the block input is less than the lower limit,
indicating a false decision.

The End of dead zone parameter specifies the upper limit of the dead zone.
For the End of dead zone, decision coverage measures:

• The number of time steps that the block input is greater than the upper
limit, indicating a true decision.

• The number of time steps that the block input is less than or equal to the
upper limit, indicating a false decision.

When the upper limit is true, the software does not measure Start of dead
zone coverage for that time step. Therefore, the total number of Start of
dead zone decisions equals the number of time steps that the End of dead
zone is false.

If at least one time step is true and at least one time step is false, decision
coverage for each of the two individual decisions for the Dead Zone block is
100%. If no time steps are true, or if no time steps are false, decision coverage
is 50%. The software treats each element of a vector or matrix as a separate
coverage measurement.
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Direct Lookup Table (n-D)
The Direct Lookup Table (n-D) block receives lookup table coverage. For an
n-dimensional lookup table, the number of output break points is the product
of all the number of break points for each table dimension.

Lookup table coverage measures:

• The number of times during simulation that each combination of dimension
input values is between each of the break points.

• The number of times during simulation that each combination of dimension
input values is below the lowest break point and above the highest break
point for each table dimension.

The total number of coverage points for any n-dimensional lookup table is the
product of the number of break points in each table dimension plus one. In
the coverage report, an increasing white-to-green color scale, with six evenly
spaced data ranges starting with zero, indicates the number of time steps that
the software measures each interpolation or extrapolation point.

The software determines a percentage of total coverage by measuring the
total interpolation and extrapolation points that achieve a measurement of
at least one time step during simulation between a break point or beyond
the end points.

14-9



14 Model Objects That Receive Model Coverage

Discrete-Time Integrator
The Discrete-Time Integrator block receives decision coverage. Decision
coverage is based on the External reset and Limit output parameters. If
you set External reset to none, the Simulink Verification and Validation
software does not report decision coverage for the reset decision. Otherwise,
the decision coverage measures:

• The number of time steps that the block output is reset, indicating a true
decision.

• The number of time steps that the block output is not reset, indicating
a false decision.

If you do not select Limit output, the software does not report decision
coverage for that decision. Otherwise, the software reports decision coverage
for the Lower saturation limit and the Upper saturation limit.

For the Upper saturation limit, decision coverage measures:

• The number of time steps that the integration result is greater than or
equal to the upper limit, indicating a true decision.

• The number of time steps that the integration result is less than the upper
limit, indicating a false decision.

For the Lower saturation limit, decision coverage measures

• The number of time steps that the integration result is less than or equal to
the lower limit, indicating a true decision.

• The number of time steps that the integration result is greater than the
lower limit, indicating a false decision.

For a time step when the upper limit is true, the software does not measure
Lower saturation limit coverage. Therefore, the total number of lower limit
decisions equals the number of time steps that the upper limit is false.

If at least one time step is true and at least one time step is false, decision
coverage for each of the three individual decisions (Limit output, Lower
saturation limit, and Upper saturation limit) for the block is 100%. If no
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Discrete-Time Integrator

time steps are true, or if no time steps are false, decision coverage is 50%. The
software treats each element of a vector or matrix as a separate coverage
measurement.
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Enabled Subsystem
The Enabled Subsystem block receives decision, condition, and MCDC
coverage.

Decision coverage measures:

• The number of time steps that the block is enabled, indicating a true
decision.

• The number of time steps that the block is disabled, indicating a false
decision.

If at least one time step is true and at least one time step is false, decision
coverage is 100%. If no time steps are true, or if no time steps are false,
decision coverage is 50%.

The Simulink Verification and Validation software measures condition
coverage for the enable input only if the enable input is a vector. For the
enable input, condition coverage measures the number of time steps each
element of the enable input is true and the number of time steps each element
of the enable input is false. The software reports condition coverage based on
the total number of possible conditions and how many are true for at least one
time step and how many are false for at least one time step.

The software measures MCDC coverage for the enable input only if the enable
input is a vector. Because the enable of the subsystem is an OR of the vector
inputs, MCDC coverage is 100% if, during at least one time step, each vector
enable input is exclusively true and if, during at least one time step, all vector
enable inputs are false. For MCDC coverage measurement, the software
treats each element of the vector as a separate condition.
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Enabled and Triggered Subsystem
The Enabled and Triggered Subsystem block receives decision, condition, and
MCDC coverage. Decision coverage measures:

• The number of time steps that a trigger edge occurs while the block is
enabled, indicating a true decision.

• The number of time steps that a trigger edge does not occur while the block
is enabled, or the block is disabled, indicating a false decision.

If at least one time step is true and at least one time step is false, decision
coverage is 100%. If no time steps are true, or if no time steps are false,
decision coverage is 50%.

The software measures condition coverage for the enable input and for the
trigger input separately:

• For the enable input, condition coverage measures the number of time
steps the enable input is true and the number of time steps the enable
input is false.

• For the trigger input, condition coverage measures the number of time
steps the trigger edge occurs, indicating true, and the number of time steps
the trigger edge does not occur, indicating false.

The software reports condition coverage based on the total number of possible
conditions and how many conditions are true for at least one time step and
how many are false for at least one time step. The software treats each
element of a vector as a separate condition coverage measurement.

The software measures MCDC coverage for the enable input and for the
trigger input in combination. Because the enable input of the subsystem is an
AND of these two inputs, MCDC coverage is 100% if all of the following occur:

• During at least one time step, both inputs are true.

• During at least one time step, the enable input is true and the trigger edge
is false.

• During one time step, the enable input is false and the trigger edge is true.
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The software treats each vector element as a separate MCDC coverage
measurement. It measures each trigger edge element against each enable
input element. However, if the number of elements in both the trigger and
enable inputs exceeds 12, the software does not report MCDC coverage.
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Fcn
The Fcn block receives condition and MCDC coverage. The Simulink
Verification and Validation software reports condition or MCDC coverage for
Fcn blocks only if the top-level operator is Boolean (&&, ||, or !).

Condition coverage is based on input values or arithmetic expressions that are
inputs to Boolean operators in the block. The condition coverage measures:

• The number of time steps that each input to a Boolean operator is true
(not equal to zero).

• The number of time steps that each input to a Boolean operator is false
(equal to zero).

If all Boolean operator inputs are false for at least one time step and true for
at least one time step, condition coverage is 100%. Otherwise, the software
reports condition coverage based on the total number of possible conditions
and how many are true for at least one time step and how many are false for
at least one time step.

The software measures MCDC coverage for Boolean expressions within the
Fcn block. If, during at least one time step, each condition independently
sets the output of the expression to true and if, during at least one time
step, each condition independently sets the output of the expression to false,
MCDC coverage is 100%. Otherwise, the software reports MCDC coverage
based on the total number of possible conditions and how many times each
condition independently sets the output to true during at least one time
step and how many conditions independently set the output to false during
at least one time step.
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For Iterator, For Iterator Subsystem
The For Iterator block and For Iterator Subsystem receive decision coverage.
The Simulink Verification and Validation software measures decision
coverage for the loop condition value, which is determined by one of the
following:

• The iteration value being at or below the iteration limit, indicated as true.

• The iteration value being above the iteration limit, indicated as false.

The software reports the total number of times that each loop condition
evaluates to true and to false. If the loop condition evaluates to true at least
once and false at least once, decision coverage is 100%. If no loop conditions
are true, or if no loop conditions are false, decision coverage is 50%.
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If, If Action Subsystem
The If block that is used to execute an If Action Subsystem receives decision
coverage. The Simulink Verification and Validation software measures
decision coverage for the if condition and all elseif conditions defined in
the If block.

The software does not directly measure the else condition, because if there
are not elseif conditions, the else condition is directly the complement of
the if condition, or the else condition is the complement of the last elseif
condition.

The software reports the total number of time steps that each if and elseif
condition evaluates to true and to false. If the if or elseif condition evaluates
to true at least once, and evaluates to false at least once, decision coverage is
100%. If no if or elseif conditions are true, or if no if or elseif conditions
are false, decision coverage is 50%. If the previous if or elseif condition
never evaluates as false, an elseif condition can have 0% decision coverage.
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Interpolation Using Prelookup
The Interpolation Using Prelookup block receives lookup table coverage. For
an n-D lookup table, the number of output break points equals the product
of all the number of break points for each table dimension. The lookup table
coverage measures:

• The number of times during simulation that each combination of dimension
input values is between each of the break points.

• The number of times during simulation that each combination of dimension
input values is below the lowest break point and above the highest break
point for each table dimension.

The total number of coverage points for any n-dimensional lookup table is the
product of the number of break points in each table dimension plus one. In
the coverage report, an increasing white-to-green color scale, with six evenly
spaced data ranges starting with zero, indicates the number of time steps that
the software measures each interpolation or extrapolation point.

The software determines a percentage of total coverage by measuring the
total interpolation and extrapolation points that achieve a measurement of
at least one time step during simulation between a break point or beyond
the end points.
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Library-Linked Objects
Simulink blocks and Stateflow charts that are linked to library objects receive
the same coverage that they would receive if they were not linked to library
objects. The Simulink Verification and Validation software records coverage
individually for each library object in the model. If your model contains
multiple instances of the same library object, each instance receives its own
coverage data.
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Logical Operator
The Logical Operator block receives condition and MCDC coverage. The
Simulink Verification and Validation software measures condition coverage
for each input to the block. The condition coverage measures:

• The number of time steps that each input is true (not equal to zero).

• The number of time steps that each input is false (equal to zero).

If all block inputs are false for at least one time step and true for at least
one time step, the software condition coverage is 100%. Otherwise, the
software reports the condition coverage based on the total number of possible
conditions and how many are true at least one time step and how many are
false at least one time step.

The software measures MCDC coverage for all inputs to the block. If,
during at least one time step, each condition independently sets the output
of the block to true and if, during at least one time step, each condition
independently sets the output of the block to false, MCDC coverage is
100%. Otherwise, the software reports the MCDC coverage based on the
total number of possible conditions and how many times each one of them
independently set the output to true for at least one time step and how many
independently set the output to false for at least one time step.
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1-D Lookup Table
The 1-D Lookup Table block receives lookup table coverage; for a
one-dimensional lookup table, the number of input and output break points is
equal. Lookup table coverage measures:

• The number of times during simulation that the input and output values
are between each of the break points.

• The number of times during simulation that the input and output values
are below the lowest break point and above the highest break point.

The total number of coverage points for any one-dimensional lookup table is
the number of break points in the table plus one. In the coverage report, an
increasing white-to-green color scale, with six evenly spaced data ranges
starting with zero, indicates the number of time steps that the software
measures each interpolation or extrapolation point.

The software determines a percentage of total coverage by measuring the
total interpolation and extrapolation points that achieve a measurement of
at least one time step during simulation between a break point or beyond
the end points.
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2-D Lookup Table
The 2-D Lookup Table block receives lookup table coverage. For a
two-dimensional lookup table, the number of output break points equals the
number of row break points multiplied by the number of column inputs.
Lookup table coverage measures:

• The number of times during simulation that each combination of row input
and column input values is between each of the break points.

• The number of times during simulation that each combination of row input
and column input values is below the lowest break point and above the
highest break point for each row and column.

The total number of coverage points for any two-dimensional lookup table
is the number of row break points in the table plus one, multiplied by the
number of column break points in the table plus one. In the coverage report,
an increasing white-to-green color scale, with six evenly spaced data ranges
starting with zero, indicates the number of time steps that the software
measures each interpolation or extrapolation point.
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n-D Lookup Table
The n-D Lookup Table block receives lookup table coverage. For an
n-dimensional lookup table, the number of output break points equals the
product of all the number of break points for each table dimension. Lookup
table coverage measures:

• The number of times during simulation that each combination of dimension
input values is between each of the break points.

• The number of times during simulation that each combination of dimension
output values is below the lowest break point and above the highest break
point for each table dimension.

The total number of coverage points for any n-dimensional lookup table is the
product of the number of break points in each table dimension plus one. In
the coverage report, an increasing white-to-green color scale, with six evenly
spaced data ranges starting with zero, indicates the number of time steps that
the software measures each interpolation or extrapolation point.

The software determines a percentage of total coverage by measuring the
total interpolation and extrapolation points that achieve a measurement of
at least one time step during simulation between a break point or beyond
the end points.
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MATLAB Function
For information about the type of coverage that the Simulink Verification
and Validation software reports for the MATLAB Function block, see “Model
Coverage for MATLAB Functions” on page 16-20.
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MinMax
The MinMax block receives decision coverage. Decision coverage is based on
passing each input to the output of the block. The decision coverage measures
the number of time steps that the simulation passes each input to the block
output. The number of decision points is based on the number of inputs to the
block and whether they are scalar, vector, or matrix.

If all inputs are passed to the block output for at least one time step, the
Simulink Verification and Validation software reports the decision coverage
as 100%. Otherwise, the software reports the coverage as the number of
inputs passed to the output during at least one time step, divided by the
total number of inputs.
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Model
The Model block does not receive coverage directly; the model that the block
references receives coverage. If the simulation mode for the referenced model
is set to Normal, the Simulink Verification and Validation software reports
coverage for all objects within the referenced model that receive coverage.
If the simulation mode is set to any value other than Normal, the software
cannot measure coverage for the referenced model.

In the Coverage Settings dialog box, select the referenced models for which
you want to report coverage. The software generates a coverage report for
each referenced model you select.

If your model contains multiple instances of the same referenced model,
the software records coverage for all instances of that model where the
simulation mode of the Model block is set to Normal. The coverage report
for that referenced model combines the coverage data for all Normal mode
instances of that model.

The coverage reports for referenced models are linked from a summary report
for the parent model.

Note For details on how to select referenced models to report coverage, see
“Coverage for referenced models” on page 15-5.
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Multiport Switch
The Multiport Switch block receives decision coverage. Decision coverage is
based on passing each input, excluding the first control input, to the output
of the block. The decision coverage measures the number of time steps that
each input is passed to the block output. The number of decision points is
based on the number of inputs to the block and whether the control input is
scalar or vector.

If all inputs, excluding the first control input, are passed to the block output
for at least one time step, decision coverage is 100%. Otherwise, the Simulink
Verification and Validation software reports coverage as the number of
inputs passed to the output during at least one time step, divided by the
total number of inputs minus one.
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Proof Assumption
The Proof Assumption block receives Simulink Design Verifier coverage.
Simulink Design Verifier coverage is based on the points and intervals
defined in the block dialog box. Simulink Design Verifier coverage measures
the number of time steps that each point or interval defined in the block is
satisfied. The total number of objective outcomes is based on the number of
points or intervals defined in the Proof Assumption block.

If all points and intervals defined in the block are satisfied for at least
one time step, Simulink Design Verifier coverage is 100%. Otherwise, the
Simulink Verification and Validation software reports coverage as the number
of points and intervals satisfied during at least one time step, divided by the
total number of points and intervals defined for the block.
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Proof Objective
The Proof Objective block receives Simulink Design Verifier coverage.
Simulink Design Verifier coverage is based on the points and intervals
defined in the block dialog box. Simulink Design Verifier coverage measures
the number of time steps that each point or interval defined in the block is
satisfied. The total number of objective outcomes is based on the number of
points or intervals defined in the Proof Objective block.

If all points and intervals defined in the block are satisfied for at least
one time step, Simulink Design Verifier coverage is 100%. Otherwise, the
Simulink Verification and Validation software reports coverage as the number
of points and intervals satisfied during at least one time step, divided by the
total number of points and intervals defined for the block.
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Rate Limiter
The Rate Limiter block receives decision coverage. The Simulink Verification
and Validation software reports decision coverage for the Rising slew rate
and Falling slew rate parameters.

For the Rising slew rate, decision coverage measures:

• The number of time steps that the block input changes more than or equal
to the rising rate, indicating a true decision.

• The number of time steps that the block input changes less than the rising
rate, indicating a false decision.

For the Falling slew rate, decision coverage measures:

• The number of time steps that the block input changes less than or equal to
the falling rate, indicating a true decision.

• The number of time steps that the block input changes more than the
falling rate, indicating a false decision.

The software does not measure Falling slew rate coverage for a time step
when the Rising slew rate is true. Therefore, the total number of Falling
slew rate decisions equals the number of time steps that the Rising slew
rate is false.

If at least one time step is true and at least one time step is false, decision
coverage for each of the two individual decisions for the block is 100%. If no
time steps are true, or if no time steps are false, decision coverage is 50%. The
software treats each element of a vector or matrix as a separate coverage
measurement.
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Relay
The Relay block receives decision coverage. The Simulink Verification and
Validation software reports decision coverage for the Switch on point and
the Switch off point parameters.

For the Switch on point, decision coverage measures:

• The number of consecutive time steps that the block input is greater than
or equal to the Switch on point, indicating a true decision.

• The number of consecutive time steps that the block input is less than the
Switch on point, indicating a false decision.

For the Switch off point, decision coverage measures:

• The number of consecutive time steps that the block input is less than or
equal to the Switch off point, indicating a true decision.

• The number of consecutive time steps that the block input is greater than
the Switch off point, indicating a false decision.

The software does not measure Switch off point coverage for a time step
when the switch on threshold is true. Therefore, the total number of Switch
off point decisions equals the number of time steps that the Switch on
point is false.

If at least one time step is true and at least one time step is false, decision
coverage for each of the two individual decisions for the block is 100%. If no
time steps are true, or if no time steps are false, decision coverage is 50%. The
software treats each element of a vector or matrix as a separate coverage
measurement.
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Saturation
The Saturation block receives decision coverage. The Simulink Verification
and Validation software reports decision coverage for the Lower limit and
Upper limit parameters.

For the Upper limit, decision coverage measures:

• The number of time steps that the block input is greater than or equal to
the upper limit, indicating a true decision.

• The number of time steps that the block input is less than the upper limit,
indicating a false decision.

For the Lower limit, decision coverage measures:

• The number of time steps that the block input is greater than the lower
limit, indicating a true decision.

• The number of time steps that the block input is less than or equal to the
lower limit, indicating a false decision.

The software does not measure Lower limit coverage for a time step when
the upper limit is true. Therefore, the total number of Lower limit decisions
equals the number of time steps that the Upper limit is false.

If at least one time step is true and at least one time step is false, decision
coverage for each of the two individual decisions for the Saturation block is
100%. If no time steps are true, or if no time steps are false, decision coverage
is 50%. The software treats each element of a vector or matrix as a separate
coverage measurement.
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Simulink Design Verifier Functions in MATLAB Function
Blocks

The following functions in MATLAB Function blocks receive Simulink Design
Verifier coverage:

• sldv.condition

• sldv.test

• sldv.assume

• sldv.prove

Each of these functions evaluates an expression expr, for example,
sldv.test(expr), where expr is any valid Boolean MATLAB expression.
Simulink Design Verifier coverage measures the number of time steps that
the expression expr evaluates to true.

If expr is true for at least one time step, Simulink Design Verifier coverage for
that function is 100%. Otherwise, the Simulink Verification and Validation
software reports coverage for that function as 0%.
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Switch
The Switch block receives decision coverage. Decision coverage is based on
the control input to block. Decision coverage measures:

• The number of time steps that the control input evaluates to true.

• The number of time steps the control input evaluates to false.

The number of decision points is based on whether the control input is scalar
or vector.

If the control input evaluates to true for at least one time step and evaluates
to false for at least one time step, decision coverage is 100%. If no time steps
are true, or if no time steps are false, decision coverage is 50%. If the control
input is a vector, the Simulink Verification and Validation software reports
this coverage individually for each vector element.

14-34



SwitchCase, SwitchCase Action Subsystem

SwitchCase, SwitchCase Action Subsystem
The SwitchCase block and SwitchCase Action Subsystem receive decision
coverage. The Simulink Verification and Validation software measures
decision coverage individually for each switch case defined in the block and
also for the default case.

The software reports the total number of time steps that each case evaluates
to true. If each case, including the default case, evaluates to true at least once,
decision coverage is 100%. The software determines the decision coverage
by the number of cases that evaluate true for at least one time step divided
by the total number of cases.
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Test Condition
The Test Condition block receives Simulink Design Verifier coverage.
Simulink Design Verifier coverage is based on the points and intervals
defined in the block dialog box. Simulink Design Verifier coverage measures
the number of time steps that each point or interval defined in the block is
satisfied. The total number of objective outcomes is based on the number of
points or intervals defined in the Test Condition block.

If all points and intervals defined in the block are satisfied for at least
one time step, Simulink Design Verifier coverage is 100%. Otherwise, the
Simulink Verification and Validation software reports coverage as the number
of points and intervals satisfied during at least one time step, divided by the
total number of points and intervals defined for the block.
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Test Objective
The Test Objective block receives Simulink Design Verifier coverage.
Simulink Design Verifier coverage is based on the points and intervals
defined in the block dialog box. Simulink Design Verifier coverage measures
the number of time steps that each point or interval defined in the block is
satisfied. The total number of objective outcomes is based on the number of
points or intervals defined in the Test Objective block.

If all points and intervals defined in the block are satisfied for at least
one time step, Simulink Design Verifier coverage is 100%. Otherwise, the
Simulink Verification and Validation software reports coverage as the number
of points and intervals satisfied during at least one time step, divided by the
total number of points and intervals defined for the block.
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Triggered Models
A Model block can reference a model that contains edge-based trigger ports
at the root level of the model. Triggered models receive decision, condition,
and MCDC coverage.

Decision coverage measures:

• The number of time steps that the referenced model is triggered, indicating
a true decision.

• The number of time steps that the referenced model is not triggered,
indicating a false decision.

If at least one time step is true and at least one time step is false, decision
coverage for the Model block that references the triggered model is 100%. If
no time steps are true, or if no time steps are false, decision coverage is 50%.

Only if the trigger input is a vector, the Simulink Verification and Validation
software measures condition coverage for the trigger port in the referenced
model. For the trigger port, condition coverage measures:

• The number of time steps that each element of the trigger port is true.

• The number of time steps that each element of the trigger port is false.

The software reports condition coverage based on the total number of possible
conditions and how many are true for at least one time step and how many
are false for at least one time step.

If the trigger port is a vector, the software measures MCDC coverage for the
trigger port only. Because the trigger port of the referenced model is an OR of
the vector inputs, if, during at least one time step, each vector trigger port is
exclusively true and if, during at least one time step, all vector trigger port
inputs are false, MCDC coverage is 100%. The software treats each element
of the vector as a separate condition for MCDC coverage measurement.
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Triggered Subsystem
The Triggered Subsystem block receives decision, condition, and MCDC
coverage.

Decision coverage measures:

• The number of time steps that the block is triggered, indicating a true
decision.

• The number of time steps that the block is not triggered, indicating a false
decision.

If at least one time step is true and at least one time step is false, decision
coverage is 100%. If no time steps are true, or if no time steps are false,
decision coverage is 50%.

The Simulink Verification and Validation software measures condition
coverage for the trigger input only if the trigger input is a vector. For the
trigger input, condition coverage measures:

• The number of time steps that each element of the trigger edge is true.

• The number of time steps that each element of the trigger edge is false.

The software reports condition coverage based on the total number of possible
conditions and how many are true for at least one time step and how many
are false for at least one time step.

If the trigger input is a vector, the software measures MCDC coverage for the
trigger input only. Because the trigger edge of the subsystem is an OR of the
vector inputs, if, during at least one time step, each vector trigger edge input
is exclusively true and if, during at least one time step, all vector trigger edge
inputs are false, MCDC coverage is 100%. The software treats each element
of the vector as a separate condition for MCDC coverage measurement.
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While Iterator, While Iterator Subsystem
The While Iterator block and While Iterator Subsystem receive decision
coverage. Decision coverage is measured for the while condition value, which
is determined by the while condition being satisfied (true), or the while
condition not being satisfied (false). Simulink Verification and Validation
software reports the total number of times that each while condition
evaluates to true and to false. If the while condition evaluates to true at
least once, and false at least once, decision coverage for the while condition
is 100%. If no while conditions are true, or if no while conditions are false,
decision coverage is 50%.

If the iteration limit is exceeded (true) or is not exceeded (false), the software
measures decision coverage independently. If the iteration limit evaluates to
true at least once, and false at least once, decision coverage for the iteration
limit is 100%. If no iteration limits are true, or if no iteration limits are false,
decision coverage is 50%. If you setMaximum number of iterations to -1
(no limit), the decision coverage for the iteration limit is true for all iterations
and false for zero iterations, and decision coverage is 50%.
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Model Objects That Do Not Receive Coverage
The Simulink Verification and Validation software cannot record coverage
for blocks that are not listed in Chapter 14, “Model Objects That Receive
Model Coverage”. The following table identifies specific model objects that do
not receive coverage.

Model object Does not receive coverage...

Model blocks When the Simulation mode
parameter specifies Accelerator.

Coverage for Model blocks is the sum
of the coverage data for the contents
of the referenced model.

Subsystem block When theRead/Write Permissions
parameter is set to NoReadOrWrite.
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• “Coverage Settings Dialog Box” on page 15-2

• “Coverage Tab” on page 15-3

• “Results Tab” on page 15-8

• “Reporting Tab” on page 15-10

• “Options Tab” on page 15-15

• “Filter Tab” on page 15-18
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Coverage Settings Dialog Box
Before starting a model coverage analysis, you must specify several model
coverage recording and reporting options. In a Simulink model, select
Tools > Coverage Settings. The Coverage Settings dialog box opens, with
the Coverage tab displayed.

The following sections describe the settings for each tab in the Coverage
Settings dialog box.
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Coverage Tab
On the Coverage tab, select the model coverages calculated during
simulation.
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Coverage for this model
Instructs the software to gather and report the model coverages that you
specify during simulation. When you select the Coverage for this model
option, the Select Subsystem button and the Coverage metrics section of
the Coverage pane become available.

Select Subsystem
Specifies the subsystem for which the software gathers and reports coverage
data. When you select the Coverage for this model option, the software, by
default, generates coverage data for the entire model.

To restrict coverage reporting to a particular subsystem:

1 On the Coverage tab, click Select Subsystem.

The Subsystem Selection dialog box opens.

2 In the Subsystem Selection dialog box, select the subsystem for which you
want to enable coverage reporting and click OK.
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Coverage for referenced models
Causes the software to record and report the model coverages that you specify
for referenced models during simulation. When you select the Coverage for
referenced models option, the Select Models button and the Coverage
metrics section of the Coverage tab become available.

Select Models
Click to specify the referenced models for which the Simulink Verification
and Validation software records and reports coverage data. When you select
Coverage for referenced models, the software, by default, generates
coverage data for all referenced models where the simulation mode of the
Model block is set to Normal.

To enable coverage reporting for particular referenced models:

1 On the Coverage pane, click Select Models.
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2 In the Select Models for Coverage Analysis dialog box, select the referenced
models for which you want to record coverage.

The icon next to the model name indicates the simulation mode for that
referenced model. You can select only referenced models whose simulation
mode is set to Normal.

If you have multiple Model blocks that reference the same model and whose
simulation mode is set to Normal, selecting or clearing one check box for
that model causes the check boxes for all Normal mode instances of that
model to be selected or cleared.
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3 Click OK to close the Select Models for Coverage Analysis dialog box and
return to the Coverage Settings dialog box.

Coverage for MATLAB files
Enables coverage for any external functions in your model that MATLAB
functions call. The MATLAB functions may be defined in a MATLAB Function
block or in a Stateflow chart.

You must select either Coverage for this model or Coverage for
referenced models to select the Coverage for MATLAB files option.

Coverage metrics
Select the types of test case coverage analysis that you want the tool to
perform (see “Types of Model Coverage” on page 13-4). The Simulink
Verification and Validation software gathers and reports those types of
coverage for the subsystem, model, and referenced models.

Note To specify different types of coverage analysis for each of the referenced
models in a hierarchy, use the cv.cvtestgroup and cvsimref functions. For
more information, see “Using Model Coverage Commands for Referenced
Models” on page 19-13.
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Results Tab
On the Results tab, select the destination for model coverage results.
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Save cumulative results in workspace variable
Causes model coverage to accumulate and save the results of successive
simulations in a workspace variable. You specify the workspace variable in
the cvdata object name field.

Save last run in workspace variable
Causes model coverage to save the results of the last simulation run in a
workspace variable. You specify that workspace variable in the cvdata
object name field below.

Increment variable name with each simulation
Causes the Simulink Verification and Validation software to increment the
name of the coverage data object variable that saves the coverage data from
last run with each simulation, so that the current simulation run does not
overwrite the results of the previous run.

Update results on pause
Causes the model coverage results to be recorded up to the point at which
you pause the simulation for the first time. When you resume simulation
and later pause or stop, the model coverage report reappears, with coverage
results up to the current pause or stop time.

Display coverage results using model coloring
Causes coloring of Simulink blocks according to their level of model coverage,
after simulation. Blocks highlighted in light green received full coverage
during testing. Blocks highlighted in light red received incomplete coverage.
See “Viewing Coverage Results in a Model” on page 16-5.
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Reporting Tab
On the Reporting tab, specify whether the model coverage tool generates an
HTML report and what data the report includes.
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Generate HTML report
Causes the Simulink Verification and Validation software to create an HTML
report containing the coverage data. At the end of the simulation, the report
opens in the MATLAB Web browser. Click the Settings button to select
various reporting options.

Settings
On the Report tab, click Settings to open the HTML Settings dialog box. In
the HTML Settings dialog box, choose model coverage report options.
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Option Description

Include each test in the model
summary

At the top of the HTML report,
the model hierarchy table includes
columns listing the coverage metrics
for each test. If you do not select this
option, the model summary reports
only the total coverage.

Produce bar graphs in the model
summary

Causes the model summary to
include a bar graph for each coverage
result for a visual representation of
the coverage.

Use two color bar graphs (red,
blue)

Red and blue bar graphs are
displayed in the report instead of
black and white bar graphs.

Display hit/count ratio in the
model summary

Reports coverage numbers as both a
percentage and a ratio, for example,
67% (8/12).

Do not report fully covered
model objects

The coverage report includes only
model objects that the simulation
does not cover fully, useful when
developing tests, because it reduces
the size of the generated reports.

Include cyclomatic complexity
numbers in summary

Includes the cyclomatic complexity
(see “Types of Model Coverage”
on page 13-4) of the model and its
top-level subsystems and charts in
the report summary. A cyclomatic
complexity number shown in
boldface indicates that the analysis
considered the subsystem itself
to be an object when computing
its complexity. This occurs for
atomic and conditionally executed
subsystems, as well as for Stateflow
Chart blocks.
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Option Description

Include cyclomatic complexity
numbers in block details

Includes the cyclomatic complexity
metric in the block details section of
the report.

Filter Stateflow events from
report

Excludes coverage data on Stateflow
events.

Cumulative Runs
Displays the coverage results from successive simulations in the report.
For more information, see “Save cumulative results in workspace variable”
on page 15-9.

On the Results tab, if you select the Save cumulative results in
workspace variable check box, a coverage running total is updated with
new results at the end of each simulation. However, if you change model or
block settings between simulations that are incompatible with settings from
previous simulations and affect the type or number of coverage points, the
cumulative coverage resets.

You can make cumulative coverage results persist between MATLAB
sessions. The cvload parameter RESTORETOTAL must be 1 in order to restore
cumulative results. At the end of the sessions, use cvsave to save results to a
file. At the beginning of the session, cvload to load the results.

When you save the coverage results to a file using cvsave and a model name
argument, the file also contains the cumulative running total. When you load
that file into the coverage tool using cvload, you can select whether you want
to restore the running total from the file.

When you restore a running total from saved data, the saved results are
reflected in the next cumulative report. If a running total already exists when
you restore a saved value, the existing value is overwritten.

Whenever you report on more than one single simulation, the coverage
displayed for truth tables and lookup-table maps is based on the total coverage
of all the reported runs. For cumulative reports, this information includes all
the simulations where cumulative results are stored.
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You can also calculate cumulative coverage results at the command line,
through the + operator:

covdata1 = cvsim(test1);
covdata2 = cvsim(test2);
cvhtml('cumulative_report', covdata + covdata2);

Last run
Include in the report only the results of the most recent simulation run.

Additional data to include in report
Specify names of coverage data from previous runs to include in the current
report along with the current coverage data. Each entry creates a new set of
columns in the report.
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Options Tab
On the Options tab, select options for model coverage reports.
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Treat Simulink Logic blocks as short-circuited
The Treat Simulink Logic blocks as short-circuited option applies only
to condition and MCDC coverage. If you select this option, coverage analysis
treats Simulink logic blocks as if the block ignores remaining inputs when
the previous inputs alone determine the block’s output. For example, if the
first input to a Logical Operator block whose Operator parameter specifies
AND is false, MCDC coverage analysis ignores the values of the other inputs
when determining MCDC coverage for a test case.

If you enable this feature and logic blocks are short-circuited while collecting
model coverage, you may not be able to achieve 100% coverage for that block.

To generate code from a model, select this option. Also select this option for
where you want the MCDC coverage analysis to approximate the degree of
coverage that your test cases achieve for the generated code (most high-level
languages short-circuit logic expressions).

Note A test case that does not achieve full MCDC coverage for
non-short-circuited logic expressions might achieve full coverage for
short-circuited expressions.

Warn when unsupported blocks exist in model
Select this option to warn you at the end of the simulation that the model
contains blocks that require coverage analysis but are not currently covered
by the tool.

Force block reduction off
To achieve faster execution during model simulation and in generated code, in
the Configuration Parameters dialog box, on the Optimization pane, enable
the Block reduction parameter. The Simulink software collapses certain
groups of blocks into a single, more efficient block, or removes them entirely.

One of the model coverage options, Force block reduction off, allows you to
ignore the Block reduction parameter when collecting model coverage.
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If you do not enable the Block reduction parameter, or if you select Force
block reduction off, the Simulink Verification and Validation software
provides coverage data for every block in the model that collects coverage.

If you enable the Block reduction parameter and do not set Force block
reduction off, the coverage report lists the reduced blocks that would have
collected coverage.

The model coverage report identifies any reduced blocks. For an example of a
reduced blocks report, see “Block Reduction” on page 17-29.
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Filter Tab
On the Filter tab, enter the file name that specifies the model objects to be
excluded from model coverage collection. You can use the same filter file
for multiple models.
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Filter file name
If you enable coverage for this model, you can create a filter file or open an
existing filter file. In your model, you can then specify objects that you want
to exclude from model coverage collection during simulation.

In the Filter file name field, enter the full path to the MAT-file that specifies
the model objects to be excluded from model coverage collection. Or, click
Browse to navigate to the file. You can only open MAT-files that have the
valid filter file format.

If the current model has a filter file already associated with it, the file name
appears in the Filter file name field, and the Open in Editor link is
displayed. To edit the coverage filter settings, click this link.

If the Open in Editor link is unavailable, go to the Coverage tab. Select
Coverage for this model to enable coverage for the current model. You can
then enter the filter file name and edit the file.
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• “Model Coverage Collection Workflow” on page 16-2

• “Creating and Running Test Cases” on page 16-3

• “Viewing Coverage Results in a Model” on page 16-5

• “Model Coverage for Multiple Instances of a Referenced Model” on page
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• “Model Coverage for MATLAB Functions” on page 16-20

• “Model Coverage for Stateflow Charts” on page 16-40
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Model Coverage Collection Workflow
To develop effective tests with model coverage:

1 Develop one or more test cases for your model. (See “Creating and Running
Test Cases” on page 16-3.)

2 Run the test cases to verify that the model behavior is correct.

3 Analyze the coverage reports produced by the Simulink Verification and
Validation software.

4 Using the information in the coverage reports, modify the test cases to
increase their coverage or add new test cases to cover areas not currently
covered.

5 Repeat the preceding steps until you are satisfied with the coverage of
your test suite.

Note The Simulink Verification and Validation software comes with an
online demonstration of model coverage to validate model tests. To run the
demo, at the MATLAB prompt, enter simcovdemo.
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Creating and Running Test Cases
To create and run test cases, model coverage provides two MATLAB
commands, cvtest and cvsim. The cvtest command creates test cases that
the cvsim command runs. (See “Running Tests with cvsim” on page 19-5.)

You can also run the coverage tool interactively:

1 Open the sldemo_fuelsys model.

2 In the Simulink model window, select Tools > Coverage Settings.

The Coverage Settings dialog box Coverage tab appears.

3 Select Coverage for this model: sldemo_fuelsys, which enables:

• The Select Subsystem button

• The metrics options in the Coverage metrics section

• Fields on the Results, Reporting, and Options tabs of the Coverage
Settings dialog box

4 Under Coverage metrics, select the types of coverage that you want to
record in the coverage report.

For a complete description of all coverage options in the Coverage Settings
dialog box, see Chapter 15, “Setting Model Coverage Options”.

5 Click OK.

6 In the Simulink model window, select Start > Simulation or on the
Simulink toolbar, click the Start button to start simulating the model.

If you specify to report model coverage, the Simulink Verification
and Validation software saves coverage data for the current run
in the workspace object covdata and cumulative coverage data in
covCumulativeData, by default. At the end of the simulation, this data
appears in an HTML report that opens in a browser window.
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Note You cannot run simulations if you select both model coverage
reporting and acceleration options. If you select Accelerator mode in the
model window, Simulink does not record coverage.

You cannot select both block reduction and conditional branch input
optimization when you perform coverage analysis because they interfere
with coverage recording.
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Viewing Coverage Results in a Model

In this section...

“Overview of Model Coverage Highlighting” on page 16-5

“Enabling Coverage Highlighting” on page 16-6

“Examples: Model Coverage Coloring” on page 16-6

“Coverage Display Window” on page 16-9

Overview of Model Coverage Highlighting
When you simulate a Simulink model, you can configure your model to
provide visual results that allow you to see at a glance which objects recorded
100% coverage. After the simulation:

• In the model window, model objects are highlighted in certain colors
according to what coverage was recorded:

- Light green indicates that an object received full coverage during testing.

- Light red indicates that an object received incomplete coverage.

- Gray indicates that an object was filtered from coverage.

- Objects with no color highlighting received no coverage.

• When you click a colored object, the Coverage Display Window provides
details about the coverage recorded for that block. For subsystems and
Stateflow charts, the Coverage Display Window lists the summary coverage
for all objects in that subsystem or chart. For other blocks, the Coverage
Display Window list specific details about the objects that did not receive
100% coverage.

The simulation highlights blocks that received the following types of model
coverage:

• “Decision Coverage (DC)” on page 13-5

• “Condition Coverage (CC)” on page 13-5

• “Modified Condition/Decision Coverage (MCDC)” on page 13-5
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• “Simulink Design Verifier Coverage” on page 13-8

Enabling Coverage Highlighting
To enable the model coverage colored diagram display:

1 In the Simulink window, from the Tools menu, select Coverage Settings.

2 In the Coverage tab, select Coverage for this model.

3 Select the Results tab.

4 Select Display coverage results using model coloring. This is the
default setting.

After you have enabled the coverage coloring, simulate your model. In the
model, you can see at a glance which objects received full, partial, or no
coverage.

Examples: Model Coverage Coloring
The following sections show examples of model objects that

Green: Full Coverage
In this example, the Switch block received 100% coverage, as indicated by the
green highlighting and the information in the Coverage Display Window.
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Red: Partial Coverage
In this example, the control_logic Stateflow chart received the following
coverage:

• Decision: 25%

• Condition: 21%

• MCDC: 0%

Inside the control_logic subsystem, the Pressure substate was never fail.
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In the next example, in the Multiport Switch block, the second and third data
ports were never executed.
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Gray: Filtered Coverage
In this example, the fuel_rate_control subsystem is highlighted in gray
because it was filtered out of coverage recording.

Coverage Display Window
After simulating the model and recording coverage, by default, the Coverage
Display Window is the top-most visible window. When you click an object
that recorded coverage, the Coverage Display Window displays details of the
coverage recorded during simulation.

In the Coverage Display Window, you can:

• Configure the window so it is not always the top-most visible window. Next
to Always on top, click and removing the check.
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• Configure the window to display coverage information when you click an
object that recorded coverage. Click and select Click.

• Configure the window to display coverage information when you hover your
cursor on an object that recorded coverage. Click and select Focus.

• Close the window. Press Alt+F4.

• Close the window and remove all highlighting on the model. Select
View > Remove highlighting.
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Model Coverage for Multiple Instances of a Referenced
Model

In this section...

“About Coverage for Model Blocks” on page 16-11

“Example: Recording Coverage for Multiple Instances of a Referenced
Model” on page 16-11

About Coverage for Model Blocks
Model blocks do not receive coverage directly; if you set the simulation mode
of the Model block to Normal, the Simulink Verification and Validation
software records coverage for the model referenced from the Model block. If
the simulation mode for the Model block is anything other than Normal, the
software does not record coverage for the referenced model.

Your Simulink model can contain multiple Model blocks with Normal
simulation mode that reference the same model. When the software records
coverage, each instance of the referenced model can be exercised with
different inputs or parameters, possibly resulting in additional coverage for
the referenced model.

The Simulink Verification and Validation software records coverage for all
instances of the referenced model and combines the coverage data for that
referenced model in the final results.

Example: Recording Coverage for Multiple Instances
of a Referenced Model
To see how this works, simulate a model twice. The first time, you record
coverage for one Model block in Normal simulation mode. The second time,
you record coverage for two Model blocks in Normal simulation mode. Both
Model blocks reference the same model.

• “Recording Coverage for the First Instance of the Referenced Model” on
page 16-12
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• “Recording Coverage for the Second Instance of the Referenced Model” on
page 16-16

Recording Coverage for the First Instance of the Referenced
Model
Record coverage for the Counter1 block:

1 Open the sldemo_mdlref_datamngt demo model:

sldemo_mdlref_datamngt

This model contains three Model blocks that reference the
sldemo_mdlref_counter_datamngt model. The corners of each Model
block indicate the value of their Simulation mode parameter:

• Counter1 — Simulation mode: Normal

• Counter2 — Simulation mode: Accelerator

• Counter3 — Simulation mode: Accelerator

2 Configure the sldemo_mdlref_datamngt model to record coverage during
simulation:

a In the model window, select Tools > Coverage Settings.

b On the Coverage tab, select:

• Coverage for this model: sldemo_mdlref_datamngt

• Coverage for referenced models

c Under Coverage for referenced models, click Select Models. In the
Select Models for Coverage Analysis dialog box, you can select only those
referenced models whose simulation mode is Normal. In this example,
only the first instance of sldemo_mdlref_counter_datamngt is available
for recording coverage.
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d On the Reporting tab, select Last Run so that you can compare
coverage data from individual simulations, not accumulated coverage
for successive simulations.

e Click OK to exit the Select Models for Coverage Analysis dialog box.

3 Click OK to save your coverage settings and exit the Coverage Settings
dialog box.

4 Simulate the sldemo_mdlref_datamngt model.

When the simulation is complete, the HTML coverage report opens. The
coverage data for the referencedmodel, sldemo_mdlref_counter_datamngt,
shows that the model achieved 69% coverage.

5 Click the hyperlink in the report for the referenced model.

The detailed coverage report for the referenced model opens. Note the
following about the coverage for the Range Check subsystem:

• The Saturate Count block executed 100 times. This block has four
Boolean decisions. Decision coverage was 50%, because two of the four
decisions were never recorded:

– The decision input > lower limit was never false.

– The decision input >= upper limit was never true.
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• The DetectOverflow function executed 50 times. This script has five
decisions. The DetectOverflow script achieved 60% coverage because
two of the five decisions were never recorded:

– The expression count >= CounterParams.UpperLimit was never
true.

– The expression count > CounterParams.LowerLimit was never
false.
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Recording Coverage for the Second Instance of the Referenced
Model
Set the simulation mode of a second Model block, Counter2, to Normal and
simulate the model. In this example, the Counter2 block adds to the coverage
for the model referenced from both Model blocks:

1 In the model window for sldemo_mdlref_datamngt, right-click the
Counter2 block and select ModelReference Parameters.

The Function Block Parameters dialog box opens.

2 To make sure the software records coverage for the Counter2 block, set the
Simulation mode parameter to Normal.

3 Click OK to save your change and exit the Function Block Parameters
dialog box.

The corners of the Counter2 block change to indicate that the simulation
mode for this block is Normal.

4 To make sure that the software records coverage for both instances of
this model:

a Select Tools > Coverage Settings.

b On the Coverage pane, under Coverage for referenced models,
click Select Models.

In the Select Models for Coverage Analysis dialog box, both instances of
the referenced model, sldemo_mdlref_counter_datamngt, are selected.
If you have multiple instances of a referenced model in Normal mode,
you can choose to record coverage for all of them or none of them.

c Click OK to close the Select Models for Coverage Analysis dialog box.

5 Simulate the sldemo_mdlref_datamngt model again.

6 When the simulation is complete, open the HTML coverage report.

The referenced model, sldemo_mdlref_counter_datamngt achieved 85%
coverage. Note the following about the coverage data for the Range Check
subsystem:
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• The Saturate Count block executed 179 times. The simulation of the
Counter2 block executed the Saturate Count block an additional 79
times, for a total of 179 executions.

The decision input >= upper limit was true 21 times during this
simulation, compared to 0 during the first simulation. The fourth
decision input > lower limit was still never false. Three out of four
decisions were recorded during simulation, so this block achieved 75%
coverage.

• The DetectOverflow function executed 100 times. The simulation of the
Counter2 block executed the DetectOverflow function an additional
50 times.

The DetectOverflow function has five decisions. The expression
count >= CounterParams.UpperLimit was true 21 times during this
simulation, compared to 0 during the first simulation. The expression
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count > CounterParams.LowerLimit was never false. Four out of
five decisions were recorded during simulation, so the DetectOverflow
function achieved 80% coverage.
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Model Coverage for MATLAB Functions

In this section...

“About Model Coverage for MATLAB Functions” on page 16-20

“Types of Model Coverage for MATLAB Functions” on page 16-20

“How to Collect Coverage for MATLAB Functions” on page 16-22

“Examples: Model Coverage for MATLAB Functions” on page 16-23

About Model Coverage for MATLAB Functions
The Simulink Verification and Validation software simulates a Simulink
model and reports model coverage data for the decisions and conditions of
code in MATLAB Function blocks. Model coverage only supports coverage for
MATLAB functions configured for code generation.

For example, consider the following if statement:

if (x > 0 || y > 0)
reset = 1;

The if statement contains a decision with two conditions (x > 0 and y > 0).
The Simulink Verification and Validation software ensures that all decisions
and conditions are taken during the simulation of the model.

Types of Model Coverage for MATLAB Functions
The types of model coverage that the Simulink Verification and Validation
software records for MATLAB functions configured for code generation are:

• “Decision Coverage” on page 16-20

• “Condition and MCDC Coverage” on page 16-21

• “Simulink® Design Verifier Coverage” on page 16-21

Decision Coverage
During simulation, the following MATLAB Function block statements are
tested for decision coverage:
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• Function header — Decision coverage is 100% if the function or subfunction
is executed.

• if — Decision coverage is 100% if the if expression evaluates to true at
least once, and false at least once.

• switch — Decision coverage is 100% if every switch case is taken,
including the fall-through case.

• for— Decision coverage is 100% if the equivalent loop condition evaluates
to true at least once, and false at least once.

• while — Decision coverage is 100% if the equivalent loop condition
evaluates to true at least once, and evaluates to false at least once.

Condition and MCDC Coverage
During simulation, in the MATLAB Function block function, the following
logical conditions are tested for condition and MCDC coverage:

• if statement conditions

• while statement conditions

Simulink Design Verifier Coverage
The following MATLAB functions are active in code generation and in
Simulink Design Verifier:

• sldv.condition

• sldv.test

• sldv.assume

• sldv.prove

When you specify the Simulink Design Verifier coverage metric in the
Coverage Settings dialog box, the Simulink Verification and Validation
software records coverage for these functions.

Each of these functions evaluates an expression expr, for example,
sldv.test(expr), where expr is any valid Boolean MATLAB expression.
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Simulink Design Verifier coverage measures the number of time steps that
the expression expr evaluates to true.

If expr is true for at least one time step, Simulink Design Verifier coverage
for that function is 100%. Otherwise, the Simulink Verification and Validation
software reports coverage for that function as 0%.

For an example of coverage data for Simulink Design Verifier functions in a
coverage report, see “Simulink® Design Verifier Coverage” on page 17-35.

How to Collect Coverage for MATLAB Functions
When you simulate your model, the Simulink Verification and Validation
software can collect coverage data for MATLAB functions configured for code
generation. To enable model coverage, select Tools > Coverage Settings
and select Coverage for this model.

You collect model coverage for MATLAB functions as follows:

• Functions in a MATLAB Function block

• Functions in an external MATLAB file

To collect coverage for an external MATLAB file, on the Coverage tab
of the Coverage Settings dialog box, select Coverage for External
MATLAB files.

• Simulink Design Verifier functions:

- sldv.condition

- sldv.test

- sldv.assume

- sldv.prove

To collect coverage for these functions, on the Coverage tab of the Coverage
Settings dialog box, select the Simulink Design Verifier coverage metric.

The following section provides model coverage examples for each of these
situations.
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Examples: Model Coverage for MATLAB Functions

• “Example: Model Coverage for MATLAB Function Blocks” on page 16-23

• “Example: Model Coverage for MATLAB Functions in an External File” on
page 16-35

• “Example: Model Coverage for Simulink® Design Verifier MATLAB
Functions” on page 16-36

Example: Model Coverage for MATLAB Function Blocks
Simulink Verification and Validation software measures model coverage for
functions in a MATLAB Function block.

The following model contains two MATLAB functions in its MATLAB
Function block:

In the Configuration Parameters dialog box, on the Solver pane, under
Solver options, the simulation parameters are set as follows:

• Type — Fixed-step
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• Solver — discrete (no continuous states)

• Fixed-step size (fundamental sample time)— 1

The MATLAB Function block contains two functions:

• The top-level function, run_intersect_test, sends the coordinates
for two rectangles, one fixed and the other moving, as arguments to
rect_intersect.

• The subfunction, rect_intersect, tests for intersection between the two
rectangles. The origin of the moving rectangle increases by 1 in the x and y
directions with each time step.

The coordinates for the origin of the moving test rectangle are represented
by persistent data x1 and y1, which are both initialized to -1. For the first
sample, x1 and y1 are both incremented to 0. From then on, the progression of
rectangle arguments during simulation is as shown in the following graphic.
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The fixed rectangle is shown in bold with a lower-left origin of (2,4) and a
width and height of 2. At time t = 0, the first test rectangle has an origin of
(0,0) and a width and height of 2. For each succeeding sample, the origin
of the test rectangle increments by (1,1). The rectangles at sample times
t = 2, 3, and 4 intersect with the test rectangle.

The subfunction rect_intersect checks to see if its two rectangle arguments
intersect. Each argument consists of coordinates for the lower-left corner of
the rectangle (origin), and its width and height. x values for the left and right
sides and y values for the top and bottom are calculated for each rectangle and
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compared in nested if-else decisions. The function returns a logical value of
1 if the rectangles intersect and 0 if they do not.

Scope output during simulation, which plots the return value against the
sample time, confirms the intersecting rectangles for sample times 2, 3, and 4 .

After the simulation, the model coverage report appears in a browser window.
After the summary in the report, the Details section of the model coverage
report reports on each parts of the model.

The model coverage report for the MATLAB Function block shows that the
block itself has no decisions of its own apart from its function.

The following sections examine the model coverage report for the example
model in reverse function-block-model order. Reversing the order helps you
make sense of the summary information at the top of each section.
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Coverage for the MATLAB Function run_intersect_test. Model coverage
for the MATLAB Function block function run_intersect_test appears
under the linked name of the function. Clicking this link opens the function
in the editor.

Below the linked function name is a link to the model coverage report
for the parent MATLAB Function block that contains the code for
run_intersect_test.

The top half of the report for the function summarizes its model coverage
results. The coverage metrics for run_intersect_test include decision,
condition, and MCDC coverage. You can best understand these metrics by
examining the code for run_intersect_test.
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Lines with coverage elements are marked by a highlighted line number
in the listing:

• Line 1 receives decision coverage on whether the top-level function
run_intersect_test is executed.

• Line 6 receives decision coverage for its if statement.
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• Line 14 receives decision coverage on whether the subfunction
rect_intersect is executed.

• Lines 27 and 30 receive decision, condition, and MCDC coverage for their
if statements and conditions.

Each of these lines is the subject of a report that follows the listing.

The condition right1 < left2 in line 30 is highlighted in red. This means
that this condition was not tested for all of its possible outcomes during
simulation. Exactly which of the outcomes was not tested is in the report
for the decision in line 30.

The following sections display the coverage for each run_intersect_test
decision line. The coverage for each line is titled with the line itself, which
if clicked, opens the editor to the designated line.

Coverage for Line 1. The coverage metrics for line 1 are part of the
coverage data for the function run_intersect_test.

The first line of every MATLAB function configured for code generation
receives coverage analysis indicative of the decision to run the function
in response to a call. Coverage for run_intersect_test indicates that it
executed at least once during simulation.

Coverage for Line 6. The Decisions analyzed table indicates that
the decision in line 6, if isempty(x1), executed a total of eight times.
The first time it executed, the decision evaluated to true, enabling
run_intersect_test to initialize the values of its persistent data. The
remaining seven times the decision executed, it evaluated to false. Because
both possible outcomes occurred, decision coverage is 100%.
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Coverage for Line 14. The Decisions Analyzed table indicates that the
subfunction rect_intersect executed during testing, thus receiving 100%
coverage.

Coverage for Line 27. The Decisions analyzed table indicates that there
are two possible outcomes for the decision in line 27: true and false. Five
of the eight times it was executed, the decision evaluated to false. The
remaining three times, it evaluated to true. Because both possible outcomes
occurred, decision coverage is 100%.

The Conditions analyzed table sheds some additional light on the decision
in line 27. Because this decision consists of two conditions linked by a logical
OR (||) operation, only one condition must evaluate true for the decision to
be true. If the first condition evaluates to true, there is no need to evaluate
the second condition. The first condition, top1 < bottom2, was evaluated
eight times, and was true twice. This means that it was necessary to evaluate
the second condition only six times. In only one case was it true, which
brings the total true occurrences for the decision to three, as reported in the
Decisions analyzed table.
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MCDC coverage looks for decision reversals that occur because one condition
outcome changes from T to F or from F to T. The MC/DC analysis table
identifies all possible combinations of outcomes for the conditions that lead
to a reversal in the decision. The character x is used to indicate a condition
outcome that is irrelevant to the decision reversal. Decision-reversing
condition outcomes that are not achieved during simulation are marked with a
set of parentheses. There are no parentheses, therefore all decision-reversing
outcomes occurred and MCDC coverage is complete for the decision in line 27.
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Coverage for Line 30. The line 30 decision, if (right1 < left2 ||
right2 < left1), is nested in the if statement of the line 27 decision and is
evaluated only if the line 27 decision is false. Because the line 27 decision
evaluated false five times, line 30 is evaluated five times, three of which are
false. Because both the true and false outcomes are achieved, decision
coverage for line 30 is 100%.

Because line 30, like line 27, has two conditions related by a logical OR
operator (||), condition 2 is tested only if condition 1 is false. Because
condition 1 tests false five times, condition 2 is tested five times. Of these,
condition 2 tests true two times and false three times, which accounts for
the two occurrences of the true outcome for this decision.

Because the first condition of the line 30 decision does not test true, both
outcomes do not occur for that condition and the condition coverage for
the first condition is highlighted with a rose color. MCDC coverage is also
highlighted in the same way for a decision reversal based on the true outcome
for that condition.

16-32



Model Coverage for MATLAB® Functions

Coverage for run_intersect_test. On the Details tab, the metrics that
summarize coverage for the entire run_intersect_test function are reported
and repeated as shown.
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The results summarized in the coverage metrics summary can be expressed
in the following conclusions:

• There are eight decision outcomes reported for run_intersect_test in
the line reports:

- One for line 1 (executed)

- Two for line 6 (true and false)

- One for line 14 (executed)

- Two for line 27 (true and false)

- Two for line 30 (true and false).

The decision coverage for each line shows 100% decision coverage. This
means that decision coverage for run_intersect_test is eight of eight
possible outcomes, or 100%.

• There are four conditions reported for run_intersect_test in the line
reports. Lines 27 and 30 each have two conditions, and each condition has
two condition outcomes (true and false), for a total of eight condition
outcomes in run_intersect_test. All conditions tested positive for both
the true and false outcomes except the first condition of line 30 (right1
< left2). This means that condition coverage for run_intersect_test is
seven of eight, or 88%.

• The MCDC coverage tables for decision lines 27 and 30 each list two cases
of decision reversal for each condition, for a total of four possible reversals.
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Only the decision reversal for a change in the evaluation of the condition
right1 < left2 of line 30 from true to false did not occur during
simulation. This means that three of four, or 75% of the possible reversal
cases were tested for during simulation, for a coverage of 75%.

Example: Model Coverage for MATLAB Functions in an
External File
Using the same model in “Example: Model Coverage for MATLAB Function
Blocks” on page 16-23, suppose the MATLAB functions run_intersect_test
and rect_intersect are stored in an external MATLAB file named
run_intersect_test.m.

To collect coverage for MATLAB functions in an external file, on the Coverage
Settings dialog box, on the Coverage tab, select Coverage for External
MATLAB files.

After simulation, the model coverage report summary contains sections for
the top-level model and for the external function.

The model coverage report for run_intersect_test.m reports the same
coverage data as if the functions were stored in the MATLAB Function block.

For a detailed example of a model coverage report for a MATLAB function in
an external file, see “External MATLAB File Coverage Reports” on page 17-39.
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Example: Model Coverage for Simulink Design Verifier
MATLAB Functions
If the MATLAB code includes any of the following Simulink Design Verifier
functions configured for code generation, you can measure coverage:

• sldv.condition

• sldv.test

• sldv.assume

• sldv.prove

For this example, consider the following model that contains a MATLAB
Function block.

The MATLAB Function block contains the following code:

function y = fcn(u)
% This block supports MATLAB for code generation.

sldv.condition(u > -30)
sldv.test(u == 30)
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y = 1;

To collect coverage for Simulink Design Verifier MATLAB functions, on the
Coverage Settings dialog box, on the Coverage tab, select Simulink Design
Verifier.

After simulation, the model coverage report listed coverage for the
sldv.condition and sldv.test functions. For sldv.condition, the
expression u > -30 evaluated to true 51 times. For sldv.test, the
expression u == 30 evaluated to true 51 times.
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For an example of model coverage data for Simulink Design Verifier blocks,
see “Simulink Design Verifier Coverage” on page 13-8.

16-39



16 Collecting Model Coverage

Model Coverage for Stateflow Charts

In this section...

“How Model Coverage Reports Work for Stateflow Charts” on page 16-40

“Specifying Coverage Report Settings” on page 16-41

“Cyclomatic Complexity” on page 16-41

“Decision Coverage” on page 16-42

“Condition Coverage” on page 16-45

“MCDC Coverage” on page 16-46

“Model Coverage Reports for Stateflow Charts” on page 16-47

“Model Coverage for Stateflow Atomic Subcharts” on page 16-56

“Model Coverage for Stateflow Truth Tables” on page 16-59

“Colored Stateflow Chart Coverage Display” on page 16-64

How Model Coverage Reports Work for Stateflow
Charts
To generate a Model Coverage report, select Tools > Coverage Settings and
specify the desired options on the Reporting tab of the Coverage Settings
dialog box. For Stateflow charts, the Simulink Verification and Validation
software records the execution of the chart itself and the execution of states,
transition decisions, and individual conditions that compose each decision.
After simulation ends, the model coverage reports on how thoroughly a model
was tested. The report shows:

• How many times each exclusive substate is entered, executed, and exited
based on the history of the superstate

• How many times each transition decision has been evaluated as true or
false

• How many times each condition has been evaluated as true or false
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Note To measure model coverage data for a Stateflow chart, you must have a
Stateflow license.

For complete information about Stateflow software, see Stateflow User’s
Guide.

Specifying Coverage Report Settings
To specify coverage report settings, select Tools > Coverage Settings in
a Simulink model window.

By selecting the Generate HTML Report option in the Coverage Settings
dialog box, you can create an HTML report containing the coverage data
generated during simulation of the model. The report appears in the MATLAB
Help browser at the end of simulation.

By selecting the Generate HTML Report option, you also enable the
selection of different coverages that you can specify for your reports. The
following sections address only coverage metrics that affect reports for
Stateflow charts. These metrics include decision coverage, condition coverage,
and MCDC coverage. For a complete discussion of all dialog box fields and
entries, see Chapter 15, “Setting Model Coverage Options”.

Cyclomatic Complexity
Cyclomatic complexity is a measure of the complexity of a software module
based on its edges, nodes, and components within a control-flow graph. It
provides an indication of how many times you need to test the module.

The calculation of cyclomatic complexity is as follows:

CC = E - N + p

where CC is the cyclomatic complexity, E is the number of edges, N is the
number of nodes, and p is the number of components.

Within the Model Coverage tool, each decision is exactly equivalent to a single
control flow node, and each decision outcome is equivalent to a control flow
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edge. Any additional structure in the control-flow graph is ignored since it
contributes the same number of nodes as edges and therefore has no effect on
the complexity calculation. Therefore, you can express cyclomatic complexity
as follows:

CC = OUTCOMES - DECISIONS + p

For analysis purposes, each chart counts as a single component.

Decision Coverage
Decision coverage interprets a model execution in terms of underlying
decisions where behavior or execution must take one outcome from a set of
mutually exclusive outcomes.

Note Full coverage for an object of decision means that every decision has
had at least one occurrence of each of its possible outcomes.

Decisions belong to an object making the decision based on its contents or
properties. The following table lists the decisions recorded for model coverage
for the Stateflow objects owning them. The sections that follow the table
describe these decisions and their possible outcomes.

Object Possible Decisions

Chart If a chart is a triggered Simulink block, it must decide
whether or not to execute its block.

If a chart contains exclusive (OR) substates, it must decide
which of its states to execute.

State If a state is a superstate containing exclusive (OR) substates,
it must decide which substate to execute.

If a state has on event name actions (which might include
temporal logic operators), the state must decide whether or
not to execute the actions.

Transition If a transition is a conditional transition, it must decide
whether or not to exit its active source state or junction and
enter another state or junction.
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Chart as a Triggered Simulink Block Decision
If the chart is a triggered block in a Simulink model, the decision to execute
the block is tested. If the block is not triggered, there is no decision to execute
the block, and the measurement of decision coverage is not applicable (NA).

Chart Containing Exclusive OR Substates Decision
If the chart contains exclusive (OR) substates, the decision on which substate
to execute is tested. If the chart contains only parallel AND substates, this
coverage measurement is not applicable (NA).

Superstate Containing Exclusive OR Substates Decision
Since a chart is hierarchically processed from the top down, procedures such
as exclusive (OR) substate entry, exit, and execution are sometimes decided
by the parenting superstate.

Note Decision coverage for superstates applies only to exclusive (OR)
substates. A superstate makes no decisions for parallel (AND) substates.

Since a superstate must decide which exclusive (OR) substate to process, the
number of decision outcomes for the superstate is the number of exclusive
(OR) substates that it contains. In the examples that follow, the choice of
which substate to process can occur in one of three possible contexts.

Note Implicit transitions appear as dashed lines in the following examples.

16-43



16 Collecting Model Coverage

Context Example Decisions That Occur

Active call States A and A1 are active. • The parent of states A and B
must decide which of these
states to process. This decision
belongs to the parent. Since A
is active, it is processed.

• State A, the parent of states
A1 and A2, must decide which
of these states to process.
This decision belongs to state
A. Since A1 is active, it is
processed.

During processing of state A1, all
outgoing transitions are tested.
This decision belongs to the
transition and not to the parent
state A. In this case, the transition
marked by condition C2 is tested
and a decision is made whether to
take the transition to A2 or not.

Implicit
substate exit

A transition takes place whose source is
superstate A and whose destination is
state B.

If the superstate has two exclusive
(OR) substates, it is the decision
of superstate A which substate
performs the implicit transition
from substate to superstate.
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Context Example Decisions That Occur

Substate entry
with a history
junction

A history junction records which substate
was last active before the superstate was
exited.

If that superstate becomes
the destination of one or more
transitions, the history junction
decides which previously active
substate to enter.

For more information, see “State Details Report Section” on page 16-50.

State with On Event_Name Action Statement Decision
A state that has an on event_name action statement must decide whether to
execute that statement based on the reception of a specified event or on an
accumulation of the specified event when using temporal logic operators.

Conditional Transition Decision
A conditional transition is a transition with a triggering event and/or a
guarding condition. In a conditional transition from one state to another, the
decision to exit one state and enter another is credited to the transition itself.

Note Only conditional transitions receive decision coverage. Transitions
without decisions are not applicable to decision coverage.

Condition Coverage
Condition coverage reports on the extent to which all possible outcomes are
achieved for individual subconditions composing a transition decision.
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Note Full condition coverage means that all possible outcomes occurred for
each subcondition in the test of a decision.

For example, for the decision [A & B & C] on a transition, condition coverage
reports on the true and false occurrences of each of the subconditions A, B,
and C. This results in eight possible outcomes: true and false for each of
three subconditions.

Outcome A B C

1 T T T

2 T T F

3 T F T

4 T F F

5 F T T

6 F T F

7 F F T

8 F F F

For more information, see “Transition Details Report Section” on page 16-53.

MCDC Coverage
The Modified Condition Decision Coverage (MCDC) option reports a test’s
coverage of occurrences in which changing an individual subcondition within
a transition results in changing the entire transition trigger expression from
true to false or false to true.

Note If matching true and false outcomes occur for each subcondition,
coverage is 100%.

For example, if a transition executes on the condition [C1 & C2 & C3 | C4
& C5], the MCDC report for that transition shows actual occurrences for
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each of the five subconditions (C1, C2, C3, C4, C5) in which changing its
result from true to false is able to change the result of the entire condition
from true to false.

Model Coverage Reports for Stateflow Charts

• “Summary Report Section” on page 16-47

• “Subsystem and Chart Details Report Sections” on page 16-48

• “State Details Report Section” on page 16-50

• “Transition Details Report Section” on page 16-53

The following sections of a Model Coverage report were generated by
simulating the sf_boiler model, which includes the Bang-Bang Controller
chart. The coverage metrics for Decision, Condition, and MCDC are
enabled for this report.

Summary Report Section
The Summary section shows coverage results for the entire test and appears
at the beginning of the Model Coverage report.
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Each line in the hierarchy summarizes the coverage results at that level and
the levels below it. You can click a hyperlink to a later section in the report
with the same assigned hierarchical order number that details that coverage
and the coverage of its children.

The top level, sf_boiler, is the Simulink model itself. The second level,
Bang-Bang Controller, is the Stateflow chart. The next levels are superstates
within the chart, in order of hierarchical containment. Each superstate
uses an SF: prefix. The bottom level, Boiler Plant model, is an additional
subsystem in the model.

Subsystem and Chart Details Report Sections
When recording coverage for a Stateflow chart, the Simulink Verification and
Validation software reports two types of coverage for the chart—Subsystem
and Chart.

• Subsystem — This section reports coverage for the chart:
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- Coverage (this object): Coverage data for the chart as a container
object

- Coverage (inc.) descendants: Coverage data for the chart and the
states and transitions in the chart.

If you click the hyperlink of the subsystem name in the section title, the
Bang-Bang Controller block is highlighted in the block diagram.

Decision coverage is not applicable (NA) because this chart does not have an
explicit trigger. Condition coverage and MCDC are not applicable (NA) for a
chart, but apply to its descendants.

• Chart — This section reports coverage for the chart:

- Coverage (this object): Coverage data for the chart and its inputs

- Coverage (inc.) descendants: Coverage data for the chart and the
states and transitions in the chart.

If you click the hyperlink of the chart name in the section title, the chart
opens in the Stateflow Editor.

Decision coverage is listed appears for the chart and its descendants.
Condition coverage and MCDC are not applicable (NA) for a chart, but apply
to its descendants.
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State Details Report Section
For each state in a chart, the coverage report includes a State section with
details about the coverage recorded for that state.

In the sf_boiler model, the state On resides in the box Heater. On is a
superstate that contains:

• Two substates HIGH and NORM

• A history junction

• The function warm
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The coverage report includes a State section on the state On.

16-51



16 Collecting Model Coverage

The decision coverage for the On state tests the decision of which substate to
execute.

The three decisions are listed in the report:

• Under Substate executed, which substate to execute when On executes.

• Under Substate exited when parent exited, which substate is active
when On exits. NORM is listed as never being active when On exits because
the coverage tool sees the supertransition from NORM to Off as a transition
from On to Off.

• Under Previously active substate entered due to history, which
substate to reenter when On re-executes. The history junction records the
previously active substate.

Because each decision can result in either HIGH or NORM, the total possible
outcomes are 3 × 2 = 6. The results indicate that five of six possible outcomes
were tested during simulation.
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Cyclomatic complexity and decision coverage also apply to descendants
of the On state. The decision required by the condition [warm()] for the
transition from HIGH to NORM brings the total possible decision outcomes to
8. Condition coverage and MCDC are not applicable (NA) for a state.

Note Nodes and edges that make up the cyclomatic complexity calculation
have no direct relationship with model objects (states, transitions, and so on).
Instead, this calculation requires a graph representation of the equivalent
control flow.

Transition Details Report Section
Reports for transitions appear under the report sections of their owning
objects. Transitions do not appear in the model hierarchy of the Summary
section, since the hierarchy is based on superstates that own other Stateflow
objects.
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The decision for this transition depends on the time delay of 40 seconds and
the condition [cold()]. If, after a 40 second delay, the environment is cold
(cold() = 1), the decision to execute this transition and turn the Heater on
is made. For other time intervals or environment conditions, the decision is
made not to execute.

For decision coverage, both true and false outcomes occurred. Because two of
two decision outcomes occurred, coverage was full or 100%.

Condition coverage shows that only 4 of 6 condition outcomes were tested.
The temporal logic statement after(40,sec) represents two conditions:
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the occurrence of sec and the time delay after(40,sec). Therefore, three
conditions on the transition exist: sec, after(40,sec), and cold(). Since
each of these decisions can be true or false, six possible condition outcomes
exist.

The Conditions analyzed table shows each condition as a row with the
recorded number of occurrences for each outcome (true or false). Decision
rows in which a possible outcome did not occur are shaded. For example, the
first and the third rows did not record an occurrence of a false outcome.

In the MC/DC report, all sets of occurrences of the transition conditions are
scanned for a particular pair of decisions for each condition in which the
following are true:

• The condition varies from true to false.

• All other conditions contributing to the decision outcome remain constant.

• The outcome of the decision varies from true to false, or the reverse.

For three conditions related by an implied AND operator, these criteria can
be satisfied by the occurrence of these conditions.

Condition Tested True Outcome False Outcome

1 TTT Fxx

2 TTT TFx

3 TTT TTF

Notice that in each line, the condition tested changes from true to false while
the other condition remains constant. Irrelevant contributors are coded with
an "x" (discussed below). If both outcomes occur during testing, coverage is
complete (100%) for the condition tested.

The preceding report example shows coverage only for condition 2. The false
outcomes required for conditions 1 and 3 did not occur, and are indicated
by parentheses for both conditions. Therefore, condition rows 1 and 3 are
shaded. While condition 2 has been tested, conditions 1 and 3 have not and
MCDC is 33%.
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For some decisions, the values of some conditions are irrelevant under certain
circumstances. For example, in the decision [C1 & C2 & C3 | C4 & C5] the
left side of the | is false if any one of the conditions C1, C2, or C3 is false. The
same applies to the right side result if either C4 or C5 is false. When searching
for matching pairs that change the outcome of the decision by changing one
condition, holding some of the remaining conditions constant is irrelevant.
In these cases, the MC/DC report marks these conditions with an "x" to
indicate their irrelevance as a contributor to the result. These conditions
appear as shown.

Consider the first matched pair. Since condition 1 is true in the True outcome
column, it must be false in the matching False outcome column. This makes
the conditions C2 and C3 irrelevant for the false outcome since C1 & C2 &
C3 is always false if C1 is false. Also, since the false outcome is required to
evaluate to false, the evaluation of C4 & C5 must also be false. In this case, a
match was found with C4 = F, making condition C5 irrelevant.

Model Coverage for Stateflow Atomic Subcharts
In a Stateflow chart, an atomic subchart is a graphical object that allows you
to reuse the same state or subchart across multiple charts and models.

When you specify to record coverage data for a model during simulation, the
Simulink Verification and Validation software records coverage for any atomic
subcharts in your model. The coverage data records the execution of the
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chart itself, and the execution of states, transition decisions, and individual
conditions that compose each decision in the atomic subchart.

Simulate the doc_atomic_subcharts_map_iodata example model and record
decision coverage:

1 Open the doc_atomic_subcharts_map_iodata.mdl model.

This model contains two Sine Wave blocks that supply input signals to
the Stateflow chart Chart. Chart contains two atomic subcharts—A and
B—that are linked from the same library chart, also named A. The library
chart contains the following objects:

2 In the Model Editor, select Tools > Coverage Settings

The Coverage Settings dialog box appears.

3 On the Coverage tab, select Coverage for this model:
doc_atomic_subcharts_map_iodata.

4 On the Reporting tab, select Generate HTML report.

5 Click OK to close the Coverage Settings dialog box.

6 Simulate the doc_atomic_subcharts_map_iodata model.

When the simulation completes, the coverage report opens.

The report provides coverage data for atomic subcharts A and B in the
following forms:
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• For the atomic subchart instance and its contents. Decision coverage is not
applicable (NA) because this chart does not have an explicit trigger.

• For the library chart A and its contents. The chart itself achieves 100%
coverage on the input u1, and 88% coverage on the states and transitions
inside the library chart.
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Atomic subchart B is a copy of the same library chart A. The coverage of
the contents of subchart B is identical to the coverage of the contents of
subchart A.

Model Coverage for Stateflow Truth Tables

• “Types of Coverage in Stateflow Truth Tables” on page 16-59

• “Analyzing Coverage in Stateflow Truth Tables” on page 16-60

Types of Coverage in Stateflow Truth Tables
Simulink Verification and Validation software reports model coverage for the
decisions the objects make in a Stateflow chart during model simulation. The
report includes coverage for the decisions the truth table functions make.

For this type of
truth table...

The report includes coverage data for...

Stateflow Classic Conditions only.

MATLAB Conditions and only those actions that have decision
points.

Note With the MATLAB for code generation action
language, you can specify decision points in actions
using control flow constructs, such as loops and switch
statements.

Note To measure model coverage data for a Stateflow truth table, you must
have a Stateflow license.

For details information about truth tables and truth table functions in
Stateflow, see “Truth Table Functions”.
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Analyzing Coverage in Stateflow Truth Tables
If you have a Stateflow license, you can generate a model coverage report
for a truth table.

Consider the following model.

The Stateflow chart Chart contains the following truth table:
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When you simulate the model and collect coverage, the model coverage report
includes the following data:
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The Coverage (this object) column shows no coverage. The reason is that
the container object for the truth table function—the Stateflow chart—does
not decide whether to execute the ttable truth table.

The Coverage (inc. descendants) column shows coverage for the graphical
function. The graphical function has the decision logic that makes the
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transitions for the truth table. The transitions in the graphical function
contain the decisions and conditions of the truth table. Coverage for the
descendants in the Coverage (inc. descendants) column includes coverage
for these conditions and decisions. Function calls to the truth table test the
model coverage of these conditions and decisions.

Note See “How Stateflow Software Implements Truth Tables” for a
description of the graphical function for a truth table.

Coverage for the decisions and their individual conditions in the ttable truth
table function are as follows.

Coverage Explanation

No model coverage for the default
decision, D5

All logic that leads to taking a default
decision is based on a false outcome for
all preceding decisions. This means
that the default decision requires no
logic, so there is no model coverage.

13% (1/8) decision coverage The three constants that are inputs
to the truth table (1, 0, 0) cause only
decision D1 to be true. These inputs
satisfy only one of the eight decisions
(D1 through D4, T or F).

Because each condition can have
an outcome value of T or F, three
conditions can have six possible values.
However, decision D4 has only decision
coverage, not condition coverage or
MCDC coverage, because it represents
a decision with a single predicate.

3 of the 18 (17%) condition
coverage

Three decisions D1, D2, and D3 have
condition coverage, because the set of
inputs (1, 0, 0) make only decision D1
true.
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Coverage Explanation

No (0/9) MCDC coverage MCDC coverage looks for decision
reversals that occur because one
condition outcome changes from T to F
or F to T. The simulation tests only one
set of inputs, so the model reverses no
decisions.

Missing coverage The red letters T and F indicate that
model coverage is missing for those
conditions. For decision D1, only the T
decision is satisfied. For decisions D2,
D3, and D4, none of the conditions are
satisfied.

Colored Stateflow Chart Coverage Display
The Model Coverage tool displays model coverage results for individual blocks
directly in Simulink diagrams. If you enable this feature, the Model Coverage
tool:

• Highlights Stateflow objects that receive model coverage during simulation

• Provides a context-sensitive display of summary model coverage
information for each object

Caution The coverage tool changes colors only for open charts at the time
coverage information is reported. When you interact with the chart, such
as selecting a transition or a state, colors revert to default values.

For details on enabling and selecting this feature in the Simulink window, see
“Enabling Coverage Highlighting” on page 16-6 in the Simulink Verification
and Validation documentation.
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Displaying Model Coverage with Model Coloring
Once you enable display coverage with model coloring, anytime that the model
generates a model coverage report, individual chart objects receiving coverage
appear highlighted with light green or light red.

1 Open the sf_car model.

2 Select Tools > Coverage Settings.

3 In the Coverage Settings dialog box, select Coverage for this model.

4 Click OK.

5 Simulate the model.
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After simulation ends, chart objects with coverage appear highlighted.

Object highlighting indicates coverage as follows:

• Light green for full coverage

• Light red for partial coverage

• No color for zero coverage

Note To revert the chart to show original colors, select and deselect any
objects.
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6 Click selection_state in the chart.

The following summary report appears.

When you click a highlighted Stateflow object, the summarized coverage
for that object appears in the Coverage Display Window. Clicking the
hyperlink opens the appropriate section of the coverage report for this
object.

Tip You can set the Coverage Display Window to appear for a block in
response to a hovering mouse cursor instead of a mouse click in one of
two ways:

• Select the downward arrow on the right side of the Coverage Display
Window and select Focus.

• Right-click a colored block and select Coverage > Display details on
mouse-over.
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Types of Coverage Reports
In the Coverage Settings dialog box, on the Report tab, if you select the
Generate HTML report option, the Simulink Verification and Validation
software creates one or more model coverage reports after a simulation.

Report Type Description HTML Report File Name

“Model Coverage Reports” on page
17-3

Provides coverage
information for all model
elements, including the
model itself.

model_name_cov.html

“Model Summary Reports” on page
17-37

Provides links to coverage
results for all referenced
models and external
MATLAB files in the model
hierarchy. Created when
the top-level model includes
Model blocks or calls one or
more external files.

model_name
_summary_cov.html

“Model Reference Coverage
Reports” on page 17-38

Created for each referenced
model in the model
hierarchy; has the same
format as the model
coverage report.

reference_model_name
_cov.html

“External MATLAB File Coverage
Reports” on page 17-39

Provides detailed coverage
information about any
external MATLAB file that
the model calls. There is
one report for each external
file called.

MATLAB_file_name_cov.html

“Subsystem Coverage Reports” on
page 17-44

Model coverage report
includes only coverage
results for the subsystem, if
you select one.

model_name_cov.html;
model_name is the name of
the top-level model
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Model Coverage Reports
The Simulink Verification and Validation software always creates a model
coverage report for the top-level model named model_name_cov.html. The
model coverage report contains several sections:

In this section...

“Coverage Summary” on page 17-3

“Details” on page 17-5

“Cyclomatic Complexity” on page 17-14

“Decisions Analyzed” on page 17-16

“Conditions Analyzed” on page 17-18

“MCDC Analysis” on page 17-18

“Cumulative Coverage” on page 17-20

“N-Dimensional Lookup Table” on page 17-22

“Block Reduction” on page 17-29

“Signal Range Analysis” on page 17-31

“Signal Size Coverage for Variable-Dimension Signals” on page 17-33

“Simulink® Design Verifier Coverage” on page 17-35

Coverage Summary
The coverage summary section contains basic information about the model
being analyzed:

• Model Information

• Simulation Optimization Options

• Coverage Options

The coverage summary has two subsections:
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• Tests— The simulation start and stop time of each test case and any setup
commands that preceded the simulation. The heading for each test case
includes any test case label specified using the cvtest command.

• Summary— Summaries of the subsystem results. To see detailed results
for a specific subsystem, in the Summary subsection, click the subsystem
name.
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Details
The Details section reports the detailed model coverage results. Each section
of the detailed report summarizes the results for the metrics that test each
object in the model:
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• “Filtered Objects” on page 17-6

• “Model Details” on page 17-7

• “Subsystem Details” on page 17-8

• “Block Details” on page 17-9

• “Chart Details” on page 17-10

• “Coverage Details for MATLAB Functions and Simulink® Design Verifier
Functions” on page 17-11

You can also access a model element Details subsection as follows:

1 Right-click a Simulink element.

2 In the context menu, select Coverage > Report.

Filtered Objects
The Filtered Objects section lists all the objects in the model that were filtered
from coverage recording, and the rationale you specified for filtering those
objects. If the filter rule specifies that all blocks of a certain type be filtered,
all those blocks are listed here.

In the following graphic, several blocks, subsystems, and transitions were
filtered. Two library-linked blocks, protected division and protected division1,
were filtered because their block library was filtered.
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Model Details
The Details section contains a results summary for the model as a whole,
followed by a list of elements. Click the model element name to see its
coverage results.

The following graphic shows the Details section for the fuelsys model.
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Subsystem Details
Each subsystem Details section contains a summary of the test coverage
results for the subsystem and a list of the subsystems it contains. The
overview is followed by sections for blocks, charts, and MATLAB functions,
one for each object that contains a decision point in the subsystem.

The following graphic shows the coverage results for the EGO sensor
subsystem in the fuelsys model.
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Block Details
The following graphic shows the coverage results for the Switch block in the
EGO sensor subsystem of the fuelsys model.

The Uncovered Links element first appears in the Block Details section of
the first block in the model hierarchy that does not achieve 100% coverage.
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The first Uncovered Links element has an arrow that links to the Block
Details section in the report of the next block that does not achieve 100%
coverage.

Subsequent blocks that do not achieve 100% coverage have links to the Block
Details sections in the report of the previous and next blocks that do not
achieve 100% coverage.

Chart Details
The following graphic shows the coverage results for the Stateflow chart,
Chart2, in the mExternalMfile model.

For more information about model coverage reports for Stateflow charts and
their objects, see “Model Coverage for Stateflow Charts” on page 16-40 in
the Stateflow documentation.
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Coverage Details for MATLAB Functions and Simulink Design
Verifier Functions
By default, the Simulink Verification and Validation software records
coverage for all MATLAB functions in a model. MATLAB functions are in
MATLAB Function blocks, Stateflow charts, or external MATLAB files.

Note For a detailed example of coverage reports for external MATLAB files,
see “External MATLAB File Coverage Reports” on page 17-39.

To record Simulink Design Verifier coverage for sldv.* functions called by
MATLAB functions, and any Simulink Design Verifier blocks, in the Coverage
Settings dialog box, on the Coverage tab, select Simulink Design Verifier.

The following example shows coverage details for a MATLAB function,
hFcnsInExternalEML, that calls four Simulink Design Verifier functions. In
this example, the code for hFcnsInExternalEML resides in an external file.

This example also shows Simulink Design Verifier coverage details for the
following functions:

• sldv.assume

• sldv.condition

• sldv.prove

• sldv.test

In the coverage results, code that achieves 100% coverage is green; code that
achieves less than 100% coverage is red.
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Coverage for the hFcnsInExternalEML function and the sldv.* calls is:
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• Line 1, the function declaration for hFcnsInExternalEMLis green
because the simulation executes that function at least once. fcn calls
hFcnsInExternalEML 11 times during simulation.

Line 4, sldv.assume(u1 > u2), achieves 0% coverage because u1 > u2
never evaluates to true.

• Line 5, sldv.condition(u1 == 0), achieves 100% coverage because u1 ==
0 evaluates to true for at least one time step.

• Line 6, switch u1, achieves 25% coverage because only one of the four
outcomes in the switch statement (case 0) occurs during simulation.
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• Line 17, sldv.test(y > u1); sldv.test (y == 4) achieves 50%
coverage. The first sldv.test call achieves 100% coverage, but the second
sldv.test call achieves 0% coverage.

For more information about coverage for MATLAB functions, see “Model
Coverage for MATLAB Functions” on page 16-20.

For more information about coverage for Simulink Design Verifier functions,
see “Simulink Design Verifier Coverage” on page 13-8.

Cyclomatic Complexity
You can specify that the model coverage report include cyclomatic complexity
numbers in two locations in the report:
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• The Summary section contains the cyclomatic complexity numbers for
each object in the model hierarchy. For a subsystem or Stateflow chart,
that number includes the cyclomatic complexity numbers for all their
descendants.

• The Details sections for each object list the cyclomatic complexity numbers
for all individual objects.
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Decisions Analyzed
The Decisions analyzed table lists possible outcomes for a decision and the
number of times that an outcome occurred in each test simulation. Outcomes
that did not occur are in red highlighted table rows.

The following graphic shows the Decisions analyzed table for the Switch
Control block in the EGO sensor subsystem of the fuelsys model.
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To display and highlight the block in question, click the block name associated
with the Decisions analyzed table, as in this example from the fuelsys model.

The next graphic shows the Decisions analyzed table for the lib_em2 function
call in Chart2 of the MexternalMfile model.
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Conditions Analyzed
The Conditions analyzed table lists the number of occurrences of true and
false conditions on each input port of the corresponding block.

MCDC Analysis
The MC/DC analysis table lists the MCDC input condition cases represented
by the corresponding block and the extent to which the reported test cases
cover the condition cases.

Each row of the MC/DC analysis table represents a condition case for a
particular input to the block. A condition case for input n of a block is a
combination of input values. Input n is called the deciding input of the
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condition case. Changing the value of input n alone changes the value of
the block’s output.

The MC/DC analysis table shows a condition case expression to represent a
condition case. A condition case expression is a character string where:

• The position of a character in the string corresponds to the input port
number.

• The character at the position represents the value of the input. (T means
true; F means false).

• A boldface character corresponds to the value of the deciding input.

For example, FTF represents a condition case for a three-input block where
the second input is the deciding input.

The Decision/Condition column specifies the deciding input for an input
condition case. The #1 True Out column specifies the deciding input value
that causes the block to output a true value for a condition case. The #1 True
Out entry uses a condition case expression, for example, FF, to express the
values of all the inputs to the block, with the value of the deciding variable
in bold.

Parentheses around the expression indicate that the specified combination of
inputs did not occur during the first (or only) test case included in this report.
In other words, the test case did not cover the corresponding condition case.
The #1 False Out column specifies the deciding input value that causes the
block to output a false value and whether the value actually occurred during
the first (or only) test case included in the report.

If you select Treat Simulink Logic blocks as short-circuited in the
Coverage Settings dialog box, MC/DC coverage analysis does not verify
whether short-circuited inputs actually occur. The MC/DC analysis table uses
an x in a condition expression (for example, TFxxx) to indicate short-circuited
inputs that were not analyzed by the tool.

If you enable this feature and Logic blocks are short-circuited while collecting
model coverage, you may not be able to achieve 100% coverage for that block.
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Uncovered Links. The section for each block that did not achieve 100%
coverage contains a backward and a forward arrow. Click the forward arrow
to go to the next section in the report that describes a block that did not
achieve 100% coverage. Click the back arrow to return to the previous section
in the report that describes a block that did not achieve 100% coverage.

Cumulative Coverage
On the Results tab, if you select Save cumulative results in workspace
variable and on the Report tab, Cumulative runs, the results of each
simulation are saved and recorded in the report.

In a cumulative coverage report, the results located in the right-most area in
all tables reflect the running total value. The report is organized so that you
can easily compare the additional coverage from the most recent run with the
coverage from all prior runs in the session.

A cumulative coverage report contains information about:

• Current Run — The coverage results of the simulation just completed.

• Delta — Percentage of coverage added to the cumulative coverage achieved
with the simulation just completed. If the previous simulation’s cumulative
coverage and the current coverage are nonzero, the delta may be 0 if the
new coverage does not add to the cumulative coverage.

• Cumulative — The total coverage collected for the model up to, but not
including, the simulation just completed.

After running three test cases for the slvnv_autopilot_test_harnessmodel,
the Summary report shows how much additional coverage the third test case
achieved and the cumulative coverage achieved for the first two test cases.
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The Decisions analyzed table for cumulative coverage contains three columns
of data about decision outcomes that represent the current run, the delta
since the last run, and the cumulative data, respectively.

The Conditions analyzed table uses column headers #n T and #n F to indicate
results for individual test cases. The table uses Tot T and Tot F for the
cumulative results. You can identify the true and false conditions on each
input port of the corresponding block for each test case.
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The MC/DC analysis #n True Out and #n False Out columns show the
condition cases for each test case. The Total Out T and Total Out F column
show the cumulative results.

N-Dimensional Lookup Table
The following interactive chart summarizes the extent to which elements of a
lookup table are accessed. In this example, two Sine Wave blocks generate x
and y indices that access a 2-D Lookup Table block of 10-by-10 elements filled
with random values.
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In this model, the lookup table indices are 1, 2,..., 10 in each direction. The
Sine Wave 2 block is out of phase with the Sine Wave 1 block by pi/2 radians.
This generates x and y numbers for the edge of a circle, which you see when
you examine the resulting Lookup Table coverage.
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The report contains a two-dimensional table representing the elements of the
lookup table. The element indices are represented by the cell border grid
lines, which number 10 in each dimension. Areas where the lookup table
interpolates between table values are represented by the cell areas. Areas
of extrapolation left of element 1 and right of element 10 are represented by
cells at the edge of the table, which have no outside border.

The number of values interpolated (or extrapolated) for each cell (execution
counts) during testing is represented by a shade of green assigned to the
cell. Each of six levels of green shading and the range of execution counts
represented are displayed on one side of the table.

If you click an individual table cell, you see a dialog box that displays the index
location of the cell and the exact number of execution counts generated for it

17-24



Model Coverage Reports

during testing. The following example shows the contents of a color-shaded
cell on the right edge of the circle.

The selected cell is outlined in red. You can also click the extrapolation cells
on the edge of the table.

A bold grid line indicates that at least one block input equal to its exact index
value occurred during the simulation. Click the border to display the exact
number of hits for that index value.
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The following example model uses an n-D Lookup Table block of 10-by-10-by-5
elements filled with random values.

Both the x and y table axes have the indices 1, 2,..., 10. The z axis has the
indices 10, 20,..., 50. Lookup table values are accessed with x and y indices
that the two Sine Wave blocks generated, in the preceding example, and a z
index that a Ramp block generates.

After simulation, you see the following lookup table report.
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Instead of a two-dimensional table, the link Force Map Generation displays
the following tables:
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Lookup table coverage for a three-dimensional lookup table block is reported
as a set of two-dimensional tables.

The vertical bars represent the exact z index values: 10, 20, 30, 40, 50. If a
vertical bar is bold, this indicates that at least one block input was equal to
the exact index value it represents during the simulation. Click a bar to get a
coverage report for the exact index value that bar represents.

You can report lookup table coverage for lookup tables of any dimension.
Coverage for four-dimensional tables is reported as sets of three-dimensional
sets, like those in the preceding example. Five-dimensional tables are
reported as sets of sets of three-dimensional sets, and so on.
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Block Reduction
All model coverage reports indicate the status of the Simulink Block
reduction parameter at the beginning of the report. In the following
example, you set Force block reduction off.

In the next example, you enabled the Simulink Block reduction parameter,
and you did not set Force block reduction off.

Consider the following model where the simulation does not execute the
MinMax1 block because there is only one input—the constant 3.

17-29



17 Understanding Model Coverage Reports

If you set Force block reduction off, the report contains no coverage data
for this block because the minimum input to the MinMax1 block is always 1.
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If you do not set Force block reduction off, the report contains no coverage
data for reduced blocks.

Signal Range Analysis
If you select Signal Range Coverage, the software creates a Signal Range
Analysis section at the bottom of the model coverage report. This section
lists the maximum and minimum signal values for each output signal in the
model measured during simulation.

Access the Signal Range Analysis report quickly with the Signal Ranges
link in the nonscrolling region at the top of the model coverage report, as
shown for the fuelsys model.
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Each block is reported in hierarchical fashion; child blocks appear directly
under parent blocks. Each block name in the Signal Ranges report is a link.
For example, select the EGO sensor link to display this block highlighted
in its native diagram.

Select the SwitchControl link to display this block in its own subsystem by
looking under the mask for EGO sensor.
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Signal Size Coverage for Variable-Dimension Signals
If you select Signal Size, the software creates a Variable Signal Widths
section after the Signal Ranges data in the model coverage report. This
section lists the maximum and minimum signal sizes for all output ports
in the model that have variable-size signals. It also lists the memory that
Simulink allocated for that signal, as measured during simulation. This list
does not include signals whose size does not vary during simulation.

The following example shows the Variable Signal Widths section in a coverage
report.
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Each block is reported in hierarchical fashion; child blocks appear directly
under parent blocks. Each block name in the Variable Signal Widths list
is a link.

In this example, the Abs block signal size varied from 2 to 5, with an allocation
of 5. Click the Abs link in the report. The Model Editor becomes current,
with the Abs block highlighted.
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After the analysis, the variable-size signals have a wider line design. double
(5) in this example indicates the data type and allocation for that signal.

Simulink Design Verifier Coverage
If you select Simulink Design Verifier, the analysis collects coverage data
for all Simulink Design Verifier blocks in your model.

For an example of how this works, open the sldvdemo_debounce_testobjblks
model.

This model contains two Test Objective blocks:

• The True block defines a property that the signal have a value of 2.

• The Edge block, inside the Masked Objective subsystem, describes the
property where the output of the AND block in the Masked Objective
subsystem changes from 2 to 1.

The Simulink Design Verifier software analyzes this model and produces a
harness model that contains test cases that achieve certain test objectives.
To see if the original model achieves those objectives, simulate the harness
model and collect model coverage data. The model coverage tool analyzes
any decision points or values within an interval that you specify in the Test
Objective block.

In this example, the coverage report shows that you achieved 100% coverage
of the True block because the signal value was 2 at least once. The signal
value was 2 in 6 out of 14 time steps.
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The input signal to the Edge block achieved a value of True once out of 14
time steps.

17-36



Model Summary Reports

Model Summary Reports
If the top-level model contains Model blocks or calls external files,
the software creates a model summary coverage report named
model_name_summary_cov.html. The title of this report is Coverage by
Model.

The summary report lists and provides links to coverage reports for all Model
block referenced models and external files called by MATLAB code in the
model. For more information, see “External MATLAB File Coverage Reports”
on page 17-39.

The following graphic shows an example of a model summary report. It
contains links to the model coverage report (mExternalMfile), a report for the
Model block (mExternalMfileRef), and three external files called from the
model (externalmfile,I externalmfile1, andexternalmfile2).
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Model Reference Coverage Reports
If your top-level model references a model in a Model block, the software
creates a separate report, named reference_model_name_cov.html, that
includes coverage for the referenced model. This report has the same format
as the “Model Coverage Reports” on page 17-3. Coverage results are recorded
as if the referenced model was a standalone model; the report gives no
indication that the model is referenced in a Model block.

17-38



External MATLAB® File Coverage Reports

External MATLAB File Coverage Reports
If your top-level model calls any external MATLAB files, select
Coverage for External MATLAB files on the Coverage tab of the
Coverage Settings dialog box. The software creates a report, named
MATLAB_file_name_cov.html, for each distinct file called from the model. If
there are several calls to a given file from the model, the software creates only
one report for that file, but it accumulates coverage from all the calls to the
file. The external MATLAB file coverage report does not include information
about what parts of the model call the external file.

The first section of the external MATLAB file coverage report contains
summary information about the external file, similar to the model coverage
report.
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The Details section reports coverage for the external file and the function
in that file.
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The Details section also lists the content of the file, highlighting the code
lines that have decision points or function definitions.
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Coverage results for each of the highlighted code lines follow in the report.
The following graphic shows a portion of these coverage results from the
preceding code example.
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Subsystem Coverage Reports
In the Coverage Settings dialog box, when you select Coverage for this
model, you can click Select Subsystem to request coverage for only the
selected subsystem in the model. The software creates a model coverage report
for the top-level model, but includes coverage results only for the subsystem.

However, if the top-level model calls any external files and you select
Coverage for External MATLAB files in the Coverage Settings dialog box,
the results include coverage for all external files called from:

• The subsystem for which you are recording coverage

• The top-level model that includes the subsystem

If the subsystem parameter Read/Write Permissions is set to
NoReadOrWrite, the software does not record coverage for that subsystem.

For example, in the fuelsys model, you click Select Subsystem, and select
coverage for the EGO sensor subsystem.
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The report is similar to the model coverage report, except that it includes only
results for the EGO sensor subsystem and its contents.
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What Is Coverage Filtering?
Coverage filtering is excluding model objects from model coverage when you
simulate your Simulink model. You specify which objects you want to be
excluded from coverage recording.

After you specify the objects to exclude, when you simulate your model,
Simulink Verification and Validation software does not record coverage for
filtered objects in your model.
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When to Use Coverage Filtering
You use coverage filtering to facilitate a bottom-up approach to recording
model coverage. If you have a large model, there may be design elements
that intentionally do not record 100% coverage. You might also have several
design elements that do not record 100% coverage that must record 100%
coverage. You can temporarily or permanently eliminate these elements from
coverage recording to focus on a subset of objects for testing and modification.

This approach allows you to iterate more efficiently—focus on a small
problem, fix it, and then move on to resolve the next small problem. Before
recording coverage for the entire model, you can resolve missing coverage
problems with individual parts of the model.
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Coverage Filter Rules and Files

In this section...

“What Is a Coverage Filter Rule?” on page 18-4

“What Is a Coverage Filter File?” on page 18-4

What Is a Coverage Filter Rule?
A coverage filter rule is a rule that specifies a model object or set of objects
to exclude from coverage recording:

Each coverage filter rule includes the following fields:

• Name—Name or path of the object to be filtered from coverage

• Type—Whether a specific object is filtered or all objects of a given type
are filtered

• Rationale—An optional description that explains why this object is
filtered from coverage

What Is a Coverage Filter File?
A coverage filter file is a collection of coverage filter rules. Each rule specifies
one or more objects to exclude from coverage recording.

To apply the coverage filter rules during coverage recording, you must first
attach a coverage filter file to your model. After you attach the coverage filter
file, when you simulate the model, the specified objects are excluded from
coverage. You can attach a coverage filter file to several Simulink models.
However, a model can have only one attached coverage filter file.

MATLAB saves coverage filter files in the MATLAB Current Folder, unless
you specify a different folder. The default name for a coverage filter file is
<model_name>_covfilter.cvf.

If you use the default file name and the coverage filter file exists on the
MATLAB path, each time you open the model, you see the coverage filter
rules, unless another coverage filter file is already attached to that model.
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Model Objects That You Can Exclude From Coverage
In your model, the objects that you can filter from coverage recording are:

• Simulink blocks that receive coverage, including MATLAB Function blocks

• Subsystems and their contents. When you exclude a subsystem from
coverage recording, none of the objects inside the subsystem record
coverage.

• Individual library-linked blocks or charts

• All reference blocks linked to a library

• Stateflow charts, subcharts, states, transitions, and temporal events

For a complete list of model objects that receive coverage, see Chapter 14,
“Model Objects That Receive Model Coverage”.
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Managing Coverage Filter Rules for a Simulink Model

In this section...

“Edit the Coverage Filter Rules” on page 18-6

“Save the Coverage Filter to a File” on page 18-9

“Attach a Coverage Filter File to a Model” on page 18-9

“View Coverage Filter Rules in Your Model” on page 18-10

“Remove a Coverage Filter Rule” on page 18-10

Edit the Coverage Filter Rules

• “Create a Coverage Filter Rule” on page 18-6

• “Add a Rationale to a Coverage Filter Rule” on page 18-7

• “Create Additional Coverage Filter Rules” on page 18-8

• “Remove a Coverage Filter Rule” on page 18-9

Create a Coverage Filter Rule
To create a coverage filter rule:

1 In the Coverage Settings dialog box, enable model coverage.

2 In the model window, right-click a model object and select
Coverage > Exclude ....

The following table lists the Exclude ... menu options. Depending on which
option you select, the Type field is automatically set for the coverage filter
rule you selected; you cannot override the value in the Type field.

If you select Coverage > ... The rule type is ...

Exclude this block by block path

Exclude all blocks with type
<block_type>

by block type
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If you select Coverage > ... The rule type is ...

Exclude all blocks with type MATLAB
Function

by block type

Exclude all blocks with type Truth Table by block type

Exclude subsystem with all dependents by subsystem

Exclude referenced library:
<library_name>

by library reference

Exclude subsystem with all descendants by subsystem

Exclude chart with all descendants by chart

Exclude mask type <mask name> by mask type

Exclude state with all descendants by state

Exclude this transition by transition

Exclude temporal event <event_name> by temporal event

Add a Rationale to a Coverage Filter Rule
Optionally, you can add text that describes why you want to exclude that
object or objects from coverage recording, and might be useful to others who
review the coverage for your model. When you add a new coverage filter rule,
the Coverage Filter Viewer opens. To add the rationale:

1 Double-click the Rationale field for the rule.

2 Delete the existing text.

3 Add the rationale for excluding this object.

The following graphic shows examples of text in the Rationale field.
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Note The Rationale field is the only coverage filter rule field that you can
edit in the Coverage Filter Viewer.

Create Additional Coverage Filter Rules
From the Coverage Filter Viewer, you can navigate back to the model to
create as many coverage filter rules as you need. To return to the model
window, click Add new rule by right-clicking in the model.

For each rule that you add, the Coverage Filter Viewer opens so that you can
specify a rationale for excluding that object from coverage.
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Remove a Coverage Filter Rule
To delete a coverage filter rule:

1 To open the Coverage Filter Viewer, right-click anywhere in the model and
select Coverage > Open Filter Viewer.

2 Select all the rules that you want to remove.

3 Click Remove rule.

Save the Coverage Filter to a File
After you define the coverage filter rules, save the rules to a file so that you
can reuse them with this model or with other models. By default, coverage
filter files are named <model_name>_covfilter.cvf.

In the Coverage Filter Viewer:

1 In the File name field, specify a file name for the filter file or accept the
default file name.

2 Click Apply to save the coverage filter rules to that file.

If you make multiple changes to the coverage filter rules, apply the changes
to the coverage filter file each time.

Attach a Coverage Filter File to a Model
Attach a coverage filter file to your model so that each time you open the
model, the coverage filter rules apply when you simulate your model.

In the Coverage Filter Viewer:

1 Select Attach file to model.

2 Click Apply.

Note You can also attach a coverage filter file to your model in the Coverage
Settings dialog box, on the Filter tab.
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You can have only one coverage filter file attached to a model at a time. If
you attach a different coverage filter file, the newly attached file replaces
the previously attached file.

Two or more models can have the same coverage filter file attached. If a model
has an attached filter file that contains coverage filter rules for specific objects
in a different model, those rules are ignored during coverage recording.

View Coverage Filter Rules in Your Model
Whenever you define a coverage filter rule or remove an existing coverage
filter rule, the Coverage Filter Viewer opens. This dialog box lists all the
coverage filter rules for your model. For more information, see “Using the
Coverage Filter Viewer” on page 18-11.

To open the Coverage Filter Viewer, right-click anywhere in the model
window and select Coverage > Open Filter Viewer.

If you are inside a subsystem, you can view any coverage filter rule attached
to the subsystem. To open the Coverage Filter Viewer, right-click any object
inside the subsystem and select Coverage > Show filter parent.

Remove a Coverage Filter Rule
To remove a model object from coverage filtering, right-click the object and
select Coverage > Remove .... The Coverage Filter Viewer opens. The
coverage filter rule for the select model object is no longer on the list of rules.

To remove additional rules, in the Coverage Filter Viewer, select the rule and
click Remove rule.
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Using the Coverage Filter Viewer
In the Coverage Filter Viewer, you can:

• Review and manage the coverage filter rules for your Simulink model.

• Attach and detach coverage filter files for your model.

• Navigate to the model to create additional coverage filter rules.
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To ... Do this:

Navigate to the model to create
coverage filter rules.

Click Add new rule by
right-clicking in the model.

Navigate to a model object associated
with a rule. 1 Select the rule.

2 Click View in model.

Delete a rule.
1 Select the rule.

2 Click Remove rule.

Save the current rules to a file.
1 Enter a file name or browse to the
file.

2 Click Apply.

Attach the current filter file to the
model. 1 Clear the Attach file to model

check box.

2 Click Apply.

Detach the current filter file from
the model. 1 Click Attach file to model.

2 Click Apply.

Attach a new filter file to the model.
1 Click Browse.

2 Navigate to the desired filter file.

3 Click Open.

4 Click Attach file to model.

5 Click Apply.

Close the Coverage Viewer and save
the changes.

Click OK.
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Example: Creating Coverage Filter Rules for a Simulink
Model

In this section...

“About the Example Model” on page 18-13

“Simulating the Example Model and Reviewing Coverage” on page 18-13

“Filtering a Stateflow Transition” on page 18-14

“Filtering a Stateflow Temporal Event” on page 18-16

“Filtering Library Reference Blocks” on page 18-18

“Filtering a Subsystem” on page 18-19

“Filtering a Specific Block” on page 18-19

About the Example Model
In this example, when you simulate the slvnvdemo_covfilt model, the model
does not record 100% coverage. In subsequent steps, you filter certain objects
from recording coverage. These steps allow you to focus on specific parts of
the model to test for coverage.

The slvnvdemo_covfilt model is configured to record and report coverage
during simulation for the following coverage metrics:

• Decision coverage

• Condition coverage

• Modified condition/decision coverage (MCDC)

Simulating the Example Model and Reviewing
Coverage
To identify areas of your model that do not record 100% coverage, simulate
the model and record coverage.

1 Open the demo model:

slvnvdemo_covfilt
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2 Select Simulation > Start.

When the simulation is complete, an HTML coverage report opens. This
model does not record 100% coverage.

Filtering a Stateflow Transition
In the Mode Logic Stateflow chart, the [!on] transition is never false because
it evaluates only when the [on] transition is false. If you do not collect
coverage for the [!on] transition, the chart behavior does not change, so
you should filter the [!on] transition.

1 Open the Mode Logic chart.
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2 Right-click the [!on] transition and select Coverage > Exclude this
transition.

The Coverage Filter Viewer opens with the new filter rule listed.

3 Click in the Rationale field and enter the reason for excluding this
transition, for example, This transition is never evaluated.

4 Save this rule to a filter file with the default name,
slvnvdemo_covfilt_covfilter.cvf. Click Apply.

If you are using this filter for the first time, the file is created in your
MATLAB Current Folder. You can specify a different file name and
location for your filter file.

5 Attach this filter file to the slvnvdemo_covfilt model. Click Attach file
to model and click Apply.

6 Click OK to close the Coverage Filter Viewer.

7 Simulate the model again and review the results in the coverage report.

Under Filtered Objects, the report lists the [!on] transition as filtered
from the coverage analysis.
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If you open the Mode Logic chart and click the transition, the Informer
window displays filtering information and the Rationale text.

Filtering a Stateflow Temporal Event
Temporal events in Stateflow are a common cause for missing coverage in a
chart, because they sometimes form an condition for coverage that can never
be satisfied.

For example, in the Mode Logic chart, as you can see from the coverage report,
the temporal event tick is never false.
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As a result, you cannot record 100% condition and MCDC coverage for the
transition after(4, tick).

To filter this temporal event, filter the transition after(4, tick).

1 Open the Mode Logic chart.

2 Right-click the after(4, tick) transition and selectCoverage > Exclude
temporal event ’tick’.

The Coverage Filter Viewer opens with the new filter rule listed.

3 Click in the Rationale field and enter text for excluding this transition,
for example, tick is never false.
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4 Save this rule to the current filter. Click Apply.

5 Simulate the model again and review the results.

The Filtered Blocks section of the report lists the transition after(4,
tick). Condition and MCDC coverage for the Mode Logic chart is not
recorded.

Filtering Library Reference Blocks
The slvnvdemo_covfilt model contains two instances of a library-linked
subsystem in the library slvnvdemo_covfilt_lib:

• protected division

• protected division1

The library subsystem is a protection against division by zero and might not
be relevant in the coverage report. Exclude it from coverage for this model.

1 In the model window, right-click either of the protected division reference
blocks.

When you filter a library block, all instances of that block are filtered from
coverage.

2 Select Coverage > Exclude reference library:
slvnvdemo_covfilt_lib/protected division.

The Coverage Filter Viewer opens with the new filter rule listed.

3 Click in the Rationale field for this new rule and enter text for excluding
this transition, for example, Protection against division by zero.

4 Save this rule to the current filter. Click Apply.

5 Simulate the model again and review the results.

The Filtered Blocks section of the report lists both protected division
reference blocks. No coverage is recorded for the two protected division
subsystems.

In the model window, the blocks filtered from coverage are colored grey.
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Filtering a Subsystem
The slvnvdemo_covfilt model uses a Constant block to drive the enable port
for the Switchable config subsystem. Because the constant is always 0, this
subsystem never executes.

Exclude the Switchable config subsystem from coverage.

1 In the model window, right-click the Switchable config subsystem.

2 Select Coverage > Exclude subsystem with all descendants.

3 Click in the Rationale field for this new rule and enter text for excluding
this transition, for example, Never executed.

4 Save this rule to the current filter. Click Apply.

5 Simulate the model again and review the results.

The Filtered Blocks section of the report lists the Switchable config
subsystem. No coverage is recorded for the subsystem.

Filtering a Specific Block
In the slvnvdemo_covfilt model, the rate signal can never be less than or
equal to 0, which is the value of the Lower limit parameter of the Saturation
block. This condition leads to missing coverage.
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Exclude the Saturation block from coverage.

1 In the model window, right-click the Saturation block.

2 Select Coverage > Exclude this block.

3 Click in the Rationale field for this new rule and enter text for excluding
this transition, for example, Input never <= lower limit (0).

4 Save this rule to the current filter. Click Apply.

5 Simulate the model again and review the results.

The Filtered Blocks section of the report lists the Saturation block.
Coverage for that block is omitted from the report.
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About Model Coverage Commands
Using model coverage commands lets you automate the entire model coverage
process with MATLAB scripts. You can use model coverage commands to set
up model coverage tests, execute them in simulation, and store and report
the results. For a list of the model coverage commands that the Simulink
Verification and Validation software provides, see Function Reference.

The following sections describe a workflow for using model coverage
commands to create, run, store, and report model coverage tests.

19-2



Creating Tests with cvtest

Creating Tests with cvtest
The cvtest command creates a test specification object. Once you create the
object, you simulate it with the cvsim command.

The call to cvtest has the following default syntax:

cvto = cvtest(root)

root is the name of, or a handle to, a Simulink model or a subsystem of
a model. cvto is a handle to the resulting test specification object. Only
the specified model or subsystem and its descendants are subject to model
coverage.

To create a test object with a specified label (used for reporting results):

cvto = cvtest(root, label)

To create a test with a setup command:

cvto = cvtest(root, label, setupcmd)

You execute the setup command in the base MATLAB workspace, just prior
to running the instrumented simulation. Use this command for loading data
prior to a test.

The returned cvtest object, cvto, has the following structure.

Field Description

id Read-only internal data-dictionary
ID

modelcov Read-only internal data-dictionary
ID

rootPath Name of the system or subsystem for
analysis

label String for reporting results

setupCmd Command executed prior to
simulation
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Field Description

settings.condition Set to 1 for condition coverage

settings.decision Set to 1 for decision coverage

settings.
designverifier

Set to 1 for coverage for Simulink
Design Verifier blocks.

settings.mcdc Set to 1 for MCDC coverage

settings.sigrange Set to 1 for signal range coverage

settings.sigsize Set to 1 for signal size coverage.

settings.tableExec Set to 1 for lookup table coverage

modelRefSettings.enable String specifying one of the following
values:

• Off — Disables coverage for all
referenced models

• all — Enables coverage for all
referenced models

• filtered— Enables coverage for
only referenced models not listed
in the excludedModels subfield

modelRefSettings.
excludeTopModel

Set to 1 for excluding coverage for
the top model

modelRefSettings.
excludedModels

String specifying a comma-separated
list of referenced models for
which coverage is disabled when
modelRefSettings.enable specifies
filtered

emlSettings.
enableExternal

Set to 1 to enable coverage for
external program files called by
MATLAB functions in your model

options.
forceBlockReduction

Set to 1 to override the Simulink
Block reduction parameter if it is
enabled.
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Running Tests with cvsim
Use the cvsim command to simulate a test specification object.

Note You do not have to enable model coverage reporting (see “Creating and
Running Test Cases” on page 16-3) to use the cvsim command.

The call to cvsim has the following default syntax:

cvdo = cvsim(cvto)

This command executes the cvtest object cvto by starting a simulation run
for the corresponding model. The results are returned in the cvdata object
cvdo. When recording coverage for multiple models in a hierarchy, cvsim
returns its results in a cv.cvdatagroup object.

You can also control the simulation in a cvsim command by using parameters
for the Simulink sim command:

• The following command returns the simulation time vector t, matrix of
state values x, and matrix of output values y.

[cvdo,t,x,y] = cvsim(cvto)

• The following command overrides default simulation values with new
values.

[cvdo,t,x,y] = cvsim(cvto, timespan, options)

For descriptions of the parameters t, x, y, timespan, and options in the
previous examples, see documentation for the sim command.

You can execute multiple test objects with the cvsim command. The following
command executes a set of coverage test objects, cvto1, cvto2, ... and
returns the results in a set of cvdata objects, cvdo1, cvdo2, ....

[cvdo1, cvdo2, ...] = cvsim(cvto1, cvto2, ...)
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You can also use the cvsim command to create and execute a cvtest object
in one command:

[cvdo,t,x,y] = cvsim(cvto, label, setupcmd)
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Retrieving Coverage Details from Results
Simulink Verification and Validation provides commands that allow you to
retrieve specific coverage information from the cvtest object after you have
simulated your model and recorded coverage. Use these commands to retrieve
the specified coverage information for a block, subsystem, or Stateflow chart
in your model or for the model itself:

• complexityinfo — Cyclomatic complexity coverage

• conditioninfo — Condition coverage

• decisioninfo — Decision coverage

• mcdcinfo— Modified condition/decision (MCDC) coverage

• sigrangeinfo — Signal range coverage

• sigsizeinfo — Signal size coverage

• tableinfo — Lookup Table block coverage

• getCoverageinfo— Coverage for Simulink Design Verifier blocks

The basic format of these functions is:

coverage = <coverage_type_prefix>info = (cvdata_object,
object, ignore_descendants)

• coverage— Multipart vector containing the retrieved coverage results for
object

• cvdata_object— cvdata object that you create when you call cvtest

• object — Handle to a model or object in the model

• ignore_descendants — Flag to ignore coverage results in subsystems,
referenced models, and Stateflow charts
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Creating HTML Reports with cvhtml
Once you run a test in simulation with cvsim, results are saved to
cv.cvdatagroup or cvdata objects in the base MATLAB workspace. Use the
cvhtml command to create an HTML report of these objects.

The following command creates an HTML report of the coverage results in
the cvdata object cvdo. The results are written to the file file in the current
MATLAB folder.

cvhtml(file, cvdo)

The following command creates a combined report of several cvdata objects:

cvhtml(file, cvdo1, cvdo2, ...)

The results from each object are displayed in a separate column of the HTML
report. Each cvdata object must correspond to the same root model or
subsystem, or the function produces errors.

You can specify the detail level of the report with the value of detail, an
integer between 0 and 3:

cvhtml(file, cvdo1, cvdo2,..., detail)

Higher numbers for detail indicate greater detail. The default value is 2.

19-8



Saving Test Runs to a File with cvsave

Saving Test Runs to a File with cvsave
Once you run a test with cvsim, save its coverage tests and results to a file
with the function cvsave:

cvsave(filename, model)

Save all the tests and results related to model in the text file filename.cvt:

cvsave(filename, cvto1, cvto2, ...)

Save the tests in the text file filename.cvt. Information about the referenced
models is also saved.

You can save specified cvdata objects to file. The following example saves
the tests, test results, and referenced models’ structure in cvdata objects to
the text file filename.cvt:

cvsave(filename, cvdo1, cvdo2, ...)
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Loading Stored Coverage Test Results with cvload
The cvload command loads into memory the coverage tests and results stored
in a file by the cvsave command. The following example loads the tests and
data stored in the text file filename.cvt:

[cvtos, cvdos] = cvload(filename)

The cvtest objects that are successfully loaded are returned in cvtos, a cell
array of cvtest objects. The cvdata objects that are successfully loaded are
returned in cvdos, a cell array of cvdata objects. cvdos has the same size as
cvtos, but can contain empty elements if a particular test has no results.

In the following example, if restoretotal is 1, the cumulative results from
prior runs are restored:

[cvtos, cvdos] = cvload(filename, restoretotal)

If restoretotal is unspecified or 0, the model’s cumulative results are
cleared.

cvload Special Considerations
When using the cvload command, be aware of the following considerations:

• When a model with the same name exists in the coverage database, only
the compatible results are loaded from the file. They reference the existing
model to prevent duplication.

• When the Simulink models referenced in the file are open but do not exist
in the coverage database, the coverage tool resolves the links to the models
that are already open.

• When you are loading several files that reference the same model, only the
results that are consistent with the earlier files are loaded.
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Coverage Script Example
The following script demonstrates some common model coverage commands.

This script:

• Creates two data files to load before simulation.

• Creates two cvtest objects, testObj1 and testObj2 and simulates them
according to their specifications. Each cvtest object uses the setupCmd
property to load a data file before simulation.

• Enables decision, condition, and MCDC coverage.

• Retrieves the decision coverage results for the Adjustable Rate Limited
subsystem.

• Uses cvhtml to display the coverage results for the two tests and the
cumulative coverage.

• Compute cumulative coverage with the + operator and save the results

mdl = 'slvnvdemo_ratelim_harness';
mdl_subsys = 'slvnvdemo_ratelim_harness/Adjustable Rate Limiter';

open_system(mdl);
open_system(mdl_subsys);

t_gain = (0:0.02:2.0)'; u_gain = sin(2*pi*t_gain);
t_pos = [0;2]; u_pos = [1;1]; t_neg = [0;2]; u_neg = [-1;-1];
save('within_lim.mat','t_gain','u_gain','t_pos','u_pos','t_neg','u_neg');
t_gain = [0;2]; u_gain = [0;4]; t_pos = [0;1;1;2];
u_pos = [1;1;5;5]*0.02; t_neg = [0;2]; u_neg = [0;0];
save('rising_gain.mat','t_gain','u_gain','t_pos','u_pos','t_neg','u_neg')

testObj1 = cvtest(mdl_subsys);
testObj1.label = 'Gain within slew limits';
testObj1.setupCmd = 'load(''within_lim.mat'');';
testObj1.settings.mcdc = 1;
testObj1.settings.condition = 1;
testObj1.settings.decision = 1;
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testObj2 = cvtest(mdl_subsys);
testObj2.label = 'Rising gain that temporarily exceeds slew limit
testObj2.setupCmd = 'load(''rising_gain.mat'');';
testObj2.settings.mcdc = 1;
testObj2.settings.condition = 1;
testObj2.settings.decision = 1;

[dataObj1,T,X,Y] = cvsim(testObj1,[0 2]);
decision_cov1 = decisioninfo(dataObj1,mdl_subsys);
percent_cov1 = 100 * decision_cov1(1) / decision_cov1(2)
cc_cov2 = complexityinfo(dataObj1, mdl_subsys);

[dataObj2,T,X,Y] = cvsim(testObj2,[0 2]);
decision_cov2 = decisioninfo(dataObj2,mdl_subsys);
percent_cov2 = 100 * decision_cov2(1) / decision_cov2(2)
cc_cov2 = complexityinfo(dataObj1, mdl_subsys);

cvhtml('ratelim_report',dataObj1,dataObj2);
cumulative = dataObj1+dataObj2;

cvsave('ratelim_testdata',cumulative);

close_system('slvnvdemo_ratelim_harness',0);

19-12



Using Model Coverage Commands for Referenced Models

Using Model Coverage Commands for Referenced Models

In this section...

“Introduction” on page 19-13

“Creating a Test Group with cv.cvtestgroup” on page 19-16

“Running Tests with cvsimref” on page 19-16

“Extracting Results from cv.cvdatagroup” on page 19-17

Introduction
Using Simulink software, you can include one model in another with Model
blocks. Each Model block represents a reference to another model, called a
referenced model or submodel. A referenced model can contain Model blocks
that reference other models. You can construct a hierarchy of referenced
models, in which the topmost model is called the top model. For more
information, see “Referencing a Model” in the Simulink User’s Guide.

Model coverage supports referenced models that operate in Normal mode.
You can record coverage only for those Model blocks whose Simulation
mode parameter specifies Normal. You can use model coverage commands
to record coverage for referenced models (see Chapter 19, “Using Model
Coverage Commands”). However, if you want to record different types of
coverage for models in a hierarchy, you must use the cvsimref function. The
following steps describe a basic workflow for using this function to obtain
model coverage results for Model blocks.

Step Description See...

1 Use cv.cvtestgroup to group
together test specification objects
that correspond to each model in
a hierarchy.

“Creating a Test Group with
cv.cvtestgroup” on page 19-16

2 Use cvsimref to simulate the top
model in a hierarchy and record
coverage results for its referenced
models.

“Running Tests with cvsimref” on
page 19-16
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Step Description See...

3 Use cv.cvdatagroup to extract
the coverage data objects that
correspond to each model in a
hierarchy.

“Extracting Results from
cv.cvdatagroup” on page 19-17

The next sections illustrate how to complete each of these steps using the
following model hierarchy.
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Creating a Test Group with cv.cvtestgroup
The cvtest command creates a test specification object for a Simulink model
(see “Creating Tests with cvtest” on page 19-3). If your model references other
models, you might use a different test specification object for each model in
the hierarchy. In this case, the cv.cvtestgroup object allows you to group
together multiple test specification objects. After you create a group of test
specification objects, you simulate it using the cvsimref function.

For example, suppose that you create a different test specification object for
each of the models in your hierarchy:

cvto1 = cvtest('TopModel')
cvto2 = cvtest('SubModel1')
cvto3 = cvtest('SubModel2')

The following command creates a test group object named cvtg, which
contains all the cvtest objects associated with your model hierarchy:

cvtg = cv.cvtestgroup(cvto1, cvto2, cvto3)

A cv.cvtestgroup object provides methods, such as add and get, so that
you can customize the contents of the cv.cvtestgroup object to meet your
needs. For more information, see the documentation for the cv.cvtestgroup
function.

Running Tests with cvsimref
Once you create a test group object, you simulate it with the cvsimref
function.

Note You must use the cvsimref function to record coverage for referenced
models in a hierarchy.

The call to cvsimref has the following default syntax:

cvdg = cvsimref(topModelName, cvtg)
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This command executes the test group object cvtg by simulating the top
model in the corresponding model hierarchy, topModelName. It returns the
coverage results in a cv.cvdatagroup object named cvdg.

You can use parameters from the Simulink sim function in a cvsimref
command to control the simulation:

• To return the simulation time vector t, matrix of state values x, and matrix
of output values y:

[cvdg,t,x,y] = cvsimref(topModelName, cvtg)

• To override default simulation values with new values:

[cvdg,t,x,y] = cvsimref(topModelName, cvtg, timespan, options)

For descriptions of the parameters t, x, y, timespan, and options, see the
documentation for the sim function.

Extracting Results from cv.cvdatagroup
Once you simulate a test group with cvsimref, the function returns results
that reside in a cv.cvdatagroup object. The data group object contains
multiple cvdata objects, each of which corresponds to coverage results for a
particular model in the hierarchy.

A cv.cvdatagroup object provides methods, such as allNames and get,
so that you can extract individual cvdata objects. For example, enter the
following command to obtain a cell array that lists all model names associated
with the data group cvdg:

modelNames = cvdg.allNames

To extract the cvdata objects that correspond to the particular models, enter:

cvdo1 = cvdg.get('TopModel')
cvdo2 = cvdg.get('SubModel1')
cvdo3 = cvdg.get('SubModel2')

After you extract the individual cvdata objects, you can use other model
coverage commands to use the coverage data of a particular model. For
example, you can use the cvhtml function to create and display an HTML
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report of the coverage results (see “Creating HTML Reports with cvhtml”
on page 19-8).
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What Is Component Verification?

In this section...

“Component Verification Approaches” on page 20-2

“Using Simulink® Verification and Validation Tools for Component
Verification” on page 20-2

Component Verification Approaches
Component verification allows you to test a design component in your model
using one of two approaches:

• Within the context of the model that contains the component —
Using systematic simulation of closed-loop controllers requires that you
verify components within a control system model. Doing so allows you
to test the control algorithms with your model. This approach is called
system analysis.

• As standalone components — For a high level of confidence in the
correctness of the component algorithm, verify the component in isolation
from the rest of the system. This approach is called component analysis.

Verifying standalone components provides several advantages:

- You can use the analysis to focus on portions of the design that you
cannot test because of the physical limitations of the system being
controlled.

- You can use this approach for open-loop simulations to test the plant
model without feedback control.

- You can use this approach when the model is not yet available or when
you need to simulate a control system model in accelerated mode for
performance reasons.

Using Simulink Verification and Validation Tools for
Component Verification
By isolating the component to verify and using tools that the Simulink
Verification and Validation software provides, you create test cases that allow
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you to expand the scope of the testing for large models. This expanded testing
helps you accomplish the following:

• Achieve 100% model coverage — If certain model components do not record
100% coverage, the top-level model cannot achieve 100% coverage. By
verifying these components individually, you can create test cases that
fully specify the component interface, allowing the component to record
100% coverage.

• Debug the component — To ensure that each model component satisfies
the specified design requirements, you can create test cases that verify that
specific components perform as designed.

• Test the robustness of the component — To ensure that a component
handles unexpected inputs and calculations properly, you can create test
cases that generate data. Then, test the error-handling capabilities in
the component.
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Workflows for Component Verification

In this section...

“Common Workflow for Component Verification” on page 20-4

“Verifying a Component Independently of the Container Model” on page
20-6

“Verifying a Model Block in the Context of the Container Model” on page
20-7

Common Workflow for Component Verification
The following graphic illustrates the common workflow for component
verification.
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This graphic illustrates the two approaches for component verification,
described in “What Is Component Verification?” on page 20-2:

20-4



Workflows for Component Verification

1 Choose your approach for component verification:

• For closed-loop simulations, verify a component within the context of its
container model by logging the signals to that component and storing
them in a data file. If those signals do not constitute a complete test
suite, generate a harness model and add or modify the test cases in the
Signal Builder.

• For open-loop simulations, verify a component independently of the
container model by extracting the component from its container model
and creating a harness model for the extracted component. Add or
modify test cases in the Signal Builder and log the signals to the
component in the harness model.

2 Prepare component for verification.

3 Create and log test cases. If desired, merge the test case data into a single
data file.

The data file contains the test case data for simulating the component. If
you cannot achieve the desired results with a certain set of test cases, add
new test cases or modify existing test cases in the data file, and merging
them into a single data file.

Continue adding or modifying test cases until you achieve a test suite that
satisfies the goals of your analysis.

4 Execute the test cases in Software-in-the-Loop or Processor-in-the-Loop
mode.

5 After you have a complete test suite, you can:

• Simulate the model and execute the test cases to:

– Record coverage.

– Record output values to make sure that you get the expected results.

• Invoke the Code Generation Verification (CGV) API to execute the
generated code for the model that contains the component in simulation,
Software-in-the-Loop (SIL), or Processor-in-the-Loop (PIL) mode.
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Note To execute a model in different modes of execution, you use the
CGV API to verify the numerical equivalence of results. For more
information about the CGV API, see “Verifying Numerical Equivalence
with Code Generation Verification”.

The next sections describe the steps for component verification in more detail:

• “Verifying a Component Independently of the Container Model” on page
20-6

• “Verifying a Model Block in the Context of the Container Model” on page
20-7

Verifying a Component Independently of the
Container Model
Use component analysis to verify:

• Model blocks

• Atomic subsystems

• Stateflow atomic subcharts

The recommended steps for verifying a component independently of the
container model:

1 Depending on the type of component, take one of the following actions:

• Model blocks — Open the referenced model.

• Atomic subsystems — Extract the contents of the subsystem into its
own Simulink model.

• Atomic subcharts — Extract the contents of the Stateflow atomic
subchart into its own Simulink model.

2 Create a harness model for:

• The referenced model
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• The extracted model that contains the contents of the atomic subsystem
or atomic subchart

3 Add or modify test cases in the Signal Builder in the harness model.

4 Log the input signals from the Signal Builder to the test unit.

5 Repeat steps 3 and 4 until you are satisfied with the test suite.

6 Merge the test case data into a single file.

7 Depending on your goals, take one of the following actions:

• Execute the test cases to:

– Record coverage.

– Record output values and make sure that they equal the expected
values.

• Invoke the Code Generation Verification (CGV) API to execute the test
cases in Software-in-the-Loop (SIL) or Processor-in-the-Loop (PIL) mode
on the generated code for the model that contains the component.

If the test cases do not achieve the desired results, repeat steps 3 through 5.

Verifying a Model Block in the Context of the
Container Model
Use system analysis to verify a Model block in the context of the block’s
container model. Use this technique when you analyze a closed-loop controller.

The recommended steps for system analysis:

1 Log the input signals to the component by simulating the container model.

or

Analyze the model using the Simulink Design Verifier software.

2 If you want to add test cases to your test suite or modify existing test cases,
create a harness model using the logged signals.
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3 Add or modify test cases in the Signal Builder in the harness model.

4 Log the input signals from the Signal Builder to the test unit.

5 Repeat steps 3 and 4 until you are satisfied with the test suite.

6 Merge the test case data into a single file.

7 Depending on your goals, do one of the following:

• Execute the test cases to:

– Record coverage.

– Record output values and make sure that they equal the expected
values.

• Invoke the Code Generation Verification (CGV) API to execute the test
cases in Software-in-the-Loop (SIL) or Processor-in-the-Loop (PIL) mode
on the generated code for the model.

If the test cases do not achieve the desired results, repeat steps 3 through 5.
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Functions for Component Verification
The Simulink Verification and Validation software provides several functions
that facilitate the tasks associated with component verification.

Task Function

Simulate a Simulink model and log input signals to
a Model block in the model. If you modify the test
cases in the Signal Builder harness model, use this
approach for logging input signals to the harness
model itself.

slvnvlogsignals

Create a harness model for a component, using
logged input signals if specified, or using the
default signals.

A harness model contains four Simulink blocks
as described in “Preparing the Component for
Verification” on page 21-6 in Chapter 21, “Example:
Verifying a Component for Code Generation”.

slvnvmakeharness

Merge test case data into a single data structure
for batch execution or harness generation.

slvnvmergedata

Merge test cases from several harness models into
a single harness model.

slvnvmergeharness

Extract an atomic subsystem or atomic subchart
into a new model.

slvnvextract

Simulate a model, executing the specified test cases
to record model coverage and outport values.

slvnvruntest

Invoke the Code Generation Verification (CGV)
API, and execute the specified test cases on the
generated code for the model.

slvnvruncgvtest

Component verification functions do not support the following Simulink
software features:

• Variable-step solvers for slvnvruntest

• Component interfaces that contain:
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- Complex signals

- Variable-size signals

- Array of buses

- Multiword fixed-point data types
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About the Example Model
This example uses the slvnvdemo_powerwindow demo model to show how to
verify a component in the context of the model that contains that component.
As you work through this example, you use the Simulink Verification and
Validation component verification functions to create test cases and measure
coverage for a referenced model. In addition, you execute the referenced
model in both simulation mode and Software-in-the-Loop (SIL) mode using
the Code Generation Verification (CGV) API and then compare the results.

Note You must have the following product licenses to run this example:

• Stateflow

• Embedded Coder

• Simulink Coder

The component you verify is a Model block named control. This component
resides inside the power_window_control_system subsystem in the top level of
the slvnvdemo_powerwindow model.
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The Model block references the slvnvdemo_powerwindow_controller model.
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The referenced model contains a Stateflow chart control, which implements
the logic for the power window controller.
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Preparing the Component for Verification
To verify the referenced model slvnvdemo_powerwindow_controller, you
need to create a harness model that contains the input signals that simulate
the controller in the plant model. Perform the following steps:

1 Open the slvnvdemo_powerwindow demo model:

slvnvdemo_powerwindow

2 Open the power_window_control_system subsystem.

3 The Model block named control in the power_window_control_system
subsystem references the component you verify during this
example—slvnvdemo_powerwindow_controller. Load the referenced
model:

load_system('slvnvdemo_powerwindow_controller');

4 Simulate the Model block that references
slvnvdemo_powerwindow_controller and log the input signals to the
Model block:

loggedSignalsPlant = ...
slvnvlogsignals(...

'slvnvdemo_powerwindow/power_window_control_system/control');

slvnvlogsignals stores the logged signals in loggedSignalsPlant.

5 Generate an empty harness model so that you can create new test cases
manually:

harnessModelFilePath = ...
slvnvmakeharness('slvnvdemo_powerwindow_controller');

slvnvmakeharness creates a harness model named
slvnvdemo_powerwindow_controller_harness. The harness
model includes:

• Test Unit — A Model block that references the
slvnvdemo_powerwindow_controller model.
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• Inputs — A Signal Builder block that contains one test case. That test
case specifies the values of the input signals logged when the model
slvnvdemo_powerwindow was simulated.

• Test Case Explanation — A DocBlock block that describes the test case.

• Size-Type — A Subsystem block that transmits signals from the Inputs
block to the Test Unit block. The output signals from this block match
the input signals for the Model block you are verifying.

• moveUp and moveDown — Two output ports that match the output
ports from the Model block.

6 Save the name of the harness model for use later in this example:
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[~,harnessModel] = fileparts(harnessModelFilePath);

7 Leave all models open for the next part of this example.

Next, create a test case that tests values for input signals to the component.

21-8



Creating and Logging Test Cases

Creating and Logging Test Cases
Add a test case for your component to help you get closer to achieving 100%
coverage.

For this example, use the signalbuilder function to add a new test case to
the Signal Builder block in the harness model. The new test case specifies
new values for the input signals to the component:

1 Load the file that contains the data for the new test case into the MATLAB
workspace:

load('slvnvdemo_powerwindow_controller_newtestcase.mat');

The workspace variables newTestData and newTestTime contain the
test-case data.

2 Add the new test case to the Signal Builder block in the harness model.

signalBuilderBlock = slvnvdemo_signalbuilder_block(harnessModel);
signalbuilder(signalBuilderBlock,'Append',...

newTestTime, newTestData,...
{'endstop','obstacle','driver(1)','driver(2)','driver(3)',...
'passenger(1)','passenger(2)','passenger(3)'},'New Test Case');

3 Simulate the harness model with both test cases, then log the signals to the
referenced model, and save the results:

loggedSignalsHarness = slvnvlogsignals(harnessModel);

Next, record coverage for the slvnv_powerwindow_controller model.
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Merging the Test Case Data
You have two sets of test case data:

• loggedSignalsPlant— Logged signals to the Model block control

• loggedSignalsHarness — Logged signals to the test cases you added to
the empty harness

To simulate all the test data at the same time, merge the two data files into a
single data file:

1 Combine the test case data:

mergedTestCases = slvnvmergedata(loggedSignalsPlant,...
loggedSignalsHarness);

2 View the merged data:

disp(mergedTestCases);

Next, simulate the referenced model with the merged data and recover
coverage for the referenced model, slvnv_powerwindow_controller.
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Recording Coverage for the Component
Model coverage is a measure of how thoroughly a test case tests a model and
the percentage of pathways that a test case exercises. To record coverage for
the slvnv_powerwindow_controller model:

1 Create a default options object, required by the slvnvruntest function:

runopts = slvnvruntestopts;

2 Specify to simulate the model, and record coverage:

runopts.coverageEnabled = true;

3 Simulate the model using the logged input signals:

[~, covdata] = slvnvruntest('slvnvdemo_powerwindow_controller',...
mergedTestCases,runopts);

4 Display the HTML coverage report:

cvhtml('Coverage with Test Cases from Harness', covdata);

The slvnv_powerwindow_controller model achieved:

• Decision coverage: 44%

• Condition coverage: 45%

• MCDC coverage: 10%

Note For more information about decision coverage, condition coverage,
and MCDC coverage, see “Types of Model Coverage” on page 13-4.

If you do not achieve the desired coverage, continue to modify the test cases in
the Signal Builder in the harness model, log the input signals to the harness
model, and repeat the preceding steps until you achieve the desired coverage.

To achieve additional coverage to bring your model closer to 100% coverage,
modify or add test cases using the Signal Builder block in the harness model,
as described in “Creating and Logging Test Cases” on page 21-9.

21-11



21 Example: Verifying a Component for Code Generation

Executing the Component in Simulation Mode
To verify that the generated code for the model produces the same results
as simulating the model, use the Code Generation Verification (CGV) API
methods. When you perform this procedure, the simulation compiles and
executes the model code using the merged test cases:

1 Create a default options object for slvnvruncgvtest:

runcgvopts = slvnvruntestopts('cgv');

2 Specify to execute the model in simulation mode:

runcgvopts.cgvConn = 'sim';

3 Execute the slvnv_powerwindow_controller model using the two test
cases and the runopts object:

cgvSim = slvnvruncgvtest('slvnvdemo_powerwindow_controller', ...
mergedTestCases, runcgvopts);

These steps save the results in the workspace variable cgvSim.

Next, execute the same model with the same test cases in Software-in-the-Loop
(SIL) mode and compare the results from both simulations.

For more information about Normal simulation mode, see “Executing the
Model”.
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Executing the Component in Software-in-the-Loop (SIL)
Mode

When you execute a model in Software-in-the-Loop (SIL) mode, the simulation
compiles and executes the generated code on your host computer.

To execute a model in SIL mode, you must have an Embedded Coder license.

In this section, you execute the slvnvdemo_powerwindow_controller model
in SIL mode and compare the results to the previous section, where you
executed the model in simulation mode:

1 Specify to execute the model in SIL mode:

runcgvopts.cgvConn = 'sil';

2 Execute the slvnv_powerwindow_controller model using the merged
test cases and the runopts object:

cgvSil = slvnvruncgvtest('slvnvdemo_powerwindow_controller', ...
mergedTestCases, runcgvopts);

The workspace variable cgvSil contains the results of the SIL mode
execution.

3 Compare the results in cgvSil to the results in to cgvSim (the results from
the simulation mode execution). Use the cgv.CGV.compare method to
compare the results from the two simulations:

for i=1:length(loggedSignalsHarness.TestCases)
simout = cgvSim.getOutputData(i);
silout = cgvSil.getOutputData(i);
[matchNames, ~, mismatchNames, ~ ] = ...

cgv.CGV.compare(simout, silout);

4 Display the results of the comparison in the MATLAB command window:

fprintf('\nTest Case(%d): %d Signals match, ...
%d Signals mismatch', i, length(matchNames), ...
length(mismatchNames));

end
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For more information about Software-in-the-Loop (SIL) simulations, see
“What are SIL and PIL Simulations?”
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the Verification Manager”
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Overview of Model Verification Blocks
Model verification blocks monitor model signals and model characteristics,
and check that they remain within specified bounds during simulation.

Simulink “Model Verification” library blocks monitor time-domain signals in
your model, according to the specifications that you assign to the blocks.

Note To see a complete description of all Simulink model verification
blocks, see the “Model Verification” category in the Simulink Block Reference
documentation.

If you have Simulink® Control Design™ software, you can also monitor
frequency-domain characteristics such as:

• Gain and phase margins

• Peak magnitude

Note For more information about the Simulink Control Design model
verification blocks, see “Model Verification” in the Simulink Control Design
documentation.

You set a verification block to assert when its signal leaves the limit or range
that you specify. During simulation, when the signal crosses the limit, the
verification block can:

• Stop the simulation and bring immediate focus to that part of the model.

• Report the limit encounter with a logical signal output of its own. If the
simulation does not encounter the limit, the signal output is true. If the
simulation encounters the limit, the signal output is false.

Use these blocks with the Verification Manager tool in the Signal Builder to
construct simulation tests for your model.
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Example: Using the Check Static Lower Bound Block to
Check for Out-of-Bounds Signal

The following example uses a Check Static Lower Bound block to stop
simulation when a signal from a Sine Wave block crosses its lower bound limit.

1 Attach a Check Static Lower Bound block to the signal from a Sine Wave
block.

2 Set the Simulation stop time to 2 seconds.

3 Double-click the Sine Wave block and set the following parameters:

• Set the Amplitude to 1.

• Set the Frequency to pi radians per second.

4 Double-click the Check Static Lower Bound block and set the Lower
bound parameter to -0.8.
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Enable assertion is the default. This parameter enables a verification
block for an assertion. You set the Check Static Lower Bound block to
detect a signal value of –0.8 or lower. If the signal value reaches that value
or falls below it, the simulation stops.

5 Run the simulation.

The model stops simulating after 1.295 seconds, when the output is –0.8.
The software highlights the Check Static Lower Bound block.

When the simulation stops, you see the following diagnostic message.

6 To verify the signal value, double-click the Scope block.
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7 To disable the Check Static Lower Bound block from asserting its limit,
clear the Enable assertion check box.

The block is crossed out in the model, as shown.
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Simulink Control Design Model Verification Blocks
If you have Simulink Control Design software, you can use the “Model
Verification” blocks in the Simulink Control Design library to:

• Specify bounds on linear system characteristics.

• Check that the bounds are satisfied during simulation.

For example, you can check if the linearized behavior of your model satisfied
upper and lower magnitude bounds on a Bode plot or gain and phase margins.
For more information, see the individual block reference pages.
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What Is the Verification Manager?
The Verification Manager is a graphical interface in the Signal Builder dialog
box. Using this tool, you can manage all the Model Verification blocks in
your model from a central location.
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Opening the Verification Manager
Create a Simulink model that you can use to examine the Verification
Manager.

1 In the Simulink software, create the following example model.

a In the Signal Builder block, create a signal group with five signals in
the group.

b Make two copies of the signal group, so that you have three signal
groups: Group 1, Group 2, Group 3.
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Note A Signal Builder block provides test signals for an entire model
from one location. This model contains a Signal Builder block that feeds
five test signals to the Model Verification blocks. The model sends the
first four signals directly to Check Static Upper Bound blocks. The
model sends the fifth signal to a subsystem that contains a Check Static
Upper Bound block.

For more information on the Signal Builder block, see “Working with
Signal Groups” in the Simulink documentation.

c To set each Check Static Upper Bound verification block to assert for an
upper bound of 1, set the Upper bound parameter to 1.

d For the following blocks, disable the assertion by clearing the Enable
assertion parameter:

• Check Static Upper Bound

• Check Static Upper Bound1

• Check Static Upper Bound2

• Check Static Upper Bound in the subsystem

These blocks are crossed out in the model.

e To enable the Check Static Upper Bound3 block, select the Enable
assertion parameter.

2 Save this model and name it ex_verif_mgr_test_signals.

3 To open the model Signal Builder dialog box, double-click the Signal
Builder block. The signals in the first group (Group 1 in this example)
are displayed.
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4 On the Signal Builder dialog box toolbar, select the Show Verification

Settings tool .

The Verification block settings pane and the Requirements pane are
displayed.
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The Verification block settings pane lists all Model Verification blocks
in the model, grouped by subsystem. If you right-click in this pane, you
can select on of three options for viewing Model Verification blocks in this
window:

• Display > Tree format— If enabled, lists the blocks as they appear in
the model hierarchy.
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• Display > Overridden blocks only— If enabled, lists only the blocks
that have been disabled.

• Display > Active blocks only— If enabled, lists only the blocks that
are enabled.

Note If both Overridden blocks only and Active blocks only are
enabled, no Model Verification blocks appear. If both Overridden blocks
only and Active blocks only are disabled, all Model Verification blocks
appear.

In this example, the Verification block settings pane displays five Check
Static Upper Bound blocks. Four are in the top level of the model, and
one is in a subsystem.

The Requirements pane lists the requirements document links for the
current signal group. For details on adding requirement document links
in the Signal Builder dialog box, see Chapter 24, “Linking Test Cases to
Requirements Documents Using the Verification Manager”.

5 For this example, select to close the Requirements pane.

6 To display only the enabled Model Verification blocks for the current signal
group, in the Verification block settings toolbar, select the List Enabled

Verifications tool .
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7 To redisplay all Model Verification blocks for the current group, click the

Show Verification Block Hierarchy tool .
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Enabling and Disabling Model Verification Blocks Using
the Verification Manager

Use the Verification Manager to enable and disable individual Model
Verification blocks in signal groups. To open the Verification Manager in the

Signal Builder dialog box, click .

The Verification block settings pane lists the Model Verification blocks in
the model. Each verification block has a status node that indicates whether
its assertion is enabled or disabled. Each verification block’s status node also
indicates whether the enabled or disabled setting applies universally or to the
active group. The following table describes the different types of status nodes.

Node Status

Verification block is disabled for this group. Click to enable
for the current group.

Verification block is enabled for the current group. Click to
disable for the current group.

Verification block is enabled for all test groups.

Use the Verification Manager to enable or disable model verification blocks
in the ex_verif_mgr_test_signals model that you created in “Opening the
Verification Manager” on page 23-3.

1 In the Verification Manager, click the empty check box next to the Check
Static Upper Bound1 node to enable that node for the current group
(Group 1).

In the Verification block settings pane, when you enable a disabled
block, you see the following change in how the block is displayed in the
model.
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Because you enabled the Check Static Upper Bound1 block in the current
group, an Override label is applied to the block and it is no longer crossed
out.

2 In the Signal Builder, click the Group 2 tab.

3 Select the empty check box next to the Check Static Upper Bound2 node to
enable that block for the current group (Group 2).
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The Check Static Upper Bound2 block is no longer crossed out, indicating
that the block is enabled for the current group. However, Check Static
Upper Bound1 is crossed out because it is enabled in another group.

4 Save the model with these changes.
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Using Enabling and Disabling Tools in the Verification
Manager

If you have a lot of verification blocks, it is tedious to enable and disable
blocks individually. Using the Verification Manager, you can enable and
disable blocks from context menu options. Depending on the status of the
node, you have the following options.

Node
Status Context Menu Options

• Contents enable for all groups

• Contents enable by group

• Contents group enable

• Contents group disable

• Block enable by group

• Block enable for all groups

• Block group enable

• Block enable for all groups

• Block group disable

For example, assume that you define the following groups in the Verification
Manager for a model with five Model Verification blocks.

$�
� ������������������������������������$�
� ��������������������������������������$�
� �0
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1 In the Verification Manager window, right-click the
ex_verif_mgr_test_signals node and select Contents enable
for all groups.

This option enables all verification blocks, for all test groups, in all
subsystems; the settings for all groups look as follows:

2 Right-click ex_verif_mgr_test_signals and select Contents enable by
group.

This option restores the individually enabled/disabled settings for each
verification block in each group.

$�
� ������������������������������������$�
� ��������������������������������������$�
� �0

3 Click the Group 1 tab, right-click ex_verif_mgr_test_signals, and select
Contents group enable.

This option individually enables all contained blocks for only Group 1.
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$�
� ������������������������������������$�
� ���-���%�����/��������������$�
� �0�-���%�����/

4 Click the Group 1 tab, right-click ex_verif_mgr_test_signals and select
Contents group disable.

This option individually disables all contained blocks for only Group 1.

$�
� ������������������������������������$�
� ���-���%�����/��������������$�
� �0�-���%�����/

5 Click the Group 1 tab, right-click the Check Static Upper Bound node, and
select Block enable for all groups.

This option enables the Check Static Upper Bound block for all groups.

$�
� ������������������������������������$�
� ��������������������������������������$�
� �0

6 Click the Group 1 tab, right-click the Check Static Upper Bound node,
and select Block enable by group.
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This option restores the individually enabled/disabled state to this block for
all groups. The Block enable by group option lets you enable or disable
this node individually for each group.

$�
� ������������������������������������$�
� �������������������������������������$�
� �0

7 Click the Group 1 tab, right-click the Check Static Upper Bound node,
and select Block group enable.

This option enables the Check Static Upper Bound block for this group only.

$�
� ������������������������������������$�
� ���-���%�����/��������������$�
� �0�-���%�����/

Selecting Block group disable disables the specified block for this group
only.
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Linking Test Cases to
Requirements Documents
Using the Verification
Manager

You can link requirements documents to test cases and their corresponding
Model Verification blocks through the Verification Manager Requirements
pane in the Signal Builder.

1 To display the Requirements pane in the Signal Builder dialog box:

a Click the Show verification settings button ( ).

b Click the Requirements display button ( ).

2 In the Requirements pane, right-click anywhere.

3 From the context menu, select Edit/Add Links.

The Requirements dialog box opens.

4 When you browse and select a requirements document, the RMI stores the
document path as specified by the Document file reference option on the
Requirements Settings dialog box, Selection Linking tab. Make sure that
setting is correct for your working environment.

For information about which setting to use, see “Resolving the Document
Path” on page 6-14.
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5 Add links to requirements documents, as described in Chapter 4, “Creating
and Managing Requirements Links”.

The names of the linked requirements appear in the Requirements pane.

6 To view the requirements document in its native editor, right-click a
requirement link and select View.
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7 Optionally, to delete a requirement link, right-click the link and select
Delete.
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About the Model Advisor
The Model Advisor is a GUI that you can use to check a Simulink model or
subsystem for consistent modeling guidelines. Using the MathWorks checks,
you can easily apply these guidelines across projects and development teams.
For more information, see “Consulting the Model Advisor” in the Simulink
documentation.

The Model Advisor includes MathWorks checks that help you define and
implement consistent design guidelines. When you run the checks, review
your model for conditions and configuration settings that cause inaccurate
or inefficient simulation and code generation of the system that the model
represents. The Model Advisor displays different MathWorks checks
depending on which products you have installed. For more information on
individual checks, see:

• “Simulink Checks”

• “Simulink Coder Checks”

• “Simulink Verification and Validation Checks”

• “Simulink Control Design Checks”

Software is inherently complex and may not be completely free of
errors. Model Advisor checks might contain bugs. MathWorks reports
known bugs brought to its attention on its Bug Report system at
http://www.mathworks.com/support/bugreports/. The bug reports are an
integral part of the documentation for each release. Examine periodically all
bug reports for a release as such reports may identify inconsistencies between
the actual behavior of a release you are using and the behavior described
in this documentation.

While applying Model Advisor checks to your model will increase the
likelihood that your model does not violate certain modeling standards
or guidelines, their application cannot guarantee that the system being
developed will be safe or error-free. It is ultimately your responsibility to
verify, using multiple methods, that the system being developed provides its
intended functionality and does not include any unintended functionality.
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Checking Systems Programmatically

In this section...

“Overview” on page 25-3

“Workflow for Checking Systems Programmatically” on page 25-3

“Finding Check IDs” on page 25-4

“Creating a Function for Checking Multiple Systems” on page 25-5

“Checking Multiple Systems in Parallel” on page 25-6

“Creating a Function for Checking Multiple Systems in Parallel” on page
25-6

“Archiving and Viewing Results” on page 25-8

“Archiving and Viewing Results Example” on page 25-12

Overview
The Simulink Verification and Validation product includes a programmable
interface for scripting and for command-line interaction with the Model
Advisor. Using this interface, you can:

• Create scripts and functions for distribution that check one or more
systems using the Model Advisor.

• Run the Model Advisor on multiple systems in parallel on multicore
machines (requires a Parallel Computing Toolbox™ license).

• Check one or more systems using the Model Advisor from the command line.

• Archive results for reviewing at a later time.

Workflow for Checking Systems Programmatically
To define the workflow for running multiple checks on systems:

1 Specify a list of checks to run. Do one of the following:

• Create a Model Advisor configuration file that includes only the checks
that you want to run. For more information, see “Organizing Checks and
Folders Using the Model Advisor Configuration Editor” on page 28-4.
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• Create a list of check IDs. For more information on finding check IDs,
see “Finding Check IDs” on page 25-4.

2 Specify a list of systems to check.

3 Run the Model Advisor checks on the list of systems using the
ModelAdvisor.run function.

4 Archive and review the results of the run. For details, see “Archiving and
Viewing Results” on page 25-8.

Finding Check IDs
An ID is a unique string that identifies a Model Advisor check. You find check
IDs in the Model Advisor, using check context menus.

To Find... Do This...

A check ID
1 In the left pane of the Model Advisor, select the check.

2 Right-click the check name and select Send Check ID to
Workspace. The ID is displayed in the Command Window and
sent to the base workspace.

Check IDs for selected
checks in a folder 1 In the left pane of the Model Advisor, select the checks for which

you want IDs. Clear the other checks in the folder.

2 Right-click the folder and select Send Check ID to Workspace.
An array of the selected check IDs are sent to the base workspace.

If you know a check ID from a previous release, you can find the current check
ID using the ModelAdvisor.lookupCheckID function. For example, the check
ID for By Product > Simulink Verification and Validation > Modeling
Standards > DO-178B Checks > Check safety-related optimization
settings prior to Release 2010b was DO178B:OptionSet. Using the
ModelAdvisor.lookupCheckID function returns:

>> NewID = ModelAdvisor.lookupCheckID('DO178B:OptionSet')

NewID =
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mathworks.do178.OptionSet

Creating a Function for Checking Multiple Systems
The following tutorial guides you through creating and testing a function
to run multiple checks on any model. The function returns the number of
failures and warnings.

1 In the MATLAB window, select File > New > Function.

2 Save the function as run_configuration.m.

3 In the MATLAB Editor, specify [output_args] as [fail, warn].

4 Rename the function run_configuration.

5 Specify input_args to SysList.

6 Inside the function, specify the list of checks to run using the demo Model
Advisor configuration file:

fileName = 'slvnvdemo_mdladv_config.mat';

7 Call the ModelAdvisor.run function:

SysResultObjArray = ModelAdvisor.run(SysList,'Configuration',fileName);

8 Determine the number of checks that return warnings and failures:

fail=0;

warn=0;

for i=1:length(SysResultObjArray)

fail = fail + SysResultObjArray{i}.numFail;

warn = warn + SysResultObjArray{i}.numWarn;

end

The function should now look like this:

function [fail, warn] = run_configuration( SysList)

%RUN_CONFIGURATION Check systems with Model Advsior

% Check systems given as input and return number of warnings and
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% failures.

fileName = 'slvnvdemo_mdladv_config.mat';

fail=0;

warn=0;

SysResultObjArray = ModelAdvisor.run(SysList,'Configuration',fileName);

for i=1:length(SysResultObjArray)

fail = fail + SysResultObjArray{i}.numFail;

warn = warn + SysResultObjArray{i}.numWarn;

end

end

9 Save the function.

10 Test the function. In the MATLAB Command Window, run
run_configuration.m on the sldemo_auto_climatecontrol/Heater
Control subsystem:

[failures, warnings] = run_configuration(...

'sldemo_auto_climatecontrol/Heater Control');

11 Review the results. Click the Summary Report link to open the Model
Advisor Command-Line Summary report.

Checking Multiple Systems in Parallel
Checking multiple systems in parallel reduces the processing time required
by the Model Advisor to check multiple systems. If you have a Parallel
Computing Toolbox license, you can check multiple systems in parallel on a
multicore host machine.

Creating a Function for Checking Multiple Systems in
Parallel
If you have a Parallel Computing Toolbox license and a multicore host
machine, you can create the following function to check multiple systems in
parallel:
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1 Create the run_configuration function as described in “Creating a
Function for Checking Multiple Systems” on page 25-5.

2 Save the function as run_fast_configuration.m.

3 In the Editor, change the name of the function to run_fast_configuration.

4 Add another input to the run_fast_configuration function so that the
inputs are now:

SysList, numParallel

5 In the run_fast_configuration function, before calling the
ModelAdvisor.run function, add a call to the matlabpool function that
evaluates the number of cores to use:

eval(['matlabpool open ' num2str(numParallel)]);

6 At the end of the run_fast_configuration function, add a call to close the
matlabpool function:

matlabpool close;

The function should now look like this:

function [fail, warn] = run_fast_configuration(SysList, numParallel)

%RUN_FAST_CONFIGURATION Check systems in parallel with Model Advisor

% Check systems given as input in parallel on the number of cores

% specified as input. Return number of warnings and failures.

fileName = 'slvnvdemo_mdladv_config.mat';

fail=0;

warn=0;

eval(['matlabpool open ' num2str(numParallel)]);

SysResultObjArray = ModelAdvisor.run(SysList,'Configuration',fileName);

for i=1:length(SysResultObjArray)

fail = fail + SysResultObjArray{i}.numFail;

warn = warn + SysResultObjArray{i}.numWarn;

end

matlabpool close
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end

7 Save the function.

8 Test the function. In the MATLAB Command Window, create a list of
systems:

SysList={'sldemo_auto_climatecontrol/Heater Control',...

'sldemo_auto_climatecontrol/AC Control', 'rtwdemo_iec61508'};

9 Run run_fast_configuration on the list of systems, specifying
numParallel to be the number of cores in your system. For example, the
following command specifies two cores:

% Run on 2 cores

[failures, warnings] = run_fast_configuration(SysList, 2);

10 Review the results. Click the Summary Report link to open the Model
Advisor Command-Line Summary report.

Archiving and Viewing Results
You can archive and view the results of running the Model Advisor
programmatically as described in the following sections:

• “Archiving Results” on page 25-8

• “Viewing Results in the Command Window” on page 25-9

• “Viewing Results in the Model Advisor Command-Line Summary Report”
on page 25-10

• “Viewing Results in the Model Advisor GUI” on page 25-11

• “Viewing the Model Advisor Report” on page 25-12

Archiving Results
After you run the Model Advisor programmatically, you can archive the
results for use at another time. The ModelAdvisor.run function returns a cell
array of ModelAdvisor.SystemResult objects, one for each system run. If you
save the objects, you can use them to view the results at a later time without
rerunning the Model Advisor. For details, see “Saving and Loading Objects”.
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For an example of archiving results, see “Archiving and Viewing Results
Example” on page 25-12.

Viewing Results in the Command Window
When you run the Model Advisor programmatically, the system-level results
of the run are displayed in the Command Window. For example, when you
run the function that you created in “Creating a Function for Checking
Multiple Systems” on page 25-5, the following results are displayed:

Systems passed: 0 of 1

Systems with warnings: 1 of 1

Systems failed: 0 of 1

Summary Report

The Summary Report link provides access to the Model Advisor
Command-Line Summary report (see “Viewing Results in the Model Advisor
Command-Line Summary Report” on page 25-10).

You can review additional results in the Command Window by calling the
DisplayResults parameter when you run the Model Advisor. For example,
run the Model Advisor as follows:

SysResultObjArray = ModelAdvisor.run('sldemo_auto_climatecontrol/Heater Control',...

'Configuration','slvnvdemo_mdladv_config.mat','DisplayResults','Details');

The results displayed in the Command Window are:

Running Model Advisor

Running Model Advisor on sldemo_auto_climatecontrol/Heater Control

============================================================

Model Advisor run: 09-Feb-2011 15:29:50

Configuration: slvnvdemo_mdladv_config.mat

System: sldemo_auto_climatecontrol/Heater Control

System version: 7.7

Created by: The MathWorks Inc.

============================================================

(1) Warning: Check model diagnostic parameters [check ID: mathworks.maab.jc_0021]

------------------------------------------------------------

(2) Warning: Check for fully defined interface [check ID: mathworks.iec61508.RootLevelInports]

------------------------------------------------------------

25-9



25 Checking Systems with the Model Advisor

(3) Pass: Check for unconnected objects [check ID: mathworks.iec61508.UnconnectedObjects]

------------------------------------------------------------

(4) Pass: Check for questionable constructs [check ID: mathworks.iec61508.QuestionableBlks]

------------------------------------------------------------

Summary: Pass Warning Fail Not Run

2 2 0 0

============================================================

Systems passed: 0 of 1

Systems with warnings: 1 of 1

Systems failed: 0 of 1

Summary Report

To display the results in the Command Window after loading an object, use
the viewReport function.

Viewing Results in the Model Advisor Command-Line Summary
Report
When you run the Model Advisor programmatically, a Summary Report link
is displayed in the Command Window. Clicking this link opens the Model
Advisor Command-Line Summary report. The following graphic is the report
that the Model Advisor generates for run_configuration.
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To view the Model Advisor Command-Line Summary report after loading an
object, use the ModelAdvisor.summaryReport function.

Viewing Results in the Model Advisor GUI
In the Model Advisor window, you can view the results of running the
Model Advisor programmatically using the viewReport function. In the
Model Advisor window, you can review results, run checks, fix warnings and
failures, and view and save Model Advisor reports. For more information,
see “Consulting the Model Advisor”.

Tip To fix warnings and failures, you must rerun the check in the Model
Advisor window.
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Viewing the Model Advisor Report
For a single system or check, you can view the same Model Advisor report
that you access from the Model Advisor GUI.

To view the Model Advisor report for a system:

• Open the Model Advisor Command-Line Summary report. In the Systems
Run table, click the link for the Model Advisor report.

• Use the viewReport function.

To view individual check results:

• In the Command Window, generate a detailed report using the viewReport
function with the DisplayResults parameter set to Details, and then
click the Pass, Warning, or Fail link for the check. The Model Advisor
report for the check opens.

• Use the view function.

Archiving and Viewing Results Example
The following tutorial guides you through archiving the results of running
checks so that you can review them at a later time. To simulate archiving
and reviewing, the steps in the tutorial detail how to save the results, clear
out the MATLAB workspace (simulates shutting down MATLAB), and then
load and review the results.

1 Call the ModelAdvisor.run function:

SysResultObjArray = ModelAdvisor.run({'sldemo_auto_climatecontrol/Heater Control'},...

'Configuration','slvnvdemo_mdladv_config.mat');

2 Save the SystResulObj for use at a later time:

save my_model_advisor_run SysResultObjArray

3 Clear the workspace to simulate viewing the results at a different time:

clear

4 Load the results of the Model Advisor run:
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load my_model_advisor_run SysResultObjArray

5 View the results in the Model Advisor:

viewReport(SysResultObjArray{1},'MA')
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• Chapter 26, “Overview of the Model Advisor”

• Chapter 27, “Authoring Custom Checks”

• Chapter 28, “Creating Custom Configurations by Organizing Checks
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Why Use and Customize the Model Advisor?

In this section...

“About the Model Advisor” on page 26-2

“Customizing the Model Advisor” on page 26-2

About the Model Advisor
The Model Advisor is a GUI that provides a way for you to check a Simulink
model or subsystem for consistent modeling guidelines, using MathWorks
checks. Using the checks, you can easily apply these guidelines across projects
and development teams. For more information, see “Consulting the Model
Advisor” in the Simulink documentation.

The Model Advisor includes MathWorks checks, which help you define and
implement consistent design guidelines. Running the checks reviews your
model for conditions and configuration settings that cause inaccurate or
inefficient simulation and code generation of the system that the model
represents. The Model Advisor displays different MathWorks checks
depending on which products you have installed. For more information on
individual checks, see:

• “Simulink Checks”

• “Simulink Coder Checks”

• “Simulink Verification and Validation Checks”

• “Simulink Control Design Checks”

Customizing the Model Advisor
The Simulink Verification and Validation product allows you to extend the
capabilities of the Model Advisor. Using Model Advisor APIs and the Model
Advisor Configuration Editor, you can:

• Customize the behavior of the Model Advisor by defining your own custom
checks, and writing your own callback functions.

• Organize checks and folders to create custom Model Advisor configurations.
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• Create multiple custom configurations that you use for different projects
or modeling guidelines, and switch between these configurations in the
Model Advisor.

• Deploy the custom configurations to your users.

For more information, see “Customizing and Using the Model Advisor
Workflow” on page 26-4.
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Customizing and Using the Model Advisor Workflow
To customize and use the Model Advisor, perform the following high-level
tasks:

1 Review the information in “Before Customizing the Model Advisor” on
page 26-5.

2 Optionally, author custom checks in a customization file. For detailed
information, see Chapter 27, “Authoring Custom Checks”.

3 Organize checks into new and existing folders to create custom
configurations. To organize the Model Advisor, use the Model Advisor
Configuration Editor or create a customization file. For detailed
information, see Chapter 28, “Creating Custom Configurations by
Organizing Checks and Folders”.

4 Optionally, deploy custom configurations. For detailed information, see
Chapter 29, “Deploying Custom Configurations”.

5 Verify that models comply with modeling guidelines using the Model
Advisor. For detailed information, see “Consulting the Model Advisor”.
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Before Customizing the Model Advisor
Before customizing the Model Advisor:

• If you want to create custom checks, know how to create a MATLAB script.
For more information, see “Scripts” in the MATLAB documentation.

• If you want to create custom checks, understand how to access model
constructs that you want to check. For example, know how to find block
and model parameters. For more information on using utilities for creating
check callbacks, see “Common Utilities for Authoring Checks” on page
27-35.

• Identify which MathWorks checks you want to include in your custom
Model Advisor configuration.

When you are ready to create a custom configuration, follow the “Customizing
and Using the Model Advisor Workflow” on page 26-4. Each section provides
you with detailed examples of how to create custom checks and configurations
in the Model Advisor.
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Authoring Checks Workflow
1 On your MATLAB path, create a customization file called
sl_customization.m. In this file, create a sl_customization() function
to register the custom checks that you create and optional process callbacks
with the Model Advisor. For detailed information, see “Register Checks and
Process Callbacks” on page 27-18.

2 Define custom checks and where they appear in the Model Advisor. For
detailed information, see “Defining Custom Checks” on page 27-23.

3 Specify what actions you want the Model Advisor to take for the custom
checks by creating a check callback function for each custom check. For
detailed information, see “Creating Callback Functions and Results” on
page 27-34.

4 Optionally, specify what automatic fix operations the Model Advisor
performs by creating an action callback function. For detailed information,
see “Action Callback Function” on page 27-49.

5 Optionally, specify startup and post-execution actions by creating a process
callback function. For detailed information, see “Defining Startup and
Post-Execution Actions Using Process Callback Functions” on page 27-20.

27-2



Customization File Overview

Customization File Overview
A customization file is a MATLAB file that you create and name
sl_customization.m. The sl_customization.m file contains a set of
functions for registering and defining custom checks, tasks, and groups. To
set up the sl_customization.m file, follow the guidelines in this table.

Function Description When Required

sl_customization() Registers custom checks,
tasks, folders, and
callbacks with the Simulink
customization manager at
startup (see “Register Checks
and Process Callbacks” on
page 27-18).

Required for all customizations
to the Model Advisor.

One or more check definitions Defines all custom checks (see
“Defining Custom Checks” on
page 27-23).

Required for custom checks
and to add custom checks to
the By Product folder.

Check callback functions Defines the actions of the
custom checks (see “Creating
Callback Functions and
Results” on page 27-34).

Required for custom checks.
You must write one callback
function for each custom
check.

One or more calls to check
input parameters

Specifies input parameters to
custom checks (see “Defining
Check Input Parameters” on
page 27-28).

Optional.

One or more calls to check list
views

Specifies calls to the Model
Advisor Result Explorer for
custom checks (see “Defining
Model Advisor Result Explorer
Views” on page 27-30).

Optional.
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Function Description When Required

One or more calls to check
actions

Specifies actions the software
performs for custom checks
(see “Defining Check Actions”
on page 27-31 and “Action
Callback Function” on page
27-49).

Optional.

One process callback function Specifies actions to be
performed at startup and
post-execution time (see
“Defining Startup and
Post-Execution Actions Using
Process Callback Functions”
on page 27-20).

Optional.

The following is an example of a custom configuration of the Model Advisor
that has custom checks defined in custom folders. The selected check includes
input parameters, list view parameters, and actions.
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Quick Start Examples

In this section...

“Adding a Customized Check to the By Product Folder” on page 27-6

“Creating a Customized Pass/Fail Check” on page 27-8

“Creating a Customized Pass/Fail Check with Fix Action” on page 27-12

Adding a Customized Check to the By Product Folder
The following example shows how to add a customized check to a Model
Advisor By Product > Demo subfolder. In this example, the customized
check does not check model elements.

1 In your working directory, create the sl_customization.m file, as shown
below. This file registers and creates the check registration function
defineModelAdvisorChecks, which in turn registers the check callback
function SimpleCallback. The function defineModelAdvisorChecks uses
a ModelAdvisor.Root object to define the check interface.

function sl_customization(cm)

% --- register custom checks

cm.addModelAdvisorCheckFcn(@defineModelAdvisorChecks);

% --- defineModelAdvisorChecks function

function defineModelAdvisorChecks

mdladvRoot = ModelAdvisor.Root;

rec = ModelAdvisor.Check('exampleCheck');

rec.Title = 'Example of a customized check';

rec.TitleTips = 'Added customized check to Product Folder';

rec.setCallbackFcn(@SimpleCallback,'None','StyleOne');

mdladvRoot.publish(rec, 'Demo');

% --- creates SimpleCallback function

function result = SimpleCallback(system);

result={};

2 Close the Model Advisor and your model if either are open.
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3 In the MATLAB Command Window, enter:

sl_refresh_customizations

4 From the MATLAB window, select File > New > Model to open a new
Simulink model window.

5 From the model window, select Tools > Model Advisor to open the Model
Advisor.

6 A System Selector — Model Advisor dialog box opens. Click OK. The
Model Advisor window opens. It might take a few minutes.

7 In the left pane, expand the By Product.folder to display the subfolders.

The customized check Example of a customized check appears in the
By Product > Demo subfolder.
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See Also

• “Registering Checks and Process Callbacks” on page 27-18

Creating a Customized Pass/Fail Check
The following example shows how to create a Model Advisor pass/fail check.
In this example, the Model Advisor checks Constant blocks. If a Constant
blocks value is numeric, the check fails.

1 In your working directory, update the sl_customization.m file, as shown
below. This file registers and creates the check registration function
defineModelAdvisorChecks, which also registers the check callback
function SimpleCallback. The function SimpleCallback creates a check
that finds Constant blocks that have numeric values. SimpleCallback uses
the Model Advisor format template.

function sl_customization(cm)

% --- register custom checks

cm.addModelAdvisorCheckFcn(@defineModelAdvisorChecks);

% --- defineModelAdvisorChecks function

function defineModelAdvisorChecks

mdladvRoot = ModelAdvisor.Root;

rec = ModelAdvisor.Check('exampleCheck');

rec.Title = 'Check for proper Constant block usage';

rec.TitleTips = ['Fail if Constant block value is a number; Pass if' ...

' Constant block value is a letter'];

rec.setCallbackFcn(@SimpleCallback,'None','StyleOne')

mdladvRoot.publish(rec, 'Demo');

% --- SimpleCallback function that checks constant blocks

function result = SimpleCallback(system)

mdladvObj = Simulink.ModelAdvisor.getModelAdvisor(system);

result = {};

all_constant_blk=find_system(system,'LookUnderMasks','all',...

'FollowLinks','on','BlockType','Constant');

blk_with_value=find_system(all_constant_blk,'RegExp','On','Value','^[0-9]');
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ft = ModelAdvisor.FormatTemplate('ListTemplate');

ft.setInformation(['This check looks for constant blocks that'...

'use numeric values']);

if ~isempty(blk_with_value)

ft.setSubResultStatusText(['Check has failed. The following '...

'Constant blocks have numeric values:']);

ft.setListObj(blk_with_value);

ft.setSubResultStatus('warn');

ft.setRecAction('Parameterize the constant block');

mdladvObj.setCheckResultStatus(false);

else

ft.setSubResultStatusText(['Check has passed. No constant blocks'...

' with numeric values were found.']);

ft.setSubResultStatus('pass');

mdladvObj.setCheckResultStatus(true);

end

ft.setSubBar(0);

result{end+1} = ft;

2 Close the Model Advisor and your model if either are open.

3 It the MATLAB Command Window, enter:

sl_refresh_customizations

4 From the MATLAB window, select File > New > Model to open a new
Simulink model window.

5 In the Simulink model window, create two Constant blocks named
Const_One and Const_1:

• Right-click the Const_One block, choose Constant Parameters, and
assign a Constant value of one.

• Right-click the Const_1 block, choose Constant Parameters, and
assign a Constant value of 1.

• Save your model as example2_qs.mdl.
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6 From the model window, select Tools > Model Advisor to open the Model
Advisor.

7 A System Selector — Model Advisor dialog box opens. Click OK. The
Model Advisor window opens. It might take a few minutes.

8 In the left pane, click By Product > Demo > Check for proper Constant
block usage.

9 Click Run This Check. The Model Advisor check fails for the Const_1
block and displays a Recommended Action to parametrize the constant
block.

27-10



Quick Start Examples

10 Follow the Recommended Action to fix the failed Constant block. In the
Model Advisor dialog box:

• Double-click the example2_qs/Const_1 hyperlink.

• Change Constant Parameters > Constant value to two, or a
non-numeric value.

• Rerun the Model Advisor check. Both Constant blocks now pass the
check.

See Also

• “Registering Checks and Process Callbacks” on page 27-18
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• ModelAdvisor.FormatTemplate

Creating a Customized Pass/Fail Check with Fix
Action
The following example shows how to create a Model Advisor pass/fail check
with a fix action. In this example, the Model Advisor checks Constant blocks.
If a Constant block value is numeric, the check fails. The Model Advisor is
also customized to create a fix action for the failed checks.

1 In your working directory, update the sl_customization.m file, as shown
below. This file contains three functions, each of which use the Model
Advisor format template:

• defineModelAdvisorChecks — Defines the check, creates input
parameters, and defines the fix action.

• simpleCallback— Creates the check that finds Constant blocks with
numeric values.

• simpleActionCallback— Creates the fix for Constant blocks that fail
the check.

function sl_customization(cm)

% --- register custom checks

cm.addModelAdvisorCheckFcn(@defineModelAdvisorChecks);

% --- defineModelAdvisorChecks function

function defineModelAdvisorChecks

mdladvRoot = ModelAdvisor.Root;

rec = ModelAdvisor.Check('exampleCheck');

rec.Title = 'Check for proper Constant block usage';

rec.TitleTips = ['Fail if Constant block value is a number; Pass if '...

'Constant block value is a letter'];

rec.setCallbackFcn(@SimpleCallback,'None','StyleOne')

% --- input parameters

rec.setInputParametersLayoutGrid([1 1]);

inputParam1 = ModelAdvisor.InputParameter;

inputParam1.Name = 'Text entry example';

inputParam1.Value='VarNm';
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inputParam1.Type='String';

inputParam1.Description='sample tooltip';

inputParam1.setRowSpan([1 1]);

inputParam1.setColSpan([1 1]);

rec.setInputParameters({inputParam1});

% -- set fix operation

myAction = ModelAdvisor.Action;

myAction.setCallbackFcn(@simpleActionCallback);

myAction.Name='Fix Constant blocks';

myAction.Description=['Click the button to update all blocks with'...

'Text entry example'];

rec.setAction(myAction);

mdladvRoot.publish(rec, 'Demo');

% --- SimpleCallback function that checks constant blocks

function result = SimpleCallback(system)

mdladvObj = Simulink.ModelAdvisor.getModelAdvisor(system);

result = {};

all_constant_blk=find_system(system,'LookUnderMasks','all',...

'FollowLinks','on','BlockType','Constant');

blk_with_value=find_system(all_constant_blk,'RegExp','On','Value','^[0-9]');

ft = ModelAdvisor.FormatTemplate('ListTemplate');

ft.setInformation(['This check looks for constant blocks that'...

' use numeric values']);

if ~isempty(blk_with_value)

ft.setSubResultStatusText(['Check has failed. The following '...

'Constant blocks have numeric values:']);

ft.setListObj(blk_with_value);

ft.setSubResultStatus('warn');

ft.setRecAction('Parameterize the constant block');

mdladvObj.setCheckResultStatus(false);

mdladvObj.setActionEnable(true);

else

ft.setSubResultStatusText(['Check has passed. No constant blocks'...

'with numeric values were found.']);

ft.setSubResultStatus('pass');
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mdladvObj.setCheckResultStatus(true);

end

ft.setSubBar(0);

result{end+1} = ft;

% --- creates SimpleActionCallback function that fixes failed check

function result = simpleActionCallback(taskobj)

mdladvObj = taskobj.MAObj;

result = {};

system = getfullname(mdladvObj.System);

% Get the string from the input parameter box.

inputParams = mdladvObj.getInputParameters;

textEntryEx = inputParams{1}.Value;

all_constant_blk=find_system(system,'LookUnderMasks','all',...

'FollowLinks','on','BlockType','Constant');

blk_with_value=find_system(all_constant_blk,'RegExp','On','Value','^[0-9]');

ft = ModelAdvisor.FormatTemplate('TableTemplate');

% Define table col titles

ft.setColTitles({'Block','Old Value','New Value'})

for inx=1:size(blk_with_value)

oldVal = get_param(blk_with_value{inx},'Value');

ft.addRow({blk_with_value{inx},oldVal,textEntryEx});

set_param(blk_with_value{inx},'Value',textEntryEx);

end

ft.setSubBar(0);

result = ft;

mdladvObj.setActionEnable(false);

2 Close the Model Advisor and your model if either are open.

3 At the MATLAB command line, enter:

sl_refresh_customizations

4 From the MATLAB Command Window, select File > New > Model to
open a new model.
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5 In the Simulink model window, create two Constant blocks named
Const_One and Const_1:

• Right-click the Const_One block, choose Constant Parameters, and
assign a Constant value of one.

• Right-click the Const_1 block, choose Constant Parameters, and
assign a Constant value of 1.

• Save your model as example3_qs.mdl.

6 From the model window, select Tools > Model Advisor to open the Model
Advisor.

7 A System Selector — Model Advisor dialog box opens. Click OK. The
Model Advisor window opens. It might take a few minutes.

8 In the left pane, click By Product > Demo > Check for proper Constant
block usage.

9 Click Run This Check. The Model Advisor check fails for the Const_1
block. The Model Advisor box has a Fix Constant blocks button in the
Action section of the Model Advisor dialog box.
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10 In the Model Advisor Dialog box, enter a non-numeric value in the Text
entry example parameter field in the Analysis section of the Model
Advisor dialog box. In this example, the value is VarNm.

11 Click Fix Constant blocks. The Const_1 Constant block value changes
from 1 to the non-numeric value that you entered in step 10. The Result
section of the dialog box lists the Old Value and New Value of the Const_1
block.
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12 In the Model Advisor dialog box, click Run This Check. Both constant
blocks now pass the check.

See Also

• “Registering Checks and Process Callbacks” on page 27-18

• ModelAdvisor.FormatTemplate

• “Defining Check Input Parameters” on page 27-28 to add input parameters
to Model Advisor checks

• ModelAdvisor.Action to add fix actions to Model Advisor checks
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Register Checks and Process Callbacks

In this section...

“Create sl_customization Function” on page 27-18

“Registering Checks and Process Callbacks” on page 27-18

“Defining Startup and Post-Execution Actions Using Process Callback
Functions” on page 27-20

Create sl_customization Function
To add checks to the Model Advisor, on your MATLAB path, in the
sl_customization.m file, create the sl_customization() function.

Tip

• You can have more than one sl_customization.m file on your MATLAB
path.

• Do not place an sl_customization.m file that customizes checks and
folders in the Model Advisor in your root MATLAB folder or any of its
subfolders, except for the matlabroot/work folder. Otherwise, the Model
Advisor ignores the customizations that the file specifies.

The sl_customization function accepts one argument, a customization
manager object, as in this example:

function sl_customization(cm)

The customization manager object includes methods for registering custom
checks and process callbacks. Use these methods to register customizations
specific to your application, as described in the following sections.

Registering Checks and Process Callbacks
To register custom checks and process callbacks, the customization manager
includes the following methods:
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• addModelAdvisorCheckFcn (@checkDefinitionFcn)

Registers the checks that you define in checkDefinitionFcn to the By
Product folder of the Model Advisor.

The checkDefinitionFcn argument is a handle to the function that defines
all custom checks that you want to add to the Model Advisor as instances
of the ModelAdvisor.Check class (see “Defining Custom Checks” on page
27-23).

• addModelAdvisorProcessFcn (@modelAdvisorProcessFcn)

Registers the process callback function for the Model Advisor checks (see
“Defining Startup and Post-Execution Actions Using Process Callback
Functions” on page 27-20).

Caution The Model Advisor registers only one process callback function.
If you have more than one sl_customization.m file on your MATLAB
path, the Model Advisor registers the process callback function from the
sl_customization.m file that has the highest priority.

Note The @ sign defines a function handle that MATLAB calls. For more
information, see “At — @” in the MATLAB documentation.

Model Advisor Code Example: Registering Custom Checks and
Process Callbacks
The following code example registers custom checks and a process callback
function:

function sl_customization(cm)

% register custom checks

cm.addModelAdvisorCheckFcn(@defineModelAdvisorChecks);

% register custom process callback

cm.addModelAdvisorProcessFcn(@ModelAdvisorProcessFunction);
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Note If you add custom tasks and folders within the sl_customization.m
file, include methods for registering the tasks and folders in the
sl_customization function. For more information, see “Registering Tasks
and Folders” on page 28-15.

Defining Startup and Post-Execution Actions Using
Process Callback Functions
The process callback function is an optional function that you use to configure
the Model Advisor and process check results at run time. The process callback
function specifies actions that the software performs at different stages of
Model Advisor execution:

• configure stage: The Model Advisor executes configure actions at
startup, after all checks and tasks have been initialized. At this stage, you
can customize how the Model Advisor constructs lists of checks and tasks
by modifying Visible, Enable, and Value properties. For example, you can
remove, rename, and selectively display checks and tasks.

• process_results stage: The Model Advisor executes process_results
actions after checks complete execution. You can specify actions to examine
and report on the results returned by check callback functions.

If you create a process callback function, you must register it, as described in
“Register Checks and Process Callbacks” on page 27-18. The following sections
provide mode information about defining your own process callback functions.

Process Callback Function Arguments
The process callback function takes the following arguments.
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Argument I/O Type Data Type Description

stage Input Enumeration Specifies the stages at
which process callback
actions are executed.
Use this argument in
a switch statement to
specify actions for the
stages configure and
process_results.

system Input Path Model or subsystem
that the Model Advisor
analyzes.

checkCellArray Input/Output Cell array As input, the array of
checks constructed in the
check definition function.
As output, the array of
checks modified by actions
in the configure stage.

taskCellArray Input/Output Cell array As input, the array of
tasks constructed in the
task definition function.
As output, the array of
tasks modified by actions
in the configure stage.

Model Advisor Code Example: Process Callback Function
The following code is an example of a process callback function that specifies
actions in the configure stage, to make only custom checks visible. In the
process_results stage, this function displays information at the MATLAB
command line for checks that do not pass.

% Process Callback Function

% Defines actions to execute at startup and post-execution

function [checkCellArray taskCellArray] = ...

ModelAdvisorProcessFunction(stage, system, checkCellArray, taskCellArray)

switch stage

% Specify the appearance of the Model Advisor window at startup
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case 'configure'

for i=1:length(checkCellArray)

% Hide all checks that do not belong to custom folder

if isempty(strfind(checkCellArray{i}.ID, 'mathworks.example'))

checkCellArray{i}.Visible = false;

checkCellArray{i}.Value = false;

end

end

% Specify actions to perform after the Model Advisor completes execution

case 'process_results'

for i=1:length(checkCellArray)

% Print message if check does not pass

if checkCellArray{i}.Selected && (strcmp(checkCellArray{i}.Title, ...

'Check Simulink window screen color'))

mdladvObj = Simulink.ModelAdvisor.getModelAdvisor(system);

% Verify whether the check was run and if it failed

if mdladvObj.verifyCheckRan(checkCellArray{i}.ID)

if ~mdladvObj.getCheckResultStatus(checkCellArray{i}.ID)

% Display text in MATLAB Command Window

disp(['Example message from Model Advisor Process'...

' callback.']);

end

end

end

end

end
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Defining Custom Checks

In this section...

“About Custom Checks” on page 27-23

“Contents of Check Definitions” on page 27-23

“Displaying and Enabling Checks” on page 27-25

“Defining Where Custom Checks Appear” on page 27-26

“Model Advisor Code Example: Check Definition Function” on page 27-27

“Defining Check Input Parameters” on page 27-28

“Defining Model Advisor Result Explorer Views” on page 27-30

“Defining Check Actions” on page 27-31

About Custom Checks
You can create a custom check to use in the Model Advisor. Creating
custom checks provides you with the ability to specify which conditions and
configuration settings the Model Advisor reviews.

You define custom checks in one or more functions that specify the properties
of each instance of the ModelAdvisor.Check class. Define one instance of
this class for each custom check that you want to add to the Model Advisor,
and register the custom check as described in “Register Checks and Process
Callbacks” on page 27-18.

Tip You can add a check to multiple folders by creating a task. For more
information, see “Adding a Check to Custom or Multiple Folders Using Tasks”
on page 28-17.

The following sections describe how to define custom checks.

Contents of Check Definitions
When you define a Model Advisor check, it contains the information listed
in the following table.
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Contents Description

Check ID (required) Uniquely identifies the check. The
Model Advisor uses this id to access
the check.

Handle to check callback function
(required)

Function that specifies the contents
of a check.

Check name (recommended) Creates a name for the check that
the Model Advisor displays.

Check properties (optional) Creates a user interface with the
check. When adding checks as
tasks, the Model Advisor uses the
task properties instead of the check
properties, except for Visible and
LicenseName. For more information,
see ModelAdvisor.Check and
ModelAdvisor.Task.

Tip When you add checks to the
Model Advisor as tasks, specify
only the required properties
of a check, because the task
definition includes the additional
properties. For example, you
define the description of the check
in the task definition using the
ModelAdvisor.Task.Description
property instead of the
ModelAdvisor.Check.TitleTips
property.

Input Parameters (optional) Adds input parameters that request
input from the user. The Model
Advisor uses the input to perform
the check.
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Contents Description

Action (optional) Adds automatic fixing action.

Explore Result button (optional) Adds the Explore Result button
that the user clicks to open the
Model Advisor Result Explorer.

Displaying and Enabling Checks
You can create a check and specify how it appears in the Model Advisor.
You can define when to display a check, or whether a user can select or
clear a check using the Visible, Enable, and Value properties of the
ModelAdvisor.Check class.

Note When adding checks to the Model Advisor as tasks, specify these
properties in the ModelAdvisor.Task class. If you specify the properties in
both ModelAdvisor.Check and ModelAdvisor.Task, the ModelAdvisor.Task
properties take precedence, except for the Visible and LicenseName
properties. For more information, see ModelAdvisor.Task.

Modify the behavior of the Visible, Enable, and Value properties in a process
callback function (see “Defining Startup and Post-Execution Actions Using
Process Callback Functions” on page 27-20). The following chart illustrates
how these properties interact.
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Defining Where Custom Checks Appear
Specify where the Model Advisor places custom checks using the following
guidelines:

• To place a check in a new folder in the Model Advisor root, use the
ModelAdvisor.Group class. See “Defining Custom Tasks” on page 28-16.

• To place a check in a new folder in the By Task folder, use the
ModelAdvisor.FactoryGroup class. See “Defining Custom Tasks” on
page 28-16.
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• To place a check in the By Product folder, use the
ModelAdvisor.Root.publish method.

Model Advisor Code Example: Check Definition
Function
The following is an example of a function that defines the custom checks
associated with the callback functions described in “Creating Callback
Functions and Results” on page 27-34. The check definition function returns a
cell array of custom checks to be added to the Model Advisor.

The check definitions in the example use the tasks described in “Defining
Custom Tasks” on page 28-16.

% Defines custom Model Advisor checks

function defineModelAdvisorChecks

% Sample check 1: Informational check

rec = ModelAdvisor.Check('mathworks.example.configManagement');

rec.Title = 'Informational check for model configuration management';

setCallbackFcn(rec, @modelVersionChecksumCallbackUsingFT,'None','StyleOne');

rec.CallbackContext = 'PostCompile';

mdladvRoot = ModelAdvisor.Root;

mdladvRoot.register(rec);

% Sample check 2: Basic Check with Pass/Fail Status

rec = ModelAdvisor.Check('mathworks.example.unconnectedObjects');

rec.Title = 'Check for unconnected objects';

setCallbackFcn(rec, @unconnectedObjectsCallbackUsingFT,'None','StyleOne');

mdladvRoot = ModelAdvisor.Root;

mdladvRoot.register(rec);

% Sample Check 3: Check with Subchecks and Actions

rec = ModelAdvisor.Check('mathworks.example.optimizationSettings');

rec.Title = 'Check safety-related optimization settings';

setCallbackFcn(rec, @OptmizationSettingCallback,'None','StyleOne');

% Define an automatic fix action for this check

modifyAction = ModelAdvisor.Action;

setCallbackFcn(modifyAction, @modifyOptmizationSetting);

modifyAction.Name = 'Modify Settings';
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modifyAction.Description = ['Modify model configuration optimization' ...

' settings that can impact safety.'];

modifyAction.Enable = true;

setAction(rec, modifyAction);

mdladvRoot = ModelAdvisor.Root;

mdladvRoot.register(rec);

Defining Check Input Parameters
With input parameters, the check author can request input from the
user for a Model Advisor check. Define input parameters using the
ModelAdvisor.InputParameter class inside a custom check function (see
“Defining Custom Checks” on page 27-23). You must define one instance of
this class for each input parameter that you want to add to a Model Advisor
check.

Note You do not have to create input parameters for every custom check.

Specifying Input Parameter Layout
Specify the layout of input parameters in an input parameter definition. To
place input parameters, use the following methods.

Method Description

ModelAdvisor.Check
setInputParametersLayoutGrid

Specifies the size of the input
parameter grid.

ModelAdvisor.InputParameter
setRowSpan

Specifies the number of rows the
parameter occupies in the Input
Parameter layout grid.

ModelAdvisor.InputParameter
setColSpan

Specifies the number of columns
the parameter occupies in the Input
Parameter layout grid.

For information on using these methods, see the ModelAdvisor.Check and
ModelAdvisor.InputParameter class documentation.
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Model Advisor Code Example: Input Parameter Definition
The following is an example of defining input parameters that you add to
a custom check. You must include input parameter definitions inside a
custom check definition (see “Model Advisor Code Example: Check Definition
Function” on page 27-27). The following code, when included in a custom
check definition, creates three input parameters.

rec = ModelAdvisor.Check('com.mathworks.sample.Check1');
rec.setInputParametersLayoutGrid([3 2]);
% define input parameters
inputParam1 = ModelAdvisor.InputParameter;
inputParam1.Name = 'Skip font checks.';
inputParam1.Type = 'Bool';
inputParam1.Value = false;
inputParam1.Description = 'sample tooltip';
inputParam1.setRowSpan([1 1]);
inputParam1.setColSpan([1 1]);
inputParam2 = ModelAdvisor.InputParameter;
inputParam2.Name = 'Standard font size';
inputParam2.Value='12';
inputParam2.Type='String';
inputParam2.Description='sample tooltip';
inputParam2.setRowSpan([2 2]);
inputParam2.setColSpan([1 1]);
inputParam3 = ModelAdvisor.InputParameter;
inputParam3.Name='Valid font';
inputParam3.Type='Combobox';
inputParam3.Description='sample tooltip';
inputParam3.Entries={'Arial', 'Arial Black'};
inputParam3.setRowSpan([2 2]);
inputParam3.setColSpan([2 2]);
rec.setInputParameters({inputParam1,inputParam2,inputParam3});

The Model Advisor displays these input parameters in the right pane, in
an Input Parameters box.
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Defining Model Advisor Result Explorer Views
A list view provides a way for users to fix check warnings and failures using
the Model Advisor Result Explorer. Creating a list view allows you to :

• Add the Explore Result button to the custom check in the Model Advisor
window.

• Provide the information to populate the Model Advisor Result Explorer.

For information on using the Model Advisor Results Explorer, see
“Batch-Fixing Warnings or Failures” in the Simulink documentation.

Define list views using the ModelAdvisor.ListViewParameter class inside a
custom check function (see “Defining Custom Checks” on page 27-23). You
must define one instance of this class for each list view that you want to add
to a Model Advisor Result Explorer window.

Note You do not have to create list views for every custom check.
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Model Advisor Code Example: List View Definition
The following is an example of defining list views. You must make theExplore
Result button visible using the ModelAdvisor.Check.ListViewVisible
property inside a custom check function, and include list view definitions
inside a check callback function (see “Detailed Check Callback Function”
on page 27-43).

The following code, when included in a check definition function, adds the
Explore Result button to the check in the Model Advisor.

rec = ModelAdvisor.Check('com.mathworks.sample.Check1');

% add 'Explore Result' button

rec.ListViewVisible = true;

The following code, when included in a check callback function, provides the
information to populate the Model Advisor Result Explorer.

mdladvObj = Simulink.ModelAdvisor.getModelAdvisor(system);

mdladvObj.setCheckResultStatus(true);

% define list view parameters

myLVParam = ModelAdvisor.ListViewParameter;

myLVParam.Name = 'Invalid font blocks'; % the name appeared at pull down filter

myLVParam.Data = get_param(searchResult,'object')';

myLVParam.Attributes = {'FontName'}; % name is default property

mdladvObj.setListViewParameters({myLVParam});

Defining Check Actions
An action provides a way for you to specify an action that the Model Advisor
performs to fix a Model Advisor check. When you define an action, the Model
Advisor window includes an Action box below the Analysis box.

You define actions using the ModelAdvisor.Action class inside a custom
check function (see “Defining Custom Checks” on page 27-23). You must
define:

• One instance of this class for each action that you want to take.

• One action callback function for each action (see “Action Callback Function”
on page 27-49).
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Note

• Each check can contain only one action.

• You do not have to create actions for every custom check.

Model Advisor Code Example: Action Definition
The following is an example of defining actions within a custom check. You
must include action definitions inside a check definition function (see “Model
Advisor Code Example: Check Definition Function” on page 27-27).

The following code, when included in a check definition function, provides the
information to populate the Action box in the Model Advisor.

rec = ModelAdvisor.Check('mathworks.example.optimizationSettings');

% Define an automatic fix action for this check

modifyAction = ModelAdvisor.Action;

modifyAction.setCallbackFcn(@modifyOptmizationSetting);

modifyAction.Name = 'Modify Settings';

modifyAction.Description = ['Modify model configuration optimization' ...

' settings that can impact safety'];

modifyAction.Enable = true;

rec.setAction(modifyAction);

The Model Advisor, in the right pane, displays an Action box.
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Creating Callback Functions and Results

In this section...

“About Callback Functions” on page 27-34

“Common Utilities for Authoring Checks” on page 27-35

“Simple Check Callback Function” on page 27-35

“Detailed Check Callback Function” on page 27-43

“Check Callback Function with Hyperlinked Results” on page 27-45

“Action Callback Function” on page 27-49

“Formatting Model Advisor Results” on page 27-50

About Callback Functions
A callback function specifies the actions that the Model Advisor performs on
a model or subsystem, based on the check or action that the user runs. You
must create a callback function for each custom check and action so that the
Model Advisor can execute the function when a user runs the check. There
are several types of callback functions:

• “Simple Check Callback Function” on page 27-35

• “Detailed Check Callback Function” on page 27-43

• “Check Callback Function with Hyperlinked Results” on page 27-45

• “Action Callback Function” on page 27-49

All types of callback functions provide one or more return arguments for
displaying the results after executing the check or action. In some cases,
return arguments are strings or cell arrays of strings that support embedded
HTML tags for text formatting. MathWorks recommends that you use the
Model Advisor Result Template API to format check results, as described in
“Formatting Model Advisor Results” on page 27-50. Limit HTML tags to be
compatible with alternate output formats.
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Common Utilities for Authoring Checks
When you create a check, there are common Simulink utilities that you
can use to make the check perform different actions. Following is a list of
utilities and when to use them. In the Utility column, click the link for more
information about the utility.

Utility Used for...

find_system Getting handle or path to:

• Blocks

• Lines

• Annotations

When getting the object, you can:

• Specify a search depth

• Search under masks and libraries

get_param / set_param Getting and setting system and
block parameter values.

inspect Getting object properties. First you
must get a handle to the object.

evalin Working in the base workspace.

Stateflow API Programmatic access to Stateflow
objects.

Simple Check Callback Function
Use a simple check callback function with results formatted using the Result
Template API to indicate whether the model passed or failed the check, or
to recommend correcting an issue. The keyword for this callback function is
StyleOne. The check definition requires this keyword (see “Defining Custom
Checks” on page 27-23).

The check callback function takes the following arguments.
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Argument I/O Type Description

system Input Path to the model or subsystem analyzed by the
Model Advisor.

result Output MATLAB string that supports Model Advisor
Formatting API calls or embedded HTML tags
for text formatting.

Model Advisor Code Example: Informational Check Callback
Function
The following code is an example of a callback function for a custom
informational check that finds and displays the model configuration and
checksum information. The informational check uses the Result Template
API to format the check result.

An informational check includes the following items in the results:

• A description of what the check is reviewing.

• References to standards, if applicable.

An informational check does not include the following items in the results:

• The check status. The Model Advisor displays the overall check status,
but the status is not in the result.

• A description of the status.

• The recommended action to take when the check does not pass.

• Subcheck results.

• A line below the results.

% Sample Check 1 Callback Function: Informational Check

% Find and display model configuration and checksum information

% Informational checks do not have a passed or warning status in the results

function resultDescription = modelVersionChecksumCallbackUsingFT(system)

resultDescription = [];

system = getfullname(system);
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model = bdroot(system);

% Format results in a list using Model Advisor Result Template API

ft = ModelAdvisor.FormatTemplate('ListTemplate');

% Add See Also section for references to standards

docLinkSfunction{1} = {['IEC 61508-3, Table A.8 (5)' ...

' ''Software configuration management'' ']};

setRefLink(ft,docLinkSfunction);

% Description of check in results

desc = 'Display model configuration and checksum information.';

% If running the Model Advisor on a subsystem, add note to description

if strcmp(system, model) == false

desc = strcat(desc, ['<br/>NOTE: The Model Advisor is reviewing a' ...

' sub-system, but these results are based on root-level settings.']);

end

setCheckText(ft, desc);

mdladvObj = Simulink.ModelAdvisor.getModelAdvisor(system);

% If err, use these values

mdlver = 'Error - could not retrieve Version';

mdlauthor = 'Error - could not retrieve Author';

mdldate = 'Error - could not retrieve Date';

mdlsum = 'Error - could not retrieve CheckSum';

% Get model configuration and checksum information

try

mdlver = get_param(model,'ModelVersion');

mdlauthor = get_param(model,'LastModifiedBy');

mdldate = get_param(model,'LastModifiedDate');

mdlsum = Simulink.BlockDiagram.getChecksum(model);

mdlsum = [num2str(mdlsum(1)) ' ' num2str(mdlsum(2)) ' ' ...

num2str(mdlsum(3)) ' ' num2str(mdlsum(4))];

mdladvObj.setCheckResultStatus(true); % init to true

catch err

mdladvObj.setCheckResultStatus(false);

setSubResultStatusText(ft,err.message);

resultDescription{end+1} = ft;

return

end
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% Display the results

lbStr ='<br/>';

resultStr = ['Model Version: ' mdlver lbStr 'Author: ' mdlauthor lbStr ...

'Date: ' mdldate lbStr 'Model Checksum: ' mdlsum];

setSubResultStatusText(ft,resultStr);

% Informational checks do not have subresults, supress line

setSubBar(ft,false);

resultDescription{end+1} = ft;

Model Advisor Code Example: Basic Check with Pass/Fail
Status
Here is an example of a callback function for a custom basic check that finds
and reports unconnected lines, input ports, and output ports.

A basic check includes the following items in the results:

• A description of what the check is reviewing.

• References to standards, if applicable.

• The status of the check.

• A description of the status.

• Results for the check.

• The recommended actions to take when the check does not pass.

A basic check does not include the following items in the results:

• Subcheck results.

• A line below the results.

% Sample Check 2 Callback Function: Basic Check with Pass/Fail Status

% Find and report unconnected lines, input ports, and output ports

function ResultDescription = unconnectedObjectsCallbackUsingFT(system)

mdladvObj = Simulink.ModelAdvisor.getModelAdvisor(system);

% Initialize variables

mdladvObj.setCheckResultStatus(false);
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ResultDescription ={};

ResultStatus = false; % Default check status is 'Warning'

system = getfullname(system);

isSubsystem = ~strcmp(bdroot(system), system);

% Format results in a list using Model Advisor Result Template API

% Create a list template object

ft = ModelAdvisor.FormatTemplate('ListTemplate');

% Description of check in results

if isSubsystem

checkDescStr = ['Identify unconnected lines, input ports, and ' ...

'output ports in the subsystem.'];

else

checkDescStr = ['Identify unconnected lines, input ports, and ' ...

'output ports in the model.'];

end

setCheckText(ft,checkDescStr);

% Add See Also section with references to applicable standards

checkStdRef = 'IEC 61508-3, Table A.3 (3) ''Language subset'' ';

docLinkSfunction{1} = {checkStdRef};

setRefLink(ft,docLinkSfunction);

% Basic checks do not have subresults, supress line

setSubBar(ft,false);

% Check for unconnected lines, inputs, and outputs

sysHandle = get_param(system, 'Handle');

uLines = find_system(sysHandle, ...

'Findall', 'on', ...

'LookUnderMasks', 'on', ...

'Type', 'line', ...

'Connected', 'off');

uPorts = find_system(sysHandle, ...

'Findall', 'on', ...

'LookUnderMasks', 'on', ...

'Type', 'port', ...

'Line', -1);
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% Use parents of port objects for the correct highlight behavior

if ~isempty(uPorts)

for i=1:length(uPorts)

uPorts(i) = get_param(get_param(uPorts(i), 'Parent'), 'Handle');

end

end

% Create cell array of unconnected object handles

modelObj = {};

searchResult = union(uLines, uPorts);

for i = 1:length(searchResult)

modelObj{i} = searchResult(i);

end

% No unconnected objects in model

% Set result status to 'Pass' and display text describing the status

if isempty(modelObj)

setSubResultStatus(ft,'Pass');

if isSubsystem

setSubResultStatusText(ft,['There are no unconnected lines, ' ...

'input ports, and output ports in this subsystem.']);

else

setSubResultStatusText(ft,['There are no unconnected lines, ' ...

'input ports, and output ports in this model.']);

end

ResultStatus = true;

% Unconnected objects in model

% Set result status to 'Warning' and display text describing the status

else

setSubResultStatus(ft,'Warn');

if ~isSubsystem

setSubResultStatusText(ft,['The following lines, input ports, ' ...

'or output ports are not properly connected in the system: ' system]);

else

setSubResultStatusText(ft,['The following lines, input ports, or ' ...

'output ports are not properly connected in the subsystem: ' system]);

end

% Specify recommended action to fix the warning

setRecAction(ft,'Connect the specified blocks.');

% Create a list of handles to problem objects
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setListObj(ft,modelObj);

ResultStatus = false;

end

% Pass the list template object to the Model Advisor

ResultDescription{end+1} = ft;

% Set overall check status

mdladvObj.setCheckResultStatus(ResultStatus);

Model Advisor Code Example: Check With Subchecks and
Actions
Here is an example of a callback function for a custom check that finds and
reports optimization settings. The check consists of two subchecks. The first
reviews the Block reduction optimization setting, and the second reviews
the Conditional input branch execution optimization setting.

A check with subchecks includes the following items in the results:

• A description of what the overall check is reviewing.

• A title for the subcheck.

• A description of what the subcheck is reviewing.

• References to standards, if applicable.

• The status of the subcheck.

• A description of the status.

• Results for the subcheck.

• Recommended actions to take when the subcheck does not pass.

• A line between the subcheck results.

% Sample Check 3 Callback Function: Check with Subchecks and Actions

% Find and report optimization settings

function ResultDescription = OptmizationSettingCallback(system)

% Initialize variables

system =getfullname(system);

mdladvObj = Simulink.ModelAdvisor.getModelAdvisor(system);

mdladvObj.setCheckResultStatus(false); % Default check status is 'Warning'

ResultDescription = {};
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system = bdroot(system);

% Format results in a list using Model Advisor Result Template API

% Create a list template object for first subcheck

ft1 = ModelAdvisor.FormatTemplate('ListTemplate');

% Description of check in results

setCheckText(ft1,['Check model configuration for optimization settings that'...

'can impact safety.']);

% Title and description of first subcheck

setSubTitle(ft1,'Verify Block reduction setting');

setInformation(ft1,'Check whether the ''Block reduction'' check box is cleared.');

% Add See Also section with references to applicable standards

docLinks{1} = {['Reference DO-178B Section 6.3.4e - Source code ' ...

'is traceable to low-level requirements']};

% Review 'Block reduction' optimization

setRefLink(ft1,docLinks);

if strcmp(get_param(system,'BlockReduction'),'off')

% 'Block reduction' is cleared

% Set subresult status to 'Pass' and display text describing the status

setSubResultStatus(ft1,'Pass');

setSubResultStatusText(ft1,'The ''Block reduction'' check box is cleared.');

ResultStatus = true;

else

% 'Block reduction' is selected

% Set subresult status to 'Warning' and display text describing the status

setSubResultStatus(ft1,'Warn');

setSubResultStatusText(ft1,'The ''Block reduction'' check box is selected.');

setRecAction(ft1,['Clear the ''Optimization > Block reduction''' ...

' check box in the Configuration Parameters dialog box.']);

ResultStatus = false;

end

ResultDescription{end+1} = ft1;

% Title and description of second subcheck

ft2 = ModelAdvisor.FormatTemplate('ListTemplate');

setSubTitle(ft2,'Verify Conditional input branch execution setting');

setInformation(ft2,['Check whether the ''Conditional input branch execution'''...
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' check box is cleared.'])

% Add See Also section and references to applicable standards

docLinks{1} = {['Reference DO-178B Section 6.4.4.2 - Test coverage ' ...

'of software structure is achieved']};

setRefLink(ft2,docLinks);

% Last subcheck, supress line

setSubBar(ft2,false);

% Check status of the 'Conditional input branch execution' check box

if strcmp(get_param(system,'ConditionallyExecuteInputs'),'off')

% The 'Conditional input branch execution' check box is cleared

% Set subresult status to 'Pass' and display text describing the status

setSubResultStatus(ft2,'Pass');

setSubResultStatusText(ft2,['The ''Conditional input branch execution''' ...

'check box is cleared.']);

else

% 'Conditional input branch execution' is selected

% Set subresult status to 'Warning' and display text describing the status

setSubResultStatus(ft2,'Warn');

setSubResultStatusText(ft2,['The ''Conditional input branch execution'''...

' check box is selected.']);

setRecAction(ft2,['Clear the ''Optimization > Conditional input branch ' ...

'execution'' check box in the Configuration Parameters dialog box.']);

ResultStatus = false;

end

ResultDescription{end+1} = ft2; % Pass list template object to Model Advisor

mdladvObj.setCheckResultStatus(ResultStatus); % Set overall check status

% Enable Modify Settings button when check fails

mdladvObj.setActionEnable(~ResultStatus);

Detailed Check Callback Function
Use the detailed check callback function to return and organize results as
strings in a layered, hierarchical fashion. The function provides two output
arguments so you can associate text descriptions with one or more paragraphs
of detailed information. The keyword for the detailed callback function is
StyleTwo. The check definition requires this keyword (see “Defining Custom
Checks” on page 27-23).
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The detailed callback function takes the following arguments.

Argument I/O Type Description

system Input Path to the model or system
analyzed by the Model Advisor.

ResultDescription Output Cell array of MATLAB strings
that supports Model Advisor
Formatting API calls or embedded
HTML tags for text formatting.
The Model Advisor concatenates
the ResultDescription string
with the corresponding array of
ResultDetails strings.

ResultDetails Output Cell array of cell arrays, each of
which contains one or more strings.

Note The ResultDetails cell array must be the same length as the
ResultDescription cell array.

Here is an example of a detailed check callback function that checks
optimization settings for simulation and code generation.

function [ResultDescription, ResultDetails] = SampleStyleTwoCallback(system)

ResultDescription ={};

ResultDetails ={};

model = bdroot(system);

mdladvObj = Simulink.ModelAdvisor.getModelAdvisor(system); % get object

mdladvObj.setCheckResultStatus(true); % init result status to pass

% Check Simulation optimization setting

ResultDescription{end+1} = ModelAdvisor.Paragraph(['Check Simulation '...

'optimization settings:']);

if strcmp(get_param(model,'BlockReduction'),'off');

ResultDetails{end+1} = {ModelAdvisor.Text(['It is recommended to '...

'turn on Block reduction optimization option.',{'italic'}])};
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mdladvObj.setCheckResultStatus(false); % set to fail

mdladvObj.setActionEnable(true);

else

ResultDetails{end+1} = {ModelAdvisor.Text('Passed',{'pass'})};

end

% Check code generation optimization setting

ResultDescription{end+1} = ModelAdvisor.Paragraph(['Check code generation '...

'optimization settings:']);

ResultDetails{end+1} = {};

if strcmp(get_param(model,'LocalBlockOutputs'),'off');

ResultDetails{end}{end+1} = ModelAdvisor.Text(['It is recommended to'...

' turn on Enable local block outputs option.',{'italic'}]);

ResultDetails{end}{end+1} = ModelAdvisor.LineBreak;

mdladvObj.setCheckResultStatus(false); % set to fail

mdladvObj.setActionEnable(true);

end

if strcmp(get_param(model,'BufferReuse'),'off');

ResultDetails{end}{end+1} = ModelAdvisor.Text(['It is recommended to'...

' turn on Reuse block outputs option.',{'italic'}]);

mdladvObj.setCheckResultStatus(false); % set to fail

mdladvObj.setActionEnable(true);

end

if isempty(ResultDetails{end})

ResultDetails{end}{end+1} = ModelAdvisor.Text('Passed',{'pass'});

end

Check Callback Function with Hyperlinked Results
This callback function automatically displays hyperlinks for every object
returned by the check so that you can easily locate problem areas in your
model or subsystem. The keyword for this type of callback function is
StyleThree. The check definition requires this keyword (see “Defining
Custom Checks” on page 27-23).

This callback function takes the following arguments.
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Argument I/O Type Description

system Input Path to the model or system
analyzed by the Model Advisor.

ResultDescription Output Cell array of MATLAB strings
that supports the Model Advisor
Formatting API calls or embedded
HTML tags for text formatting.

ResultDetails Output Cell array of cell arrays, each
of which contains one or more
Simulink objects such as blocks,
ports, lines, and Stateflow charts.
The objects must be in the form of a
handle or Simulink path.

Note The ResultDetails cell array must be the same length as the
ResultDescription cell array.

The Model Advisor automatically concatenates each string from
ResultDescription with the corresponding array of objects from
ResultDetails. The Model Advisor displays the contents of ResultDetails
as a set of hyperlinks, one for each object returned in the cell arrays. When
you click a hyperlink, the Model Advisor displays the target object highlighted
in your Simulink model.

The following is an example of a check callback function with hyperlinked
results. This example checks a model for consistent use of font type and font
size in its blocks. It also contains input parameters, actions, and a call to the
Model Advisor Result Explorer, which are described in later sections.

function [ResultDescription, ResultDetails] = SampleStyleThreeCallback(system)

ResultDescription ={};

ResultDetails ={};

mdladvObj = Simulink.ModelAdvisor.getModelAdvisor(system);

mdladvObj.setCheckResultStatus(true);

needEnableAction = false;
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% get input parameters

inputParams = mdladvObj.getInputParameters;

skipFontCheck = inputParams{1}.Value;

regularFontSize = inputParams{2}.Value;

regularFontName = inputParams{3}.Value;

if skipFontCheck

ResultDescription{end+1} = ModelAdvisor.Paragraph('Skipped.');

ResultDetails{end+1} = {};

return

end

regularFontSize = str2double(regularFontSize);

if regularFontSize<1 || regularFontSize>=99

mdladvObj.setCheckResultStatus(false);

ResultDescription{end+1} = ModelAdvisor.Paragraph(['Invalid font size. '...

'Please enter a value between 1 and 99']);

ResultDetails{end+1} = {};

end

% find all blocks inside current system

allBlks = find_system(system);

% block diagram doesn't have font property

% get blocks inside current system that have font property

allBlks = setdiff(allBlks, {system});

% find regular font name blocks

regularBlks = find_system(allBlks,'FontName',regularFontName);

% look for different font blocks in the system

searchResult = setdiff(allBlks, regularBlks);

if ~isempty(searchResult)

ResultDescription{end+1} = ModelAdvisor.Paragraph(['It is recommended to '...

'use same font for blocks to ensure uniform appearance of model. '...

'The following blocks use a font other than ' regularFontName ': ']);

ResultDetails{end+1} = searchResult;

mdladvObj.setCheckResultStatus(false);

myLVParam = ModelAdvisor.ListViewParameter;

myLVParam.Name = 'Invalid font blocks'; % pull down filter name

myLVParam.Data = get_param(searchResult,'object')';

myLVParam.Attributes = {'FontName'}; % name is default property
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mdladvObj.setListViewParameters({myLVParam});

needEnableAction = true;

else

ResultDescription{end+1} = ModelAdvisor.Paragraph(['All block font names '...

'are identical.']);

ResultDetails{end+1} = {};

end

% find regular font size blocks

regularBlks = find_system(allBlks,'FontSize',regularFontSize);

% look for different font size blocks in the system

searchResult = setdiff(allBlks, regularBlks);

if ~isempty(searchResult)

ResultDescription{end+1} = ModelAdvisor.Paragraph(['It is recommended to '...

'use same font size for blocks to ensure uniform appearance of model. '...

'The following blocks use a font size other than ' ...

num2str(regularFontSize) ': ']);

ResultDetails{end+1} = searchResult;

mdladvObj.setCheckResultStatus(false);

myLVParam = ModelAdvisor.ListViewParameter;

myLVParam.Name = 'Invalid font size blocks'; % pull down filter name

myLVParam.Data = get_param(searchResult,'object')';

myLVParam.Attributes = {'FontSize'}; % name is default property

mdladvObj.setListViewParameters...

({mdladvObj.getListViewParameters{:}, myLVParam});

needEnableAction = true;

else

ResultDescription{end+1} = ModelAdvisor.Paragraph(['All block font sizes '...

'are identical.']);

ResultDetails{end+1} = {};

end

mdladvObj.setActionEnable(needEnableAction);

mdladvObj.setCheckErrorSeverity(1);

In the Model Advisor, if you run Example task with input parameter
and auto-fix ability for the slvnvdemo_mdladv model, you can view the
hyperlinked results. Clicking the first hyperlink, slvnvdemo_mdladv/Input,
displays the Simulink model with the Input block highlighted.
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Action Callback Function
An action callback function specifies the actions that the Model Advisor
performs on a model or subsystem when the user clicks the action button. You
must create one callback function for the action that you want to take.

The action callback function takes the following arguments.

Argument I/O Type Description

taskobj Input The ModelAdvisor.Task object for the check
that includes an action definition.

result Output MATLAB string that supports Model Advisor
Formatting API calls or embedded HTML tags
for text formatting.

Model Advisor Code Example: Action Callback Function
The following is an example of an action callback function that fixes the
optimization settings that the Model Advisor reviews as defined in “Model
Advisor Code Example: Check With Subchecks and Actions” on page 27-41.

% Sample Check 3 Action Callback Function: Check with Subresults and Actions

% Fix optimization settings

function result = modifyOptmizationSetting(taskobj)

% Initialize variables

result = ModelAdvisor.Paragraph();

mdladvObj = taskobj.MAObj;

system = bdroot(mdladvObj.System);

% 'Block reduction' is selected

% Clear the check box and display text describing the change

if ~strcmp(get_param(system,'BlockReduction'),'off')

set_param(system,'BlockReduction','off');

result.addItem(ModelAdvisor.Text( ...

'Cleared the ''Block reduction'' check box.',{'Pass'}));

result.addItem(ModelAdvisor.LineBreak);

end

% 'Conditional input branch execution' is selected

% Clear the check box and display text describing the change

if ~strcmp(get_param(system,'ConditionallyExecuteInputs'),'off')
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set_param(system,'ConditionallyExecuteInputs','off');

result.addItem(ModelAdvisor.Text( ...

'Cleared the ''Conditional input branch execution'' check box.', ...

{'Pass'}));

end

For an example of an action callback function that updates all of the blocks in
the model with the font specified in the Input Parameter defined in “Model
Advisor Code Example: Input Parameter Definition” on page 27-29, review
the customization source code in slvnvdemo_mdladv.

Formatting Model Advisor Results

• “Overview of Displaying Results” on page 27-50

• “Formatting Model Advisor Results” on page 27-51

• “Formatting Text” on page 27-51

• “Formatting Lists” on page 27-52

• “Formatting Tables” on page 27-52

• “Formatting Paragraphs” on page 27-53

• “Model Advisor Code Example: Formatted Output” on page 27-53

Overview of Displaying Results
You can make all of the analysis results of your custom checks
appear similar to each other with minimal scripting using the
Model Advisor ModelAdvisor.FormatTemplate class, as described in
ModelAdvisor.FormatTemplate. For examples of callback functions using the
ModelAdvisor.FormatTemplate class, see “Simple Check Callback Function”
on page 27-35.

If this format template does not meet your needs, or if you want to format
action results, use the Model Advisor Formatting API, as described in the
following sections.
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Formatting Model Advisor Results
Use the Model Advisor Formatting API to produce formatted outputs in the
Model Advisor. The following constructors of the ModelAdvisor class provide
the ability to format the output. For more information on each constructor
and associated methods, in the Constructor column, click the link.

Constructor Description

ModelAdvisor.Text Formats element text.

ModelAdvisor.Paragraph Combines elements into paragraphs.

ModelAdvisor.List Creates a list of elements.

ModelAdvisor.LineBreak Adds a line break between elements.

ModelAdvisor.Table Creates a table.

ModelAdvisor.Image Adds an image to the output.

Formatting Text
Text is the simplest form of output. You can format text in many different
ways. The default text formatting is:

• Empty

• Default color (black)

• Unformatted (not bold, italicized, underlined, linked, subscripted, or
superscripted)

To change text formatting, use the ModelAdvisor.Text constructor. When
you want one type of formatting for all text, use this syntax:

ModelAdvisor.Text(content, {attributes})

When you want multiple types of formatting, you must build the text.

t1 = ModelAdvisor.Text('It is ');

t2 = ModelAdvisor.Text('recommended', {'italic'});

t3 = ModelAdvisor.Text(' to use same font for ');

t4 = ModelAdvisor.Text('blocks', {'bold'});

t5 = ModelAdvisor.Text(' to ensure uniform appearance of model.');
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result = [t1, t2, t3, t4, t5];

Add ASCII and Extended ASCII characters using the MATLAB char
command. For more information, see the ModelAdvisor.Text class page.

Formatting Lists
You can create two types of lists: numbered and bulleted. The default list
formatting is bulleted. Use the ModelAdvisor.List constructor to create and
format lists (see ModelAdvisor.List). You can create lists with indented
subsections, formatted as either numbered or bulleted.

subList = ModelAdvisor.List();

subList.setType('numbered')

subList.addItem(ModelAdvisor.Text('Sub entry 1', {'pass','bold'}));

subList.addItem(ModelAdvisor.Text('Sub entry 2', {'pass','bold'}));

topList = ModelAdvisor.List();

topList.addItem([ModelAdvisor.Text('Entry level 1',{'keyword','bold'}), subList]);

topList.addItem([ModelAdvisor.Text('Entry level 2',{'keyword','bold'}), subList]);

Formatting Tables
The default table formatting is:

• Default color (black)

• Left justified

• Bold title, row, and column headings

Change table formatting using the ModelAdvisor.Table constructor. The
following example code creates a subtable within a table.

table1 = ModelAdvisor.Table(1,1);

table2 = ModelAdvisor.Table(2,3);

table2.setHeading('Table 2');

table2.setHeadingAlign('center');

table2.setColHeading(1, 'Header 1');

table2.setColHeading(2, 'Header 2');

table2.setColHeading(3, 'Header 3');
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table1.setHeading('Table 1');

table1.setEntry(1,1,table2);

Formatting Paragraphs
You must handle paragraphs explicitly because most markup languages do
not support line breaks. The default paragraph formatting is:

• Empty

• Default color (black)

• Unformatted, (not bold, italicized, underlined, linked, subscripted, or
superscripted)

• Aligned left

If you want to change paragraph formatting, use the ModelAdvisor.Paragraph
class.

Model Advisor Code Example: Formatted Output
The following is the example from “Simple Check Callback Function” on page
27-35, reformatted using the Model Advisor Formatting API.

function result = SampleStyleOneCallback(system)

mdladvObj = Simulink.ModelAdvisor.getModelAdvisor(system);

if strcmp(get_param(bdroot(system), 'ScreenColor'),'white')

result = ModelAdvisor.Text('Passed',{'pass'});

mdladvObj.setCheckResultStatus(true);

else

msg1 = ModelAdvisor.Text(...

['It is recommended to select a Simulink window screen color'...
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' of white to ensure a readable and printable model. Click ']);

msg2 = ModelAdvisor.Text('here');

msg2.setHyperlink('matlab: set_param(bdroot,''ScreenColor'',''white'')');

msg3 = ModelAdvisor.Text(' to change screen color to white.');

result = [msg1, msg2, msg3];

mdladvObj.setCheckResultStatus(false);

end
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Overview of Creating Custom Configurations

In this section...

“About Creating Custom Configurations” on page 28-2

“Creating Custom Configurations Workflow” on page 28-2

“Using the Model Advisor Configuration Editor Versus Customization File”
on page 28-3

About Creating Custom Configurations
The Simulink Verification and Validation product allows you to extend the
capabilities of the Model Advisor. Using Model Advisor APIs and the Model
Advisor Configuration Editor, you can:

• Customize the behavior of the Model Advisor by defining your own custom
checks, and writing your own callback functions.

• Organize checks and folders to create custom Model Advisor configurations.

• Create multiple custom configurations that you use for different projects
or modeling guidelines, and switch between these configurations in the
Model Advisor.

Creating Custom Configurations Workflow
When you create custom configurations, you:

1 Optionally author custom checks, as described in Chapter 27, “Authoring
Custom Checks”.

2 Identify which MathWorks checks you want to include in your custom
Model Advisor configuration.

3 Organize checks and folders to create custom configurations. You can
create custom configurations either using the Model Advisor Configuration
Editor (see “Organizing Checks and Folders Using the Model Advisor
Configuration Editor” on page 28-4), or within a customization file (see
“Organizing Checks and Folders Within a Customization File” on page
28-13).
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4 Verify the custom configuration, as described in “Verifying and Using
Custom Configurations” on page 28-23.

Using the Model Advisor Configuration Editor Versus
Customization File
The Model Advisor Configuration Editor is a GUI that expedites creating
and deploying custom configurations. While you can organize Model Advisor
configurations in a customization file, MathWorks recommends that you
create custom configurations using the Model Advisor Configuration Editor.
For more details, see “Organizing Checks and Folders Using the Model
Advisor Configuration Editor” on page 28-4.
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Organizing Checks and Folders Using the Model Advisor
Configuration Editor

In this section...

“Overview of the Model Advisor Configuration Editor” on page 28-4

“Starting the Model Advisor Configuration Editor” on page 28-10

“How To Organize Checks and Folders Using the Model Advisor
Configuration Editor” on page 28-11

Overview of the Model Advisor Configuration Editor
When you start the Model Advisor Configuration Editor, two windows
open; the Model Advisor Configuration Editor and the Model Advisor Check
Browser. The Configuration Editor window consists of two panes: the Model
Advisor Configuration Editor hierarchy and the Workflow. The Model Advisor
Configuration Editor hierarchy lists the checks and folders in the current
configuration. The Workflow on the right shows the common workflow you
use to create a custom configuration.
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Model Advisor Configuration Editor

When you select a folder or check in the Model Advisor Configuration Editor
hierarchy, the Workflow pane changes to display information about the check
or folder. You can change the display name of the check or folder in this pane.
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The Model Advisor Check Browser window includes a read-only list of
available checks. If you delete a check in the Model Advisor Configuration
Editor, you can retrieve a copy of it from the Model Advisor Check Browser.
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Tip If you use a process callback function in a sl_customization file to
hide checks and folders, the Model Advisor Configuration Editor and Model
Advisor Check Browser do not display the hidden checks and folders. For a
complete list of checks and folders, remove process callback functions and
update the Simulink environment (see “Updating the Environment to Include
Your sl_customization File” on page 28-23).
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Model Advisor Check Browser

Using the Model Advisor Configuration Editor, you can perform the following
actions.
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To... Select...

Create new configurations File > New

Find checks and folders in the Model Advisor
Check Browser

View > Check Browser

Add checks and folders to the configuration Edit > Copy
Edit > Paste
Edit > New folder
The check or folder and drag and drop

Remove checks and folders from the
configuration

Edit > Delete
Edit > Cut

Reorder checks and folders Edit > Move up
Edit > Move down
The check or folder and drag and drop

Rename checks and folders

Note The MathWorks folder display names
are restricted. When you rename a folder, you
cannot use the restricted display names.

The check or folder and edit Display Name
in right pane.

Allow or gray out the check box control for
checks and folders

Tip This capability is equivalent to enabling
checks, described in “Displaying and Enabling
Checks” on page 27-25.

Edit > Enable
Edit > Disable

Save the configuration as a MAT file for use
and distribution

File > Save
File > Save As

Set the configuration so it opens by default in
the Model Advisor

File > Set Current Configuration as
Default

Restore the MathWorks default configuration File > Restore Default Configuration

Load and edit saved configurations File > Open
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Starting the Model Advisor Configuration Editor

Note

• Before starting the Model Advisor Configuration Editor, ensure that the
current folder is writable. If the folder is not writable, you see an error
message when you start the Model Advisor Configuration Editor.

• The Model Advisor Configuration Editor uses the Simulink project (slprj)
folder (for details about storing reports and other relevant information,
see “Model Reference Simulation Targets”) in the current folder. If this
folder does not exist in the current folder, the Model Advisor Configuration
Editor creates it.

1 To include custom checks in the new Model Advisor configuration, update
the Simulink environment to include your sl_customization.m file.
For more information, see “Updating the Environment to Include Your
sl_customization File” on page 28-23.

2 Start the Model Advisor Configuration Editor.

To start the
Model Advisor
Configuration
Editor...

Do this:

Programmatically At the MATLAB command line, enter
Simulink.ModelAdvisor.openConfigUI.
For more information, see the
Simulink.ModelAdvisor function reference
page.

From the Model
Advisor

1 Start the Model Advisor.
2 Select File > Open Configuration Editor.

The Model Advisor Configuration Editor and Model Advisor Check Browser
windows open.
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3 Optionally, to edit an existing configuration in the Model Advisor
Configuration Editor window:

a Select File > Open.

b In the Open dialog box, navigate to the configuration file that you want
to edit.

c Click Open.

How To Organize Checks and Folders Using the
Model Advisor Configuration Editor
The following tutorial steps you through creating a custom configuration.

1 Open the Model Advisor Configuration Editor at the MATLAB command
line by entering Simulink.ModelAdvisor.openConfigUI . For more
options, see “Starting the Model Advisor Configuration Editor” on page
28-10.

2 In the Model Advisor Configuration Editor, in the left pane, delete the By
Product and By Task folders, to start with a blank configuration.

3 Select the root node which is labeled Model Advisor Configuration Editor.

4 In the toolbar, click the New Folder button to create a folder.

5 In the left pane, select the new folder.

6 In the right pane, edit Display Name to rename the folder. For the
purposes of this tutorial, rename the folder to Review Optimizations.

7 In the Model Advisor Check Browser window, in the Find field, enter
optimization to find Simulink > Check optimization settings.

8 Drag and drop Check optimization settings into Review
Optimizations.

9 In the Model Advisor Check Browser window, find Simulink Verification
and Validation > DO-178B Checks > Check safety-related
optimization settings.
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10 Drag and drop Check safety-related optimization settings into
Review Optimizations.

11 In the Model Advisor Configuration Editor window, expand Review
Optimizations.

12 Rename Check optimization settings to Check Simulink
optimization settings.

13 Select File > Save As to save the configuration.

14 Name the configuration optimization_configuration.mat.

15 Close the Model Advisor Configuration Editor window.
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Organizing Checks and Folders Within a Customization
File

In this section...

“Customization File Overview” on page 28-13

“Register Tasks and Folders” on page 28-14

“Defining Custom Tasks” on page 28-16

“Defining Custom Folders” on page 28-19

“Demo and Code Example” on page 28-21

Note While you can organize checks and folders within a customization
file, MathWorks recommends that you use the Model Advisor Configuration
Editor. For more information, see “Using the Model Advisor Configuration
Editor Versus Customization File” on page 28-3.

Customization File Overview
The sl_customization.m file contains a set of functions for registering and
defining custom checks, tasks, and groups. To set up the sl_customization.m
file, follow the guidelines in this table.

Function Description Required or Optional

sl_customization() Registers custom checks,
tasks, folders, and
callbacks with the Simulink
customization manager at
startup (see “Register Checks
and Process Callbacks” on
page 27-18).

Required for all customizations
to the Model Advisor.

One or more check definitions Defines all custom checks (see
“Defining Custom Checks” on
page 27-23).

Required for custom checks
and to add custom checks to
the By Product folder.
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Function Description Required or Optional

One or more task definitions Defines all custom tasks (see
“Defining Custom Tasks” on
page 28-16).

Required to add custom checks
to the Model Advisor, except
when adding the checks to the
By Product folder. Write one
task for each check that you
add to the Model Advisor.

One or more groups Defines all custom groups (see
“Defining Custom Tasks” on
page 28-16).

Required to add custom tasks
to new folders in the Model
Advisor, except when adding
a new subfolder to the By
Product folder. Write one
group definition for each new
folder.

One process callback function Specifies actions that Simulink
performs at startup and
post-execution time (see
“Defining Startup and
Post-Execution Actions Using
Process Callback Functions”
on page 27-20).

Optional.

Register Tasks and Folders

• “Create sl_customization Function” on page 28-14

• “Registering Tasks and Folders” on page 28-15

Create sl_customization Function
To add tasks and folders to the Model Advisor, create the sl_customization.m
file on your MATLAB path. Then create the sl_customization() function in
the sl_customization.m file on your MATLAB path.
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Tip

• You can have more than one sl_customization.m file on your MATLAB
path.

• Do not place an sl_customization.m file that customizes the Model
Advisor in your root MATLAB folder or any of its subfolders, except for
the matlabroot/work folder. Otherwise, the Model Advisor ignores the
customizations that the file specifies.

The sl_customization function accepts one argument, a customization
manager object, as in this example:

function sl_customization(cm)

The customization manager object includes methods for registering custom
checks, tasks, folders, and process callbacks. Use these methods to register
customizations specific to your application, as described in the sections that
follow.

Registering Tasks and Folders
The customization manager provides the following methods for registering
custom tasks and folders:

• addModelAdvisorTaskFcn (@factorygroupDefinitionFcn)

Registers the tasks that you define in factorygroupDefinitionFcn to the
By Task folder of the Model Advisor.

The factorygroupDefinitionFcn argument is a handle to the function
that defines the checks to add to the Model Advisor as instances of the
ModelAdvisor.FactoryGroup class (see “Defining Custom Tasks” on page
28-16).

• addModelAdvisorTaskAdvisorFcn (@taskDefinitionFcn)

Registers the tasks and folders that you define in taskDefinitionFcn
to the folder in the Model Advisor that you specify using the
ModelAdvisor.Root.publish method or the ModelAdvisor.Group class.
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The taskDefinitionFcn argument is a handle to the function that
defines all custom tasks and folders. Simulink adds the checks and
folders to the Model Advisor as instances of the ModelAdvisor.Task or
ModelAdvisor.Group classes (see “Defining Custom Tasks” on page 28-16).

Note The @ sign defines a function handle that MATLAB calls. For more
information, see “At — @” in the MATLAB documentation.

Model Advisor Code Example: Registering Custom Tasks and Folders.
The following code example registers custom tasks and folders:

function sl_customization(cm)

% register custom factory group

cm.addModelAdvisorTaskFcn(@defineModelAdvisorTasks);

% register custom tasks.

cm.addModelAdvisorTaskAdvisorFcn(@defineTaskAdvisor);

Note If you add custom checks and process callbacks within the
sl_customization.m file, include methods for registering the checks and
process callbacks in the sl_customization function. For more information,
see “Register Checks and Process Callbacks” on page 27-18.

Defining Custom Tasks

• “Adding a Check to Custom or Multiple Folders Using Tasks” on page 28-17

• “Creating Custom Tasks Using MathWorks Checks” on page 28-17

• “Displaying and Enabling Tasks” on page 28-18

• “Defining Where Tasks Appear” on page 28-18

• “Model Advisor Code Example: Task Definition Function” on page 28-18
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Adding a Check to Custom or Multiple Folders Using Tasks
You can use custom tasks for adding checks to the Model Advisor, either
in multiple folders or in a single, custom folder. You define custom tasks
in one or more functions that specify the properties of each instance of the
ModelAdvisor.Task class. Define one instance of this class for each custom
task that you want to add to the Model Advisor. Then register the custom
task, as described in “Register Tasks and Folders” on page 28-14. The
following sections describe how to define custom tasks.

To add a check to multiple folders or a single, custom folder:

1 Create a check using the ModelAdvisor.Check class, as described in
“Defining Custom Checks” on page 27-23.

2 Register a task wrapper for the check, as described in “Register Tasks
and Folders” on page 28-14.

3 If you want to add the check to folders that are not already present, register
and create the folders using the ModelAdvisor.Group class.

4 Add a check to the task using the ModelAdvisor.Task.setCheck method.

5 Add the task to each folder using the ModelAdvisor.Group.addTask
method and the task ID.

Creating Custom Tasks Using MathWorks Checks
You can add MathWorks checks to your custom folders by defining the checks
as custom tasks. When you add the checks as custom tasks, you identify
checks by the check ID.

To find MathWorks check IDs:

1 In the Model Advisor, select View > Source Tab.

2 Navigate to the folder that contains the MathWorks check.

3 In the right pane, click Source. The Model Advisor displays the Title,
TitleID, and Source information for each check in the folder.

4 Select and copy the TitleID of the check that you want to add as a task.

28-17



28 Creating Custom Configurations by Organizing Checks and Folders

Displaying and Enabling Tasks
The Visible, Enable, and Value properties interact the same way for tasks
as they do for checks (see “Displaying and Enabling Checks” on page 27-25).

Defining Where Tasks Appear
You can specify where the Model Advisor places tasks within the Model
Advisor using the following guidelines:

• To place a task in a new folder in the Model Advisor Task Manager,
use the ModelAdvisor.Group class. See “Defining Custom Folders” on
page 28-19.

• To place a task in a new folder in the By Task folder, use the
ModelAdvisor.FactoryGroup class. See “Defining Custom Folders” on
page 28-19.

Model Advisor Code Example: Task Definition Function
The following is an example of a task definition function. This function defines
three tasks. The tasks are derived from the checks defined in “Model Advisor
Code Example: Check Definition Function” on page 27-27.

For an example of placing these tasks into a custom group, see “Model Advisor
Code Example: Group Definition” on page 28-20.

% Defines Model Advisor tasks and a custom folder

% Add checks to a custom folder using task definitions

function defineTaskAdvisor

mdladvRoot = ModelAdvisor.Root;

% Define task that uses Sample Check 1: Informational check

MAT1 = ModelAdvisor.Task('mathworks.example.task.configManagement');

MAT1.DisplayName = 'Informational check for model configuration management';

MAT1.Description = 'Display model configuration and checksum information.';

setCheck(MAT1, 'mathworks.example.configManagement');

mdladvRoot.register(MAT1);

% Define task that uses Sample Check 2: Basic Check with Pass/Fail Status

MAT2 = ModelAdvisor.Task('mathworks.example.task.unconnectedObjects');

MAT2.DisplayName = 'Check for unconnected objects';
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setCheck(MAT2, 'mathworks.example.unconnectedObjects');

MAT2.Description = ['Identify unconnected lines, input ports, and output ' ...

'ports in the model or subsystem.'];

mdladvRoot.register(MAT2);

% Define task that uses Sample Check 3: Check with Subresults and Actions

MAT3 = ModelAdvisor.Task('mathworks.example.task.optimizationSettings');

MAT3.DisplayName = 'Check safety-related optimization settings';

MAT3.Description = ['Check model configuration for optimization ' ...

'settings that can impact safety.'];

MAT3.setCheck('mathworks.example.optimizationSettings');

mdladvRoot.register(MAT3);

% Custom folder definition

MAG = ModelAdvisor.Group('mathworks.example.ExampleGroup');

MAG.DisplayName = 'My Group';

% Add tasks to My Group folder

addTask(MAG, MAT1);

addTask(MAG, MAT2);

addTask(MAG, MAT3);

% Add My Group folder to the Model Advisor under 'Model Advisor' (root)

mdladvRoot.publish(MAG);

Defining Custom Folders

• “About Custom Folders” on page 28-19

• “Adding Custom Folders” on page 28-20

• “Defining Where Custom Folders Appear” on page 28-20

• “Model Advisor Code Example: Group Definition” on page 28-20

About Custom Folders
Use folders to group checks in the Model Advisor by functionality or usage.
You define custom folders in:

• A factory group definition function that specifies the properties of each
instance of the ModelAdvisor.FactoryGroup class.
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• A task definition function that specifies the properties of each instance of
the ModelAdvisor.Group class. For more information about task definition
functions, see “Adding a Check to Custom or Multiple Folders Using Tasks”
on page 28-17.

Define one instance of the group classes for each folder that you want to
add to the Model Advisor. Then register the custom folder, as described in
“Register Tasks and Folders” on page 28-14. The following sections describe
how to define custom groups.

Adding Custom Folders
To add a custom folder:

1 Create the folder using the ModelAdvisor.Group or
ModelAdvisor.FactoryGroup classes.

2 Add the folder to the Model Advisor, as described in “Defining Custom
Folders” on page 28-19.

Defining Where Custom Folders Appear
You can specify the location of custom folders within the Model Advisor using
the following guidelines:

• To define a new folder in the Model Advisor Task Manager, use the
ModelAdvisor.Group class.

• To define a new folder in the By Task folder, use the
ModelAdvisor.FactoryGroup class.

Note To define a new folder in the By Product folder, use the
ModelAdvisor.Root.publish method within a custom check. For more
information, see “Defining Where Custom Checks Appear” on page 27-26.

Model Advisor Code Example: Group Definition
The following is an example of a group definition. The definition places the
tasks defined in “Model Advisor Code Example: Task Definition Function” on
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page 28-18 inside a folder called My Group under the Model Advisor root.
The task definition function includes this group definition.

% Custom folder definition

MAG = ModelAdvisor.Group('mathworks.example.ExampleGroup');

MAG.DisplayName='My Group';

% Add tasks to My Group folder

MAG.addTask(MAT1);

MAG.addTask(MAT2);

MAG.addTask(MAT3);

% Add My Group folder to the Model Advisor under 'Model Advisor' (root)

mdladvRoot.publish(MAG);

The following is an example of a factory group definition function. The
definition places the checks defined in “Model Advisor Code Example: Check
Definition Function” on page 27-27 into a folder called Demo Factory Group
inside of the By Task folder.

function defineModelAdvisorTasks

mdladvRoot = ModelAdvisor.Root;

% --- sample factory group

rec = ModelAdvisor.FactoryGroup('com.mathworks.sample.factorygroup');

rec.DisplayName='Demo Factory Group';

rec.Description='Demo Factory Group';

rec.addCheck('mathworks.example.configManagement');

rec.addCheck('mathworks.example.unconnectedObjects');

rec.addCheck('mathworks.example.optimizationSettings');

mdladvRoot.publish(rec); % publish inside By Task

Demo and Code Example
The Simulink Verification and Validation software provides a demo that
shows how to customize the Model Advisor by adding:

• Custom checks

• Check input parameters

• Check actions

• Check list views to call the Model Advisor Result Explorer
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• Custom tasks to include the custom checks in the Model Advisor

• Custom folders for grouping the checks

• A process callback function

The demo also provides the source code of the sl_customization.m file that
executes the customizations.

To run the demo:

1 At the MATLAB command line, type slvnvdemo_mdladv.

2 Follow the instructions in the model.
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Verifying and Using Custom Configurations

In this section...

“Updating the Environment to Include Your sl_customization File” on
page 28-23

“Verifying Custom Configurations” on page 28-23

Updating the Environment to Include Your
sl_customization File
When you start Simulink, it reads customization (sl_customization.m)
files. If you change the contents of your customization file, update your
environment by performing these tasks:

1 If you previously started the Model Advisor:

a Close the model from which you started the Model Advisor

b Clear the data associated with the previous Model Advisor session by
removing the slprj folder from your working folder.

2 At the MATLAB command line, enter:

sl_refresh_customizations

3 Open your model.

4 Start the Model Advisor.

Verifying Custom Configurations
To verify a custom configuration:

1 If you created custom checks, or created the custom configuration using
the sl_customization method, update the Simulink environment.
For more information, see “Updating the Environment to Include Your
sl_customization File” on page 28-23.

2 Open a model.

3 From the model window, start the Model Advisor.
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4 Select File > Load Configuration. If you see a warning that the Model
Advisor report corresponds to a different configuration, click Load to
continue.

5 In the Open dialog box, navigate to and select your custom configuration.
For example, if you created the custom configuration in “How To Organize
Checks and Folders Using the Model Advisor Configuration Editor” on page
28-11, select optimization_configuration.mat.

6 When the Model Advisor reopens, verify that the new configuration
contains the appropriate folders and checks. For example, the Review
Optimizations folder and the Check Simulink optimization settings
and Check safety-related optimization settings checks.

7 Optionally, run the checks.
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Overview of Deploying Custom Configurations

In this section...

“About Deploying Custom Configurations” on page 29-2

“Deploying Custom Configurations Workflow” on page 29-2

About Deploying Custom Configurations
When you create a custom configuration, often you deploy the custom
configuration to your development group. Deploying the custom configuration
allows your development group to review models using the same checks.

After you create a custom configuration, you can use it in the Model
Advisor, or deploy the configuration to your users. You can deploy custom
configurations whether you created the configuration using the Model Advisor
Configuration Editor or within the customization file.

Deploying Custom Configurations Workflow
When you deploy custom configurations, you:

1 Optionally author custom checks, as described in Chapter 27, “Authoring
Custom Checks”.

2 Organize checks and folders to create custom configurations, as described
in Chapter 28, “Creating Custom Configurations by Organizing Checks
and Folders”.

3 Deploy the custom configuration to your users, as described in “How to
Deploy Custom Configurations” on page 29-3.
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How to Deploy Custom Configurations
To deploy a custom configuration:

1 Determine which files to distribute. You might need to distribute more
than one file.

If You... Using the... Distribute...

Created custom checks Customization file • sl_customization.m

• Files containing
check and action
callback functions
(if separate)

Model Advisor
Configuration Editor

Configuration MAT
file

Organized checks and
folders

Customization file sl_customization.m

2 Distribute the files and tell the user to include these files on the MATLAB
path.

3 Instruct the user to load the custom configuration. For more details, see
“Manually Loading and Setting the Default Configuration” on page 29-4 or
“Automatically Loading and Setting the Default Configuration” on page
29-5.
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Manually Loading and Setting the Default Configuration
When you use the Model Advisor, you can load any configuration. Once
you load a configuration, you can set it so that the Model Advisor use that
configuration every time you open the Model Advisor.

1 Open the Model Advisor.

2 Select File > Load Configuration.

3 In the Open dialog box, navigate to and select the configuration file that
you want to edit.

4 Click Open.

Simulink reloads the Model Advisor using the new configuration.

5 Optionally, when the Model Advisor opens, set the current configuration as
the default by selecting File > Set Current Configuration as Default.
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Automatically Loading and Setting the Default
Configuration

When you use the Model Advisor, you can automatically set the default
configuration by modifying an sl_customization.m file. For more
information on creating the sl_customization.m file, see “Register Checks
and Process Callbacks” on page 27-18.

1 Place a configuration MAT file on your MATLAB path. For more
information on MAT files, see “Organizing Checks and Folders Using the
Model Advisor Configuration Editor” on page 28-4

2 Modify your sl_customization.m file by adding the function:

function [checkCellArray taskCellArray] = ModelAdvisorProcessFunction ...

(stage, system, checkCellArray, taskCellArray)

switch stage

case 'configure'

ModelAdvisor.setConfiguration('qeAPIConfigFilePath.mat');

end

In the function, replace qeAPIConfigFilePath.mat with the name of the
configuration MAT file in step 1.

3 The sl_customization.m file is loaded every time you start the Model
Advisor, using qeAPIConfigFilePath.mat as the default configuration.
For more information, see “Updating the Environment to Include Your
sl_customization File” on page 28-23.

Tip You can restore the MathWorks default configuration by selecting
File > Restore Default Configuration.
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A Examples

Requirements Management Interface
“Example: Linking to Requirements in Microsoft Word Documents” on
page 3-4
“Opening the Demo Model and Associated Requirements Document” on
page 3-4
“Creating a Link from a Model Object to a Microsoft Word Requirements
Document” on page 3-4
“Example: Linking to Requirements in IBM Rational DOORS Databases”
on page 3-10
“Creating Requirements Reports” on page 3-13
“Tutorial: Managing Requirements Links to Microsoft® Excel Workbooks”
on page 4-6
“Tutorial: Creating Links to MuPAD Notebooks” on page 4-11
“Tutorial: Linking Signal Builder Blocks to Requirements” on page 4-13
“Highlighting Requirements in a Model” on page 5-2
“Navigating to Requirements from a Model” on page 5-5
“Creating a Default Requirements Report” on page 5-7
“Customizing a Requirements Report Using the RMI Settings” on page 5-17
“Applying a User Tag to a Requirement” on page 5-23
“Filtering, Highlighting, and Reporting with User Tags” on page 5-25
“Applying User Tags During Selection-Based Linking” on page 5-27
“Checking and Fixing Requirements Links in a Simulink Model” on page
6-2
“Fixing Inconsistent Links” on page 6-5
“Deleting a Single Link from a Simulink Object” on page 6-16
“Deleting All Links from a Simulink Object” on page 6-16
“Deleting All Links from Multiple Simulink Objects” on page 6-17
“Managing Requirements in Library Blocks and Reference Blocks” on page
6-18
“Enabling Linking from Microsoft Office Documents to Simulink Models”
on page 9-3
“Inserting Navigation Controls in Microsoft Office Requirements
Documents” on page 9-5
“Navigating Between a Microsoft Word Requirement and a Model” on
page 9-9
“Troubleshooting Simulink Navigation Controls in Microsoft Office 2007”
on page 9-10
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Requirements Management Interface (DOORS Version)

“Creating a Custom Link Requirement Type” on page 10-7
Chapter 12, “Including Requirements Information with Generated Code”

Requirements Management Interface (DOORS Version)
“Tutorial: Synchronizing a Simulink Model to Create a Surrogate Module”
on page 7-5
“Tutorial: Creating Links Between the Surrogate Module and Formal
Module in a DOORS Database During Synchronization” on page 7-7
“Tutorial: Resynchronizing to Include All Simulink Objects” on page 7-13
“Tutorial: Resychronizing to Reflect Model Changes” on page 7-17
“Navigating with the Surrogate Module” on page 7-19
“Navigating Between Requirements and the Surrogate Module in the
DOORS Database” on page 7-19
“Navigation Between DOORS Requirements and the Simulink Module via
the Surrogate Module” on page 7-20
“Navigating from a Simulink Object to a Requirement via the Surrogate
Module” on page 7-20
“Navigating from a Requirement to the Model via the Surrogate Module”
on page 7-21
“Configuring the Requirements Management Interface for DOORS
Software” on page 8-3
“Enabling Linking Between DOORS Databases and Simulink Models”
on page 8-5
“Inserting Navigation Objects into DOORS Requirements” on page 8-7
“Navigating Between a DOORS Requirement and a Model Object” on page
8-11

Model Coverage
“Creating and Running Test Cases” on page 16-3
“Enabling Coverage Highlighting” on page 16-6
“Examples: Model Coverage Coloring” on page 16-6
“Examples: Model Coverage for MATLAB Functions” on page 16-23
“Coverage Summary” on page 17-3
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“Details” on page 17-5
“Cyclomatic Complexity” on page 17-14
“Decisions Analyzed” on page 17-16
“Conditions Analyzed” on page 17-18
“MCDC Analysis” on page 17-18
“Cumulative Coverage” on page 17-20
“N-Dimensional Lookup Table” on page 17-22
“Block Reduction” on page 17-29
“Signal Range Analysis” on page 17-31
“Signal Size Coverage for Variable-Dimension Signals” on page 17-33
“Simulink® Design Verifier Coverage” on page 17-35
“External MATLAB File Coverage Reports” on page 17-39
“Subsystem Coverage Reports” on page 17-44
“Example: Creating Coverage Filter Rules for a Simulink Model” on page
18-13
“Coverage Script Example” on page 19-11

Component Verification
Chapter 21, “Example: Verifying a Component for Code Generation”

Verification Manager
“Example: Using the Check Static Lower Bound Block to Check for
Out-of-Bounds Signal” on page 22-3
“Opening the Verification Manager” on page 23-3
“Enabling and Disabling Model Verification Blocks Using the Verification
Manager” on page 23-9
“Using Enabling and Disabling Tools in the Verification Manager” on
page 23-12
Chapter 24, “Linking Test Cases to Requirements Documents Using the
Verification Manager”
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Model Advisor Check
“Creating a Function for Checking Multiple Systems” on page 25-5
“Creating a Function for Checking Multiple Systems in Parallel” on page
25-6
“Archiving and Viewing Results Example” on page 25-12
“Adding a Customized Check to the By Product Folder” on page 27-6
“Creating a Customized Pass/Fail Check” on page 27-8
“Creating a Customized Pass/Fail Check with Fix Action” on page 27-12
“Model Advisor Code Example: Registering Custom Checks and Process
Callbacks” on page 27-19
“Model Advisor Code Example: Check Definition Function” on page 27-27
“Model Advisor Code Example: Input Parameter Definition” on page 27-29
“Model Advisor Code Example: List View Definition” on page 27-31
“Model Advisor Code Example: Action Definition” on page 27-32
“Model Advisor Code Example: Informational Check Callback Function” on
page 27-36
“Model Advisor Code Example: Basic Check with Pass/Fail Status” on
page 27-38
“Model Advisor Code Example: Check With Subchecks and Actions” on
page 27-41
“Model Advisor Code Example: Action Callback Function” on page 27-49
“Model Advisor Code Example: Formatted Output” on page 27-53

Model Advisor Organization
“How To Organize Checks and Folders Using the Model Advisor
Configuration Editor” on page 28-11
“Model Advisor Code Example: Registering Custom Tasks and Folders” on
page 28-16
“Model Advisor Code Example: Task Definition Function” on page 28-18
“Model Advisor Code Example: Group Definition” on page 28-20
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IndexSymbols and Numerics
1-D Lookup Table block

model coverage for 14-21
2-D Lookup Table block

model coverage for 14-22

A
Abs block

model coverage for 14-6
ActiveX controls

deleting from Microsoft Excel
documents 9-15

enabling, in the Microsoft Office Trust
Center 9-9

field codes 9-11
RMI use in requirements documents 10-18

11-6
troubleshooting 9-10

atomic subcharts
model coverage for 16-56

B
block reduction

model coverage and 13-10
blocks

filtering from coverage recording 18-19
library linked

coverage 14-19

C
charts

library linked
coverage 14-19

closing Signal Builder Requirements pane 23-7
colored diagram model coverage display

enabling 16-6
Combinatorial Logic block

model coverage for 14-7
component verification

approaches 20-2
common workflow 20-4
example 21-1
functions for 20-9
independently of container model 20-6
Model blocks, in container model 20-7
tools for 20-2

components
verifying. See component verification

condition coverage 16-45
definition 16-45
description 13-5
example 16-53
MATLAB Function blocks 16-34
statements in MATLAB Function

block 16-21
truth tables 16-63

conditional input branch execution
model coverage and 13-11

coverage 13-2
filter rules 18-4
filtering model objects from 18-2
filters 18-4
objects to filter from 18-5
See also model coverage

coverage filter rules
adding rationale to 18-7
creating 18-8
creating new 18-6
editing 18-6
for filtering 18-4
removing from a model 18-10
types 18-6
using Coverage Filter Viewer to

manage 18-11
viewing 18-10

Coverage Filter Viewer
managing coverage filter rules with 18-11
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coverage filtering
library reference blocks 18-18
overview 18-2
Simulink blocks 18-19
Stateflow temporal events 18-16
Stateflow transitions 18-14
subsystems 18-19
typical workflow 18-6
when to use 18-3

coverage filters
attaching to a file 18-9
removing from a model 18-10
rules in 18-4
saving to a file 18-9
viewing 18-10

Coverage Settings dialog box 16-3
accessing 15-2
Coverage tab 15-3
Filter tab 15-18
Options tab 15-15
Reporting tab 15-10
Results tab 15-8

cvhtml function
model coverage 19-8

cvload function
model coverage 19-10

cvsave function
model coverage 19-9

cvsim function
model coverage 19-5

cvtest function
model coverage 19-3

cyclomatic complexity
description 13-4
in model coverage reports 16-41

D
Dead Zone block

model coverage for 14-8

debugging
model coverage 16-40

decision coverage 16-42
chart as a triggered block 16-43
chart containing substates 16-43
conditional transitions 16-45
description 13-5
example 16-53
in model coverage reports 16-42
MATLAB Function blocks 16-34
state with on event_name statement 16-45
statements in MATLAB Function

blocks 16-20
superstates containing substates 16-43
truth tables 16-63

defining Model Advisor checks 27-23
defining Model Advisor folders 28-19
defining Model Advisor tasks 28-16
demos

Model Advisor customization demo 28-21
simcovdemo model coverage demo 16-2

Design Requirements report 5-22
Direct Lookup Table (n-D) block

model coverage for 14-9
disabling Model Verification blocks across test

groups 23-12
Discrete-Time Integrator block

model coverage for 14-10
document index

using Requirements dialog box to display 4-4
DOORS Requirements Management Interface

block type descriptions 7-14
creating links to 3-10
definition for object 7-2
from Simulink to DOORS 7-20
hierarchical numbers 7-14
inserting navigation objects into 8-7
navigating between model and 8-11
object identifiers 7-14
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opening the object in Simulink, Stateflow, or
MATLAB 7-21

overview 8-2
saving formal modules 7-18
synchronizing models with DOORS 7-5
synchronizing objects with DOORS formal

module 7-5
viewing requirements 7-19

DOORS software
installing 8-3
manual installation 8-3

E
Enabled and Triggered Subsystem block

model coverage for 14-13
Enabled Subsystem block

model coverage for 14-12
enabling Model Verification blocks across test

groups 23-12

F
Fcn block

model coverage for 14-15
field codes

requirements in Microsoft Word 9-11
filtering

requirements 5-23
settings for 5-29

For Iterator block
model coverage for 14-16

For Iterator Subsystem block
model coverage for 14-16

formal modules
creating links to surrogate modules during

synchronization 7-7
functions

rmiobjnavigate 11-4

H
highlighting

requirements in a model 5-2

I
icons for Model Verification blocks in Verification

Manager 23-9
If block

model coverage for 14-17
If Subsystem block

model coverage for 14-17
inlined parameters

model coverage and 13-10
instances

of library blocks 6-18
Interpolation Using Prelookup block

model coverage for 14-18

L
library blocks

filtering from coverage recording 18-18
requirements links to 6-25
with requirements, copying 6-19

linked libraries
requirements in 6-18

linking
between DOORS and Simulink 8-5
customizing navigation objects and controls

for 8-9 9-7
enabling from Microsoft® Office

documents 9-3
Logical Operator block

model coverage for 14-20
Lookup Table block

in model coverage report 17-22
model coverage

n-dimensional 17-28
three-dimensional example 17-26
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two-dimensional example 17-22
lookup table coverage

description 13-7

M
MATLAB Function block

condition coverage 16-34
condition coverage statements 16-21
decision coverage 16-34
decision coverage statements 16-20
MCDC coverage 16-34
MCDC coverage statements 16-21
model coverage examples 16-23
model coverage for 14-24
model coverage for Simulink Design Verifier

functions 14-33 16-21
types of model coverage 16-20

MATLAB functions
model coverage 16-20
model coverage reports 17-11
Simulink Design Verifier coverage for 13-8

MCDC coverage
definition 16-46
description 13-5
example 16-53
explanation 16-55
irrelevant conditions 16-56
MATLAB Function blocks 16-34
specifying 16-41
statements in MATLAB Function

blocks 16-21
truth tables 16-64

MCDC table
condition cases 17-19

Microsoft Excel
deleting ActiveX controls from 9-15

Microsoft Office Trust Center
enabling ActiveX controls 9-9

Microsoft Word

linking to requirements in 3-4
requirements documents, linking to 3-4
troubleshooting ActiveX controls 9-10

MinMax block
model coverage for 14-25

model
synchronizing to DOORS surrogate

module 7-2
Model Advisor

requirements consistency checks 6-2
Model Advisor customizations

creating check callback functions 27-34
defining custom checks 27-23
defining custom folders 28-19
defining custom tasks 28-16
defining process callback functions 27-20
formatting Model Advisor results 27-50
registering custom checks 27-18
registering custom tasks and folders 28-14
slvnvdemo_mdladv demo 28-21
workflow overview 26-4

Model block
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coverage for multiple instances 16-11

model coverage 16-40
1-D Lookup Table block 14-21
2-D Lookup Table block 14-22
Abs block 14-6
analyzing model execution 13-3
atomic subcharts 16-56
block reduction 17-29
block reduction effect on 13-10
chart as subsystem report section 16-48
colored chart example 16-65
colored Simulink diagram display 16-6
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condition coverage 13-5 16-45
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conditional input branch execution effect
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conditions analyzed table 17-18
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cumulative coverage 17-20
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decision coverage 13-5 16-42
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Direct Lookup Table (n-D) block 14-9
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display 16-6
Fcn block 14-15
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generate HTML report 16-41
HTML settings 15-11
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inlined parameters and 13-10
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introduction 13-2
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16-21
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